aboutsummaryrefslogtreecommitdiff
path: root/misc/mbuffer
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-29 12:18:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-03-30 23:59:51 +0000
commit56932296b7bc5c29380a4c433c5a9250fb6b4fb5 (patch)
treefcadc9b2e2c571e2e78fbc91681b07e0cbcbb676 /misc/mbuffer
parent450bb37cf300a850f3c5825bbe79860558cbe3f7 (diff)
downloadports-56932296b7bc5c29380a4c433c5a9250fb6b4fb5.tar.gz
ports-56932296b7bc5c29380a4c433c5a9250fb6b4fb5.zip
*/*: Sunset 12.3-RELEASE from ports tree12.3-eol
- Mk/bsd.port.mk: mark FreeBSD 12.3 as unsupported. - Mk/Uses/cabal.mk: Remove the text-2 workaround for 12.3-RELEASE - biology/wfa2-lib: remove obsolete patch - databases/mongodb60: remove IGNORE for EOL FreeBSD 12.3 - devel/concurrencpp: remove workaround for EOL FreeBSD 12.3 - devel/electron22: remove IGNORE for EOL FreeBSD 12.3 - devel/malloy: this should build fine on 12.4-RELEASE - devel/qcoro: remove BROKEN for EOL FreeBSD 12.3 - devel/root: remove workaround for EOL FreeBSD 12.3 - editors/imhex: remove IGNORE for EOL FreeBSD 12.3 - emulators/ppsspp: remove workaround for EOL FreeBSD 12.3 - emulators/rpcs3: remove workaround for EOL FreeBSD 12.3 - emulators/yuzu: remove workaround for EOL 12.3-RELEASE - games/aquaria: remove support for EOL FreeBSD 12.3 - games/punchy: remove workaround for EOL FreeBSD 12.3 - graphics/cxxplot: remove support for EOL FreeBSD 12.3 - lang/gcc11*: bump a __FreeBSD_version in libphobos to 1204000 - lang/rust: untangle OSVERSION logic a bit - misc/mbuffer: remove workaround for EOL FreeBSD 12.3 for aarch64 - sysutils/libdisplay-info: remove workaround for EOL FreeBSD 12.3 - www/*chromium: remove IGNORE for EOL FreeBSD 12.3 - x11/hyprpaper: remove workaround for expired FreeBSD 12.3 - x11-wm/labwc: remove workaround for EOL FreeBSD 12.3 - x11-wm/kwinft: remove workaround for EOL FreeBSD 12.3 - www/iridium: remove IGNORE for EOL FreeBSD 12.3 Differential Revision: https://reviews.freebsd.org/D38664
Diffstat (limited to 'misc/mbuffer')
-rw-r--r--misc/mbuffer/Makefile8
-rw-r--r--misc/mbuffer/files/extra-patch-12.361
2 files changed, 1 insertions, 68 deletions
diff --git a/misc/mbuffer/Makefile b/misc/mbuffer/Makefile
index 3d273d6ed966..ff429838b6fa 100644
--- a/misc/mbuffer/Makefile
+++ b/misc/mbuffer/Makefile
@@ -31,12 +31,6 @@ GCRYPT_RUN_DEPENDS= libgcrypt>=1.8.4_1:security/libgcrypt
MHASH_RUN_DEPENDS= mhash>=0.9.9.9_5:security/mhash
RHASH_RUN_DEPENDS= rhash>=1.3.5:security/rhash
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == aarch64 && ${OSVERSION} < 1300000
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-12.3
-.endif
-
post-patch:
${REINPLACE_CMD} \
-e 's@bash@sh@' ${WRKSRC}/Makefile.in
@@ -46,4 +40,4 @@ post-install:
${MV} ${STAGEDIR}${PREFIX}/etc/mbuffer.rc \
${STAGEDIR}${PREFIX}/etc/mbuffer.rc.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/mbuffer/files/extra-patch-12.3 b/misc/mbuffer/files/extra-patch-12.3
deleted file mode 100644
index c60d49818579..000000000000
--- a/misc/mbuffer/files/extra-patch-12.3
+++ /dev/null
@@ -1,61 +0,0 @@
-- cc(1) crashes with "-g" on FreeBSD 12.3-RELEASE aarch64
-
- cc: error: unable to execute command: Abort trap (core dumped)
- cc: error: clang frontend command failed due to signal (use -v to see invocation)
- FreeBSD clang version 10.0.1 (git@github.com:llvm/llvm-project.git llvmorg-10.0.1-0-gef32c611aa2)
- Target: aarch64-unknown-freebsd12.3
- Thread model: posix
- InstalledDir: /usr/bin
- cc: note: diagnostic msg: PLEASE submit a bug report to https://bugs.freebsd.org/submit/ and include the crash backtrace, preprocessed source, and associated run script.
- cc: note: diagnostic msg:
- ********************
-
- PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
- Preprocessed source(s) and associated run script(s) are located at:
- cc: note: diagnostic msg: /tmp/idev-47a323.c
- cc: note: diagnostic msg: /tmp/idev-47a323.sh
- cc: note: diagnostic msg:
-
- ********************
- gmake[1]: *** [Makefile:197: idev.so] Error 254
- gmake[1]: Leaving directory '/usr/ports/misc/mbuffer/work/mbuffer-20211018'
-
-- llvm-objdump(1) does not support "-T" on FreeBSD 12.3-RELEASE aarch64
-
---- Makefile.in.orig 2022-05-14 11:38:27 UTC
-+++ Makefile.in
-@@ -194,7 +194,7 @@ tapetest.so: tapetest.c config.h
- $(CC) $(CFLAGS) -shared -fPIC tapetest.c -o $@ $(LIBS)
-
- idev.so: idev.c config.h
-- $(CC) $(CFLAGS) -shared -g -fPIC idev.c -o $@ $(LIBS)
-+ $(CC) $(CFLAGS) -shared -fPIC idev.c -o $@ $(LIBS)
-
- $(DEPS): | build
-
---- configure.in.orig 2022-05-14 11:37:04 UTC
-+++ configure.in
-@@ -173,19 +173,19 @@ else
- ]])],[
- AC_MSG_RESULT([OK])
- AC_MSG_CHECKING([name of open() in C library])
-- libc_open=`$OBJDUMP -T conftest | $AWK '/\*UND\*/ && $NF ~ /^open/ { print $NF }'`
-+ libc_open=`$OBJDUMP -t conftest | $AWK '/\*UND\*/ && $NF ~ /^open/ { print $NF }'`
- AC_DEFINE_UNQUOTED([LIBC_OPEN], $libc_open, [name of open() in libc])
- AC_MSG_RESULT($libc_open)
- AC_MSG_CHECKING([name of read() in C library])
-- libc_read=`$OBJDUMP -T conftest | $AWK '/\*UND\*/ && $NF ~ /^read/ { print $NF }'`
-+ libc_read=`$OBJDUMP -t conftest | $AWK '/\*UND\*/ && $NF ~ /^read/ { print $NF }'`
- AC_DEFINE_UNQUOTED([LIBC_READ], $libc_read, [name of write() in libc])
- AC_MSG_RESULT($libc_read)
- AC_MSG_CHECKING([name of write() in C library])
-- libc_write=`$OBJDUMP -T conftest | $AWK '/\*UND\*/ && $NF ~ /^write/ { print $NF }'`
-+ libc_write=`$OBJDUMP -t conftest | $AWK '/\*UND\*/ && $NF ~ /^write/ { print $NF }'`
- AC_DEFINE_UNQUOTED([LIBC_WRITE], $libc_write, [name of write() in libc])
- AC_MSG_RESULT($libc_write)
- AC_MSG_CHECKING([name of fstat() in C library])
-- libc_fstat=`$OBJDUMP -T conftest | $AWK '/\*UND\*/ && $NF ~ /^_*fstat/ { print $NF }'`
-+ libc_fstat=`$OBJDUMP -t conftest | $AWK '/\*UND\*/ && $NF ~ /^_*fstat/ { print $NF }'`
- AC_DEFINE_UNQUOTED([LIBC_FSTAT], $libc_fstat, [name of fstat() in libc])
- AC_MSG_RESULT($libc_fstat)
- ],