aboutsummaryrefslogtreecommitdiff
path: root/misc/metromap
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-03-07 21:39:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-03-07 21:39:29 +0000
commitaeebb6f9bbb349be9e42bc06c200505880d3718b (patch)
treed10382c0518febbba852ca72c238a63ebf5ac351 /misc/metromap
parent6d5bb1951d38d78e8db3481dd782f74292a6adc7 (diff)
downloadports-aeebb6f9bbb349be9e42bc06c200505880d3718b.tar.gz
ports-aeebb6f9bbb349be9e42bc06c200505880d3718b.zip
- Update to 0.1.4
Notes
Notes: svn path=/head/; revision=292920
Diffstat (limited to 'misc/metromap')
-rw-r--r--misc/metromap/Makefile16
-rw-r--r--misc/metromap/distinfo4
-rw-r--r--misc/metromap/files/patch-python2747
3 files changed, 16 insertions, 51 deletions
diff --git a/misc/metromap/Makefile b/misc/metromap/Makefile
index 7eb0bf34d924..6a1f3fa1b2dc 100644
--- a/misc/metromap/Makefile
+++ b/misc/metromap/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= metromap
-PORTVERSION= 0.1.3
-PORTREVISION= 1
+PORTVERSION= 0.1.4
CATEGORIES= misc
MASTER_SITES= http://metromap.antex.ru/ \
http://mirror.amdmi3.ru/distfiles/
@@ -15,16 +14,29 @@ MASTER_SITES= http://metromap.antex.ru/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A simple application for finding paths in different subways maps
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/doc/COPYING
+
USE_PYTHON= yes
USE_GNOME= pygtk2
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
+PORTDOCS= AUTHORS NEWS README README.data TODO
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr,${PREFIX},' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,make,${GMAKE},' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's,/usr/bin/python,${SETENV} python,' ${WRKSRC}/metromap.py
@${RM} -f ${WRKSRC}/modules/ReadMap.py.orig
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}/
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/misc/metromap/distinfo b/misc/metromap/distinfo
index ce25a862311a..490fdaa0a2b4 100644
--- a/misc/metromap/distinfo
+++ b/misc/metromap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (metromap-0.1.3.tar.bz2) = c5a39523e62a10753fdafd001d254b82eb7978b362e880b2ba9dda810aae0339
-SIZE (metromap-0.1.3.tar.bz2) = 3367351
+SHA256 (metromap-0.1.4.tar.bz2) = 7fc3b7dd92443ace8944429895c27b2d9bc6444d1eef973b5608cdba72b38fba
+SIZE (metromap-0.1.4.tar.bz2) = 3419243
diff --git a/misc/metromap/files/patch-python27 b/misc/metromap/files/patch-python27
deleted file mode 100644
index 30d512e5c6ab..000000000000
--- a/misc/metromap/files/patch-python27
+++ /dev/null
@@ -1,47 +0,0 @@
---- modules/ReadMap.py 2010-07-01 11:22:36.000000000 +0400
-+++ modules/ReadMap.py 2011-01-03 02:28:53.000000000 +0300
-@@ -85,7 +85,7 @@
- return None
-
- def GetMapName(ini):
-- cp = ConfigParser.RawConfigParser()
-+ cp = ConfigParser.RawConfigParser(allow_no_value=True)
- try:
- cp.readfp(ini)
- except:
-@@ -105,7 +105,7 @@
- return None
-
- def GetMapVec(ini):
-- cp = ConfigParser.RawConfigParser()
-+ cp = ConfigParser.RawConfigParser(allow_no_value=True)
- try:
- cp.readfp(ini)
- except:
-@@ -568,7 +568,7 @@
- self.Graph[i] = filter(lambda a: a[0] not in uclist, self.Graph[i])
-
- def _load_vec(self):
-- cp = ConfigParser.RawConfigParser()
-+ cp = ConfigParser.RawConfigParser(allow_no_value=True)
- try:
- cp.readfp(self.vec)
- except: #ConfigParser.readfp raises exception, when he thinks,
-@@ -594,7 +594,7 @@
- self.Stations[st]['vfile'] = cp_get(cp, section, self.Stations[st]['name_orig'], None)
-
- def _load(self):
-- cp = ConfigParser.RawConfigParser()
-+ cp = ConfigParser.RawConfigParser(allow_no_value=True)
- try:
- cp.readfp(self.ini)
- except: #ConfigParser.readfp raises exception, when he thinks,
-@@ -945,7 +945,7 @@
- self.name = None
- self.data = dict()
- self.enc = encoding
-- cp = ConfigParser.RawConfigParser()
-+ cp = ConfigParser.RawConfigParser(allow_no_value=True)
- try:
- cp.readfp(infodata)
- except: \ No newline at end of file