aboutsummaryrefslogtreecommitdiff
path: root/misc/mirmon
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-15 02:03:44 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-15 02:03:44 +0000
commita29a3dda2fd7d5b739148444ffb3d73d078b4de7 (patch)
tree9cea09bd3a456349fe16775ec249ad13a2d21684 /misc/mirmon
parent00743191f18ff85d98c42393ce92c69e2f93f0ec (diff)
downloadports-a29a3dda2fd7d5b739148444ffb3d73d078b4de7.tar.gz
ports-a29a3dda2fd7d5b739148444ffb3d73d078b4de7.zip
add mirmon 1.34
Monitor the status of mirrors
Notes
Notes: svn path=/head/; revision=111507
Diffstat (limited to 'misc/mirmon')
-rw-r--r--misc/mirmon/Makefile48
-rw-r--r--misc/mirmon/distinfo2
-rw-r--r--misc/mirmon/pkg-descr7
3 files changed, 57 insertions, 0 deletions
diff --git a/misc/mirmon/Makefile b/misc/mirmon/Makefile
new file mode 100644
index 000000000000..a447b29abea9
--- /dev/null
+++ b/misc/mirmon/Makefile
@@ -0,0 +1,48 @@
+# ex:ts=8
+# Ports collection makefile for: mirmon
+# Date created: Jun 15, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mirmon
+PORTVERSION= 1.34
+CATEGORIES= misc
+MASTER_SITES= http://www.cs.uu.nl/people/henkp/mirmon/src/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Monitor the status of mirrors
+
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+PLIST_FILES= bin/mirmon
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/etc,${LOCALBASE}/etc," \
+ -e "s,/sw/bin/perl,/usr/bin/env perl," \
+ -e "s,/sw,${LOCALBASE}," \
+ ${WRKSRC}/mirmon ${WRKSRC}/mirmon.html
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mirmon ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/countries.list ${WRKSRC}/icons ${DATADIR}
+ @${FIND} ${DATADIR} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} ${WRKSRC}/mirmon.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/mirmon/distinfo b/misc/mirmon/distinfo
new file mode 100644
index 000000000000..53ec8310f3f2
--- /dev/null
+++ b/misc/mirmon/distinfo
@@ -0,0 +1,2 @@
+MD5 (mirmon.tar.gz) = d5e0bb41a767115400f881268f4b3aed
+SIZE (mirmon.tar.gz) = 25626
diff --git a/misc/mirmon/pkg-descr b/misc/mirmon/pkg-descr
new file mode 100644
index 000000000000..e9f9a872722d
--- /dev/null
+++ b/misc/mirmon/pkg-descr
@@ -0,0 +1,7 @@
+Many project are mirrored worldwide. Mirmon helps in monitoring these mirrors.
+In a concise graphic format, mirmon shows each site's history of the last two
+weeks, making it easy to spot stale or dead mirrors. Mirmon quietly probes a
+subset of the sites in a given list, writes the results in the 'state' file,
+and generates a Web page with the results
+
+WWW: http://www.cs.uu.nl/people/henkp/mirmon/