aboutsummaryrefslogtreecommitdiff
path: root/misc/ngraph
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-06-09 21:14:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-06-09 21:14:01 +0000
commit36aa6dc32df677c516783374ae7ffeefe8672c86 (patch)
treea5df0df09d28c9c0c8ac1e6e97b0f8813824b976 /misc/ngraph
parentd1dc99fe611c411eb5100d0886ae9e34d7244984 (diff)
downloadports-36aa6dc32df677c516783374ae7ffeefe8672c86.tar.gz
ports-36aa6dc32df677c516783374ae7ffeefe8672c86.zip
misc/ngraph: Unbreak on systems incompatible with the system where the package was built
-march=native caused SEGVs on incompatible systems
Notes
Notes: svn path=/head/; revision=538345
Diffstat (limited to 'misc/ngraph')
-rw-r--r--misc/ngraph/Makefile10
-rw-r--r--misc/ngraph/distinfo6
-rw-r--r--misc/ngraph/pkg-plist2
3 files changed, 12 insertions, 6 deletions
diff --git a/misc/ngraph/Makefile b/misc/ngraph/Makefile
index db48c6f38bdd..bdde02b18a81 100644
--- a/misc/ngraph/Makefile
+++ b/misc/ngraph/Makefile
@@ -2,8 +2,9 @@
PORTNAME= ngraph
DISTVERSIONPREFIX= v
-DISTVERSION= 0.29.0-rc.0-270
-DISTVERSIONSUFFIX= -g92bd148c0
+DISTVERSION= 0.29.0-rc.0-345
+DISTVERSIONSUFFIX= -g58b649aa6
+PORTREVISION= 1
CATEGORIES= misc # machine-learning
PKGNAMESUFFIX= -machine-learning-library
@@ -36,6 +37,11 @@ CPP= clang-cpp${LLVM_DEFAULT}
CC= clang${LLVM_DEFAULT}
CXX= clang++${LLVM_DEFAULT}
+OPTIONS_DEFINE= NATIVE
+
+NATIVE_DESC= Build with native optimizations (-march=native)
+NATIVE_CMAKE_BOOL= NGRAPH_NATIVE_ARCH_ENABLE
+
post-install:
@cd ${STAGEDIR}${PREFIX} && \
${RM} -r licenses && \
diff --git a/misc/ngraph/distinfo b/misc/ngraph/distinfo
index 968f04666a42..88e3e6ded1fa 100644
--- a/misc/ngraph/distinfo
+++ b/misc/ngraph/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1587086490
-SHA256 (NervanaSystems-ngraph-v0.29.0-rc.0-270-g92bd148c0_GH0.tar.gz) = 1bcb2e8340b2383919a7760d03da71b4b55747e5e589ca1a00b6793f9e88fd96
-SIZE (NervanaSystems-ngraph-v0.29.0-rc.0-270-g92bd148c0_GH0.tar.gz) = 11295753
+TIMESTAMP = 1588884977
+SHA256 (NervanaSystems-ngraph-v0.29.0-rc.0-345-g58b649aa6_GH0.tar.gz) = e930980af23d7e2b82d03d6beb6dca9b7cd5f5af7ffb29219605a4076ddeb658
+SIZE (NervanaSystems-ngraph-v0.29.0-rc.0-345-g58b649aa6_GH0.tar.gz) = 11317314
diff --git a/misc/ngraph/pkg-plist b/misc/ngraph/pkg-plist
index 5fb294003347..d0391e302d4c 100644
--- a/misc/ngraph/pkg-plist
+++ b/misc/ngraph/pkg-plist
@@ -42,7 +42,6 @@ include/ngraph/distributed/null.hpp
include/ngraph/enum_names.hpp
include/ngraph/env_util.hpp
include/ngraph/evaluator.hpp
-include/ngraph/evaluator/tensor.hpp
include/ngraph/except.hpp
include/ngraph/factory.hpp
include/ngraph/file_util.hpp
@@ -379,6 +378,7 @@ include/ngraph/op/util/attr_types.hpp
include/ngraph/op/util/binary_elementwise_arithmetic.hpp
include/ngraph/op/util/binary_elementwise_comparison.hpp
include/ngraph/op/util/binary_elementwise_logical.hpp
+include/ngraph/op/util/broadcast_base.hpp
include/ngraph/op/util/fused_op.hpp
include/ngraph/op/util/index_reduction.hpp
include/ngraph/op/util/logical_reduction.hpp