aboutsummaryrefslogtreecommitdiff
path: root/misc/nn-insight
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-01-02 02:56:26 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-01-02 02:56:26 +0000
commite89f2084b068483c74c503099fb914e5f9bd040f (patch)
treecc6df703785999b598b08199ff60744a81ca5e30 /misc/nn-insight
parente77acab6ecbbeee90220418bffac9124d977e91b (diff)
downloadports-e89f2084b068483c74c503099fb914e5f9bd040f.tar.gz
ports-e89f2084b068483c74c503099fb914e5f9bd040f.zip
New port: misc/nn-insight: Neural network visualization software
Notes
Notes: svn path=/head/; revision=521794
Diffstat (limited to 'misc/nn-insight')
-rw-r--r--misc/nn-insight/Makefile29
-rw-r--r--misc/nn-insight/distinfo3
-rw-r--r--misc/nn-insight/pkg-descr6
3 files changed, 38 insertions, 0 deletions
diff --git a/misc/nn-insight/Makefile b/misc/nn-insight/Makefile
new file mode 100644
index 000000000000..04d07c6dbf29
--- /dev/null
+++ b/misc/nn-insight/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= nn-insight
+DISTVERSION= 0.1
+CATEGORIES= misc # machine-learning
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Neural network visualization software
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= avir>0:graphics/avir \
+ flatbuffers>0:devel/flatbuffers \
+ nlohmann-json>0:devel/nlohmann-json \
+ png++>0:graphics/png++
+LIB_DEPENDS= libcgraph.so:graphics/graphviz \
+ libpng16.so:graphics/png \
+ libtcmalloc.so:devel/google-perftools
+
+USES= compiler:c++17-lang cmake pkgconfig qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= yurivict
+USE_QT= core gui svg widgets buildtools_build qmake_build
+
+PLIST_FILES= bin/nn-insight \
+ libexec/nn-insight/tf-lite-plugin.so
+
+.include <bsd.port.mk>
diff --git a/misc/nn-insight/distinfo b/misc/nn-insight/distinfo
new file mode 100644
index 000000000000..39ad457aa0fd
--- /dev/null
+++ b/misc/nn-insight/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577933404
+SHA256 (yurivict-nn-insight-0.1_GH0.tar.gz) = f533e34b6799beabf6627ac6d141c125c30f5392b2fd077e9df3e11f78941398
+SIZE (yurivict-nn-insight-0.1_GH0.tar.gz) = 427489
diff --git a/misc/nn-insight/pkg-descr b/misc/nn-insight/pkg-descr
new file mode 100644
index 000000000000..41594b1200a4
--- /dev/null
+++ b/misc/nn-insight/pkg-descr
@@ -0,0 +1,6 @@
+nn-insight visualizes how neural networks work.
+
+It graphically shows the structure of the network, allows to select or paste
+an image, perform computations with it, and inspect results of the computation.
+
+WWW: https://github.com/yurivict/nn-insight