aboutsummaryrefslogtreecommitdiff
path: root/misc/openhab2
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2020-01-18 12:34:11 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2020-01-18 12:34:11 +0000
commit40130f3524f02dabfc7a76bc4769dce2181a3fd7 (patch)
treee494b27800ae554f30cbca15af468d1cdc72dfca /misc/openhab2
parenta2a5c3a73d61239674fe5ae9138bf329e422959b (diff)
downloadports-40130f3524f02dabfc7a76bc4769dce2181a3fd7.tar.gz
ports-40130f3524f02dabfc7a76bc4769dce2181a3fd7.zip
Update to 2.5.1.
Notes
Notes: svn path=/head/; revision=523417
Diffstat (limited to 'misc/openhab2')
-rw-r--r--misc/openhab2/Makefile6
-rw-r--r--misc/openhab2/distinfo6
-rw-r--r--misc/openhab2/pkg-plist39
3 files changed, 28 insertions, 23 deletions
diff --git a/misc/openhab2/Makefile b/misc/openhab2/Makefile
index 0056ada11fc4..78f73f9a954a 100644
--- a/misc/openhab2/Makefile
+++ b/misc/openhab2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openhab2
-PORTVERSION= 2.5.0
+PORTVERSION= 2.5.1
#PORTREVISION= 3
CATEGORIES= misc java
MASTER_SITES= https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab%2F${PORTVERSION}/
@@ -64,4 +64,8 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/update.freebsd ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}/runtime/bin/
(cd ${WRKSRC}/userdata && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/${PORTNAME})
+gen-plist:
+ ${FIND} ${STAGEDIR} -type f | sed -e "s:${STAGEDIR}${PREFIX}/::g" | sort -u | grep libexec/ >pkg-plist.new
+ egrep '^(@|#|%)' pkg-plist >>pkg-plist.new
+
.include <bsd.port.mk>
diff --git a/misc/openhab2/distinfo b/misc/openhab2/distinfo
index 32462553572f..3640aab28a77 100644
--- a/misc/openhab2/distinfo
+++ b/misc/openhab2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1577012002
-SHA256 (openhab-2.5.0.tar.gz) = 0ca9808159ea306ab8a0dbe40332337f4290638f350a2cd84bd6911adcc96259
-SIZE (openhab-2.5.0.tar.gz) = 82725403
+TIMESTAMP = 1579349106
+SHA256 (openhab-2.5.1.tar.gz) = 79907c05d1fa2b64a843dc1e2f7f46a8f3248f1d2d583604e3538ae5af7202de
+SIZE (openhab-2.5.1.tar.gz) = 83134957
diff --git a/misc/openhab2/pkg-plist b/misc/openhab2/pkg-plist
index 8b2e3e5295a5..d6cc7d4d8b9b 100644
--- a/misc/openhab2/pkg-plist
+++ b/misc/openhab2/pkg-plist
@@ -17,16 +17,17 @@ libexec/openhab2/runtime/bin/update.lst
libexec/openhab2/runtime/bin/userdata_sysfiles.lst
libexec/openhab2/runtime/etc/jetty.xml
libexec/openhab2/runtime/etc/quartz.properties
+libexec/openhab2/runtime/lib/README
+libexec/openhab2/runtime/lib/boot/README
libexec/openhab2/runtime/lib/boot/org.apache.karaf.diagnostic.boot-4.2.7.jar
libexec/openhab2/runtime/lib/boot/org.apache.karaf.jaas.boot-4.2.7.jar
libexec/openhab2/runtime/lib/boot/org.apache.karaf.main-4.2.7.jar
libexec/openhab2/runtime/lib/boot/org.apache.karaf.specs.activator-4.2.7.jar
libexec/openhab2/runtime/lib/boot/osgi.core-6.0.0.jar
-libexec/openhab2/runtime/lib/boot/README
+libexec/openhab2/runtime/lib/endorsed/README
libexec/openhab2/runtime/lib/endorsed/org.apache.karaf.specs.java.xml-4.2.7.jar
libexec/openhab2/runtime/lib/endorsed/org.apache.karaf.specs.java.xml.ws-4.2.7.jar
libexec/openhab2/runtime/lib/endorsed/org.apache.karaf.specs.locator-4.2.7.jar
-libexec/openhab2/runtime/lib/endorsed/README
libexec/openhab2/runtime/lib/ext/README
libexec/openhab2/runtime/lib/jdk9plus/istack-commons-runtime-3.0.8.jar
libexec/openhab2/runtime/lib/jdk9plus/jakarta.xml.bind-api-2.3.2.jar
@@ -34,8 +35,8 @@ libexec/openhab2/runtime/lib/jdk9plus/javax.activation-1.2.0.jar
libexec/openhab2/runtime/lib/jdk9plus/javax.annotation-api-1.3.1.jar
libexec/openhab2/runtime/lib/jdk9plus/jaxb-runtime-2.3.2.jar
libexec/openhab2/runtime/lib/jdk9plus/txw2-2.3.2.jar
-libexec/openhab2/runtime/lib/README
libexec/openhab2/runtime/services.cfg
+libexec/openhab2/runtime/system/README
libexec/openhab2/runtime/system/com/eclipsesource/jaxrs/publisher/5.3.1/publisher-5.3.1.jar
libexec/openhab2/runtime/system/com/fasterxml/jackson/core/jackson-annotations/2.9.10/jackson-annotations-2.9.10.jar
libexec/openhab2/runtime/system/com/fasterxml/jackson/core/jackson-core/2.9.10/jackson-core-2.9.10.jar
@@ -327,23 +328,24 @@ libexec/openhab2/runtime/system/org/openhab/core/bundles/org.openhab.core.ui.ico
libexec/openhab2/runtime/system/org/openhab/core/bundles/org.openhab.core.ui/2.5.0/org.openhab.core.ui-2.5.0.jar
libexec/openhab2/runtime/system/org/openhab/core/bundles/org.openhab.core.voice/2.5.0/org.openhab.core.voice-2.5.0.jar
libexec/openhab2/runtime/system/org/openhab/core/bundles/org.openhab.core/2.5.0/org.openhab.core-2.5.0.jar
-libexec/openhab2/runtime/system/org/openhab/distro/distro-kar/2.5.0/distro-kar-2.5.0-features.xml
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-automation-js.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-items.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-persistence-rrd4j.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-rules.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-scripts.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-services-basicui.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-services-classicui.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-services-logging.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-sitemaps.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-things.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.0/distro-resources-2.5.0-transform-en.cfg
-libexec/openhab2/runtime/system/org/openhab/distro/distro/2.5.0/distro-2.5.0-features.xml
-libexec/openhab2/runtime/system/org/openhab/distro/openhab-addons/2.5.0/openhab-addons-2.5.0-features.xml
+libexec/openhab2/runtime/system/org/openhab/distro/distro-kar/2.5.1/distro-kar-2.5.1-features.xml
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-automation-js.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-items.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-persistence-rrd4j.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-rules.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-scripts.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-services-basicui.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-services-classicui.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-services-logging.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-sitemaps.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-things.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro-resources/2.5.1/distro-resources-2.5.1-transform-en.cfg
+libexec/openhab2/runtime/system/org/openhab/distro/distro/2.5.1/distro-2.5.1-features.xml
+libexec/openhab2/runtime/system/org/openhab/distro/openhab-addons/2.5.1/openhab-addons-2.5.1-features.xml
libexec/openhab2/runtime/system/org/openhab/nrjavaserial/3.15.0.OH2/nrjavaserial-3.15.0.OH2.jar
libexec/openhab2/runtime/system/org/openhab/osgiify/com.google.dagger/2.20/com.google.dagger-2.20.jar
libexec/openhab2/runtime/system/org/openhab/osgiify/com.igormaznitsa.jbbp/1.4.1/com.igormaznitsa.jbbp-1.4.1.jar
+libexec/openhab2/runtime/system/org/openhab/ui/bundles/org.openhab.ui.dashboard/2.5.1/org.openhab.ui.dashboard-2.5.1.jar
libexec/openhab2/runtime/system/org/ops4j/pax/logging/pax-logging-api/1.11.2/pax-logging-api-1.11.2.jar
libexec/openhab2/runtime/system/org/ops4j/pax/logging/pax-logging-log4j2/1.11.2/pax-logging-log4j2-1.11.2.jar
libexec/openhab2/runtime/system/org/ops4j/pax/logging/pax-logging-logback/1.11.2/pax-logging-logback-1.11.2.jar
@@ -369,11 +371,10 @@ libexec/openhab2/runtime/system/org/slf4j/slf4j-api/1.7.12/slf4j-api-1.7.12.jar
libexec/openhab2/runtime/system/org/slf4j/slf4j-api/1.7.7/slf4j-api-1.7.7.jar
libexec/openhab2/runtime/system/org/threeten/threeten-extra/1.4/threeten-extra-1.4.jar
libexec/openhab2/runtime/system/org/yaml/snakeyaml/1.23/snakeyaml-1.23.jar
-libexec/openhab2/runtime/system/README
libexec/openhab2/runtime/system/tec/uom/lib/uom-lib-common/1.0.3/uom-lib-common-1.0.3.jar
libexec/openhab2/runtime/system/tec/uom/uom-se/1.0.10/uom-se-1.0.10.jar
-libexec/openhab2/start_debug.sh
libexec/openhab2/start.sh
+libexec/openhab2/start_debug.sh
@owner openhab
@group openhab
@sample %%DATADIR%%/etc/all.policy /var/db/openhab2/userdata/etc/all.policy