aboutsummaryrefslogtreecommitdiff
path: root/misc/openvdb
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-04-02 01:32:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-04-02 01:32:07 +0000
commitfcea5736844f125c7f3f9b8c7b4d01a8b2db1f1b (patch)
tree6579a2cc9daec71c5f417f9460dbb774399894ab /misc/openvdb
parent5d175984e09cacf2af2f2d3874ad2c6ec7d6f89b (diff)
downloadports-fcea5736844f125c7f3f9b8c7b4d01a8b2db1f1b.tar.gz
ports-fcea5736844f125c7f3f9b8c7b4d01a8b2db1f1b.zip
misc/openvdb: Update 6.1.0 -> 7.0.0
Reported by: VVD <vvd@unislabs.com> (in bug#244347)
Notes
Notes: svn path=/head/; revision=530255
Diffstat (limited to 'misc/openvdb')
-rw-r--r--misc/openvdb/Makefile8
-rw-r--r--misc/openvdb/distinfo6
-rw-r--r--misc/openvdb/files/patch-CMakeLists.txt29
-rw-r--r--misc/openvdb/files/patch-cmake_FindTBB.cmake10
-rw-r--r--misc/openvdb/files/patch-doc_CMakeLists.txt10
-rw-r--r--misc/openvdb/files/patch-openvdb_CMakeLists.txt15
-rw-r--r--misc/openvdb/files/patch-openvdb_points_AttributeSet.cc4
-rw-r--r--misc/openvdb/files/patch-openvdb_python_CMakeLists.txt14
-rw-r--r--misc/openvdb/files/patch-openvdb_python_pyOpenVDBModule.cc26
-rw-r--r--misc/openvdb/pkg-plist7
10 files changed, 79 insertions, 50 deletions
diff --git a/misc/openvdb/Makefile b/misc/openvdb/Makefile
index fa57e3b60451..07c08ae8fbc4 100644
--- a/misc/openvdb/Makefile
+++ b/misc/openvdb/Makefile
@@ -2,8 +2,7 @@
PORTNAME= openvdb
DISTVERSIONPREFIX= v
-DISTVERSION= 6.1.0
-PORTREVISION= 8
+DISTVERSION= 7.0.0
CATEGORIES= misc
MAINTAINER= yuri@FreeBSD.org
@@ -22,9 +21,10 @@ USE_GITHUB= yes
GH_ACCOUNT= AcademySoftwareFoundation
USE_LDCONFIG= yes
+CMAKE_ARGS= -DCONCURRENT_MALLOC="Tbbmalloc"
CMAKE_OFF= OPENVDB_CORE_STATIC
-OPTIONS_DEFINE= PYTHON TOOLS DOCS # TOOLS should be a subpackage
+OPTIONS_DEFINE= PYTHON TOOLS DOCS # TOOLS and PYTHON should be made into subpackages
OPTIONS_DEFAULT= PYTHON TOOLS
OPTIONS_SUB= yes
@@ -41,7 +41,7 @@ TOOLS_CMAKE_BOOL= OPENVDB_BUILD_BINARIES OPENVDB_BUILD_VDB_LOD \
TOOLS_LIB_DEPENDS= libglfw.so:graphics/glfw \
libIlmImf.so:graphics/openexr
TOOLS_USES= gl xorg
-TOOLS_USE= GL=gl,glu XORG=x11,xcursor,xi,xinerama,xrandr,xxf86vm
+TOOLS_USE= GL=gl,glu XORG=ice,sm,x11,xcursor,xext,xi,xinerama,xrandr,xxf86vm
DOCS_CMAKE_BOOL= OPENVDB_BUILD_DOCS
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
diff --git a/misc/openvdb/distinfo b/misc/openvdb/distinfo
index 8a4d833c0176..79c6aa0a9d09 100644
--- a/misc/openvdb/distinfo
+++ b/misc/openvdb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1557552105
-SHA256 (AcademySoftwareFoundation-openvdb-v6.1.0_GH0.tar.gz) = d8803214c245cf0ca14a2c30cd215b183147c03c888c59fc642f213f98b4d68f
-SIZE (AcademySoftwareFoundation-openvdb-v6.1.0_GH0.tar.gz) = 1864024
+TIMESTAMP = 1585783763
+SHA256 (AcademySoftwareFoundation-openvdb-v7.0.0_GH0.tar.gz) = 97bc8ae35ef7ccbf49a4e25cb73e8c2eccae6b235bac86f2150707efcd1e910d
+SIZE (AcademySoftwareFoundation-openvdb-v7.0.0_GH0.tar.gz) = 1872744
diff --git a/misc/openvdb/files/patch-CMakeLists.txt b/misc/openvdb/files/patch-CMakeLists.txt
index b153fc11ed0c..2360d58cc7a0 100644
--- a/misc/openvdb/files/patch-CMakeLists.txt
+++ b/misc/openvdb/files/patch-CMakeLists.txt
@@ -1,20 +1,23 @@
---- CMakeLists.txt.orig 2019-05-07 20:58:35 UTC
+--- CMakeLists.txt.orig 2019-12-06 20:11:33 UTC
+++ CMakeLists.txt
-@@ -177,7 +177,7 @@ if(NOT DISABLE_DEPENDENCY_VERSION_CHECKS)
+@@ -198,7 +198,7 @@ mark_as_advanced(
+
+ # @note Blosc version is currently treated as exception which must be adhered
+ # to. The minimum version must be at least 1.5. Previous versions are incompatible.
+-set(MINIMUM_BLOSC_VERSION 1.5)
++set(MINIMUM_BLOSC_VERSION 1.15)
+ # @note ABI always enforced so the correct deprecation messages are available.
+ # OPENVDB_USE_DEPRECATED_ABI should be used to circumvent this
+ set(MINIMUM_OPENVDB_ABI_VERSION 4)
+@@ -215,9 +215,9 @@ if(NOT DISABLE_DEPENDENCY_VERSION_CHECKS)
+ set(MINIMUM_ILMBASE_VERSION 2.2)
+ set(MINIMUM_OPENEXR_VERSION 2.2)
set(MINIMUM_ZLIB_VERSION 1.2.7)
- set(MINIMUM_TBB_VERSION 4.4)
+- set(MINIMUM_TBB_VERSION 2017.0)
++ #set(MINIMUM_TBB_VERSION 2019.0) # bogus check: https://github.com/AcademySoftwareFoundation/openvdb/issues/688
- set(MINIMUM_PYTHON_VERSION 2.7)
+ set(MINIMUM_PYTHON_VERSION ${FREEBSD_PYTHON_VER})
- set(MINIMUM_NUMPY_VERSION 1.9.2)
+ set(MINIMUM_NUMPY_VERSION 1.12.1)
set(MINIMUM_CPPUNIT_VERSION 1.10)
-@@ -271,7 +271,7 @@ if(OPENVDB_BUILD_DOCS)
- COMMENT "Generating API documentation with Doxygen" VERBATIM
- )
-
-- install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html DESTINATION docs)
-+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html DESTINATION share/doc/openvdb)
- endif()
-
- # Early exit if there's nothing to build
diff --git a/misc/openvdb/files/patch-cmake_FindTBB.cmake b/misc/openvdb/files/patch-cmake_FindTBB.cmake
new file mode 100644
index 000000000000..905c86507b5e
--- /dev/null
+++ b/misc/openvdb/files/patch-cmake_FindTBB.cmake
@@ -0,0 +1,10 @@
+--- cmake/FindTBB.cmake.orig 2020-04-01 23:48:32 UTC
++++ cmake/FindTBB.cmake
+@@ -96,7 +96,6 @@ endif()
+ set(_TBB_COMPONENT_LIST
+ tbb
+ tbbmalloc
+- tbbmalloc_proxy
+ )
+
+ if(TBB_FIND_COMPONENTS)
diff --git a/misc/openvdb/files/patch-doc_CMakeLists.txt b/misc/openvdb/files/patch-doc_CMakeLists.txt
new file mode 100644
index 000000000000..0bdb1eb72caf
--- /dev/null
+++ b/misc/openvdb/files/patch-doc_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- doc/CMakeLists.txt.orig 2019-12-06 20:11:33 UTC
++++ doc/CMakeLists.txt
+@@ -64,5 +64,5 @@ add_custom_target(doc ALL
+ )
+
+ # Suppress "Installing..." messages for all but one of the hundreds of generated files.
+-install(FILES ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html/index.html DESTINATION doc/html)
+-install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html DESTINATION doc MESSAGE_NEVER)
++install(FILES ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html/index.html DESTINATION share/doc/openvdb)
++install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/openvdb/doc/html DESTINATION share/doc/openvdb MESSAGE_NEVER)
diff --git a/misc/openvdb/files/patch-openvdb_CMakeLists.txt b/misc/openvdb/files/patch-openvdb_CMakeLists.txt
new file mode 100644
index 000000000000..a6ed463db055
--- /dev/null
+++ b/misc/openvdb/files/patch-openvdb_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- openvdb/CMakeLists.txt.orig 2020-04-01 23:48:56 UTC
++++ openvdb/CMakeLists.txt
+@@ -127,10 +127,10 @@ if(CONCURRENT_MALLOC STREQUAL "Jemalloc")
+ message(WARNING "Unable to find Jemalloc, attempting to fall back to TBB malloc.
+ It is recommended to use Jemalloc for optimum performance."
+ )
+- find_package(TBB ${MINIMUM_TBB_VERSION} REQUIRED COMPONENTS tbbmalloc tbbmalloc_proxy)
++ find_package(TBB ${MINIMUM_TBB_VERSION} REQUIRED COMPONENTS tbbmalloc)
+ endif()
+ elseif(CONCURRENT_MALLOC STREQUAL "Tbbmalloc")
+- find_package(TBB ${MINIMUM_TBB_VERSION} REQUIRED COMPONENTS tbbmalloc tbbmalloc_proxy)
++ find_package(TBB ${MINIMUM_TBB_VERSION} REQUIRED COMPONENTS tbbmalloc)
+ endif()
+
+ # Set deps. Note that the order here is important. If we're building against
diff --git a/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc b/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc
index 2ddcb64c3d0b..df4f4b49596d 100644
--- a/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc
+++ b/misc/openvdb/files/patch-openvdb_points_AttributeSet.cc
@@ -1,6 +1,6 @@
---- openvdb/points/AttributeSet.cc.orig 2019-09-16 16:50:50 UTC
+--- openvdb/points/AttributeSet.cc.orig 2019-12-06 20:11:33 UTC
+++ openvdb/points/AttributeSet.cc
-@@ -34,6 +34,7 @@
+@@ -7,6 +7,7 @@
#include "AttributeGroup.h"
#include <algorithm> // std::equal
diff --git a/misc/openvdb/files/patch-openvdb_python_CMakeLists.txt b/misc/openvdb/files/patch-openvdb_python_CMakeLists.txt
new file mode 100644
index 000000000000..d4ff4dd758b3
--- /dev/null
+++ b/misc/openvdb/files/patch-openvdb_python_CMakeLists.txt
@@ -0,0 +1,14 @@
+--- openvdb/python/CMakeLists.txt.orig 2019-12-06 20:11:33 UTC
++++ openvdb/python/CMakeLists.txt
+@@ -104,9 +104,9 @@ elseif(${CMAKE_VERSION} VERSION_LESS 3.14)
+ else()
+ # CMake >= 3.14
+ if(USE_NUMPY)
+- find_package(Python QUIET REQUIRED COMPONENTS Interpreter Development NumPy)
++ find_package(Python ${FREEBSD_PYTHON_VER} EXACT QUIET REQUIRED COMPONENTS Interpreter Development NumPy)
+ else()
+- find_package(Python QUIET REQUIRED COMPONENTS Interpreter Development)
++ find_package(Python ${FREEBSD_PYTHON_VER} EXACT QUIET REQUIRED COMPONENTS Interpreter Development)
+ endif()
+
+ OPENVDB_CHECK_PYTHON_VERSION(${Python_VERSION} ${Python_EXECUTABLE})
diff --git a/misc/openvdb/files/patch-openvdb_python_pyOpenVDBModule.cc b/misc/openvdb/files/patch-openvdb_python_pyOpenVDBModule.cc
deleted file mode 100644
index 70c0ef90a862..000000000000
--- a/misc/openvdb/files/patch-openvdb_python_pyOpenVDBModule.cc
+++ /dev/null
@@ -1,26 +0,0 @@
---- openvdb/python/pyOpenVDBModule.cc.orig 2019-05-07 20:58:35 UTC
-+++ openvdb/python/pyOpenVDBModule.cc
-@@ -320,7 +320,11 @@ struct PointIndexConverter
- /// @return nullptr if the given Python object is not convertible to the PointIndex.
- static void* convertible(PyObject* obj)
- {
-+#if PY_MAJOR_VERSION >= 3
-+ if (!PyLong_Check(obj)) return nullptr; // not a Python integer
-+#else
- if (!PyInt_Check(obj)) return nullptr; // not a Python integer
-+#endif
- return obj;
- }
-
-@@ -337,7 +341,11 @@ struct PointIndexConverter
- // Extract the PointIndex from the python integer
- PointIndexT* index = static_cast<PointIndexT*>(storage);
-
-+#if PY_MAJOR_VERSION >= 3
-+ *index = static_cast<IntType>(PyLong_AsLong(obj));
-+#else
- *index = static_cast<IntType>(PyInt_AsLong(obj));
-+#endif
- }
-
- /// Register both the PointIndex-to-integer and the integer-to-PointIndex converters.
diff --git a/misc/openvdb/pkg-plist b/misc/openvdb/pkg-plist
index e2972a0616e5..bc61c1f47f82 100644
--- a/misc/openvdb/pkg-plist
+++ b/misc/openvdb/pkg-plist
@@ -11,6 +11,7 @@ include/openvdb/PlatformConfig.h
include/openvdb/Types.h
include/openvdb/io/Archive.h
include/openvdb/io/Compression.h
+include/openvdb/io/DelayedLoadMetadata.h
include/openvdb/io/File.h
include/openvdb/io/GridDescriptor.h
include/openvdb/io/Queue.h
@@ -67,6 +68,7 @@ include/openvdb/tools/Dense.h
include/openvdb/tools/DenseSparseTools.h
include/openvdb/tools/Diagnostics.h
include/openvdb/tools/Filter.h
+include/openvdb/tools/FindActiveValues.h
include/openvdb/tools/GridOperators.h
include/openvdb/tools/GridTransformer.h
include/openvdb/tools/Interpolation.h
@@ -131,6 +133,7 @@ include/openvdb/version.h
lib/cmake/OpenVDB/FindBlosc.cmake
lib/cmake/OpenVDB/FindCppUnit.cmake
lib/cmake/OpenVDB/FindIlmBase.cmake
+lib/cmake/OpenVDB/FindJemalloc.cmake
lib/cmake/OpenVDB/FindLog4cplus.cmake
lib/cmake/OpenVDB/FindOpenEXR.cmake
lib/cmake/OpenVDB/FindOpenVDB.cmake
@@ -140,6 +143,6 @@ lib/cmake/OpenVDB/OpenVDBHoudiniSetup.cmake
lib/cmake/OpenVDB/OpenVDBMayaSetup.cmake
lib/cmake/OpenVDB/OpenVDBUtils.cmake
lib/libopenvdb.so
-lib/libopenvdb.so.6.1
-lib/libopenvdb.so.6.1.0
+lib/libopenvdb.so.7.0
+lib/libopenvdb.so.7.0.0
%%PYTHON%%%%PYTHON_LIBDIR%%/pyopenvdb.so