aboutsummaryrefslogtreecommitdiff
path: root/misc/orville-write/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-03-09 08:33:08 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-03-09 08:33:08 +0000
commite46959cf449aca5ed1185e84ad934721331bf450 (patch)
treeaaca2893b112c2c8ba7f8e7df86d3695847fb0b3 /misc/orville-write/Makefile
parent87af50562eb10f0cb75ee46f4d8f78f585ba7a12 (diff)
downloadports-e46959cf449aca5ed1185e84ad934721331bf450.tar.gz
ports-e46959cf449aca5ed1185e84ad934721331bf450.zip
Remove setuid root from a file which should not have had it. Clean up
the install target a bit while I'm here.
Notes
Notes: svn path=/head/; revision=26687
Diffstat (limited to 'misc/orville-write/Makefile')
-rw-r--r--misc/orville-write/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/misc/orville-write/Makefile b/misc/orville-write/Makefile
index 1de9f188da72..5c1d829140e1 100644
--- a/misc/orville-write/Makefile
+++ b/misc/orville-write/Makefile
@@ -21,17 +21,17 @@ post-patch:
@${PERL} -pi -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_SCRIPT} -g tty -o root -m 6711 ${WRKSRC}/write ${PREFIX}/bin
- ${INSTALL_SCRIPT} -o root -m 4711 ${WRKSRC}/mesg ${PREFIX}/bin
- ${INSTALL_SCRIPT} -o root -m 4711 ${WRKSRC}/amin ${PREFIX}/bin
- ${INSTALL_SCRIPT} -o root -m 4711 ${WRKSRC}/huh ${PREFIX}/bin
- ${INSTALL_SCRIPT} -o root -m 4711 ${WRKSRC}/helpers ${PREFIX}/bin
- ${INSTALL_SCRIPT} -g tty -o root -m 6711 ${WRKSRC}/write ${PREFIX}/bin/tel
- ${INSTALL_SCRIPT} -g tty -o root -m 6711 ${WRKSRC}/write ${PREFIX}/bin/chat
+ ${INSTALL_PROGRAM} -g tty -o root -m 6711 ${WRKSRC}/write ${PREFIX}/bin
+ ${LN} -sf ${PREFIX}/bin/write ${PREFIX}/bin/tel
+ ${LN} -sf ${PREFIX}/bin/write ${PREFIX}/bin/chat
+ ${INSTALL_PROGRAM} -o root -m 4711 ${WRKSRC}/mesg ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -o root -m 4711 ${WRKSRC}/amin ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/huh ${PREFIX}/bin
+ ${INSTALL_PROGRAM} -o root -m 4711 ${WRKSRC}/helpers ${PREFIX}/bin
${TOUCH} /var/run/wrttmp
${TOUCH} /var/run/wrthist
${TOUCH} /var/log/writelog
- ${INSTALL_SCRIPT} ${WRKSRC}/wrttab ${PREFIX}/etc/wrttab
+ ${INSTALL_DATA} ${WRKSRC}/wrttab ${PREFIX}/etc/wrttab
.for f in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/${f} ${PREFIX}/man/man1/
.endfor