aboutsummaryrefslogtreecommitdiff
path: root/misc/orville-write/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-14 19:24:34 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-14 19:24:34 +0000
commitfc1e896e41e917b671e1b13bf8bf527914790989 (patch)
tree979838e93d090a61081cf050507fed155aa4ea68 /misc/orville-write/Makefile
parent452ba3191124320e0b78d134e3ce9a56acb7c462 (diff)
downloadports-fc1e896e41e917b671e1b13bf8bf527914790989.tar.gz
ports-fc1e896e41e917b671e1b13bf8bf527914790989.zip
Allow staging as a regular user
Notes
Notes: svn path=/head/; revision=368219
Diffstat (limited to 'misc/orville-write/Makefile')
-rw-r--r--misc/orville-write/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/misc/orville-write/Makefile b/misc/orville-write/Makefile
index 002f9c1ad6e2..263f449cddaf 100644
--- a/misc/orville-write/Makefile
+++ b/misc/orville-write/Makefile
@@ -12,8 +12,9 @@ COMMENT= Advanced replacement for write/mesg
GNU_CONFIGURE= yes
CFLAGS+= -Wno-return-type
-PLIST_FILES= bin/amin bin/helpers bin/huh bin/jot bin/mesg bin/tel \
- bin/telegram bin/write etc/orville.conf etc/wrthist etc/wrttmp \
+PLIST_FILES= "@(,,4711) bin/amin" "@(,,4711) bin/helpers" "@(,,4711) bin/huh" \
+ bin/jot "@(,,4711) bin/mesg" bin/tel bin/telegram \
+ "@(,,6711) bin/write" etc/orville.conf etc/wrthist etc/wrttmp \
man/man1/amin.1.gz man/man1/helpers.1.gz man/man1/huh.1.gz \
man/man1/mesg.1.gz man/man1/write.1.gz
@@ -37,10 +38,10 @@ EXTRA_PATCHES= ${PATCHDIR}/utmpx-wrttmp.h \
do-install:
.for i in amin helpers huh mesg
- ${INSTALL_PROGRAM} -m 4711 ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
.endfor
.for i in write
- ${INSTALL_PROGRAM} -m 6711 ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/bin
.endfor
.for i in jot tel telegram
${LN} -sf write ${STAGEDIR}${PREFIX}/bin/${i}