aboutsummaryrefslogtreecommitdiff
path: root/misc/ossp-uuid/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-16 15:04:45 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-16 15:04:45 +0000
commita44b2f459f974432796d7a458b2b02d8c476a924 (patch)
tree0d09c4f17f1ef0041bb594a189d339b1269d7c3f /misc/ossp-uuid/Makefile
parent73c3d661b13cdad3b11f0f64d0442056076167ba (diff)
downloadports-a44b2f459f974432796d7a458b2b02d8c476a924.tar.gz
ports-a44b2f459f974432796d7a458b2b02d8c476a924.zip
- USES=libtool pathfix
- Use MAKE_CMD
Notes
Notes: svn path=/head/; revision=365087
Diffstat (limited to 'misc/ossp-uuid/Makefile')
-rw-r--r--misc/ossp-uuid/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index c663b5b97d08..e5ba8b1ab2c9 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -3,7 +3,7 @@
PORTNAME= uuid
PORTVERSION= 1.6.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= misc devel
MASTER_SITES= ${MASTER_SITE_OSSP}
MASTER_SITE_SUBDIR= lib/${PORTNAME}
@@ -13,8 +13,9 @@ MAINTAINER= vd@FreeBSD.org
COMMENT= ISO-C API and CLI for generating Universally Unique Identifiers
GNU_CONFIGURE= yes
+USES= libtool pathfix
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-shared --enable-static --with-cxx \
+CONFIGURE_ARGS= --with-cxx \
--includedir=${PREFIX}/include/ossp
.if defined(SLAVEPORT) && ${SLAVEPORT}=="perl"
@@ -23,15 +24,10 @@ PKGNAMEPREFIX= p5-OSSP-
CONFLICTS= e2fsprogs-libuuid-[0-9]*
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-CFLAGS+= -fPIC -DPIC
-.endif
-
regression-test: test
test: build
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>