aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-Acme-ButFirst
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 09:15:19 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 09:15:19 +0000
commitc2491389e397bae3cc3829299d4c1f6c4d802f09 (patch)
tree7f8ceedfa3d496180d8493580bb85cda28ed74ef /misc/p5-Acme-ButFirst
parentd09598917e1ce7b954d1eff55b61371c67e8ef63 (diff)
downloadports-c2491389e397bae3cc3829299d4c1f6c4d802f09.tar.gz
ports-c2491389e397bae3cc3829299d4c1f6c4d802f09.zip
Adding port misc/p5-Acme-ButFirst, allowing you to do something, but do something first.
Committed by: aaron Approved by: tobez (implicit) Thanks to Anton's excellent port-idea script for the suggestion =)
Notes
Notes: svn path=/head/; revision=156266
Diffstat (limited to 'misc/p5-Acme-ButFirst')
-rw-r--r--misc/p5-Acme-ButFirst/Makefile32
-rw-r--r--misc/p5-Acme-ButFirst/distinfo3
-rw-r--r--misc/p5-Acme-ButFirst/pkg-descr15
-rw-r--r--misc/p5-Acme-ButFirst/pkg-plist5
4 files changed, 55 insertions, 0 deletions
diff --git a/misc/p5-Acme-ButFirst/Makefile b/misc/p5-Acme-ButFirst/Makefile
new file mode 100644
index 000000000000..fdd8a104fb33
--- /dev/null
+++ b/misc/p5-Acme-ButFirst/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Acme-ButFirst
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Acme-ButFirst
+PORTVERSION= 1.00
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Acme
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Do something, but first do something else
+
+MAN3= Acme::ButFirst.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6
+.endif
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Acme-ButFirst/distinfo b/misc/p5-Acme-ButFirst/distinfo
new file mode 100644
index 000000000000..21f3a5d6dd9e
--- /dev/null
+++ b/misc/p5-Acme-ButFirst/distinfo
@@ -0,0 +1,3 @@
+MD5 (Acme-ButFirst-1.00.tar.gz) = 238401d6f109549b8fd6a43a86de7ce3
+SHA256 (Acme-ButFirst-1.00.tar.gz) = cd119eac1a273926628b77ff1091a3ecd8a87a9bd877ad7d5fe05257010f8303
+SIZE (Acme-ButFirst-1.00.tar.gz) = 2909
diff --git a/misc/p5-Acme-ButFirst/pkg-descr b/misc/p5-Acme-ButFirst/pkg-descr
new file mode 100644
index 000000000000..644aaaa817f9
--- /dev/null
+++ b/misc/p5-Acme-ButFirst/pkg-descr
@@ -0,0 +1,15 @@
+Acme::ButFirst allows you to execute a block of code, but first do
+something else. Perfect for when you wish to add to the start of a long
+block of code, but don't have the energy to scroll upwards in your editor.
+
+Acme::ButFirst recognises both butfirst and but first as keywords.
+
+Usage of Acme::ButFirst is lexically scoped. ButFirstification can be
+explicitly disabled by using no Acme::ButFirst.
+
+WWW: http://search.cpan.org/dist/Acme-ButFirst
+Author: Paul Fenwick <pjf@cpan.org>
+
+--
+Aaron Dalton
+aaron@FreeBSD.org
diff --git a/misc/p5-Acme-ButFirst/pkg-plist b/misc/p5-Acme-ButFirst/pkg-plist
new file mode 100644
index 000000000000..05659c30266e
--- /dev/null
+++ b/misc/p5-Acme-ButFirst/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Acme/ButFirst.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme/ButFirst/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme/ButFirst
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Acme
+@dirrmtry %%SITE_PERL%%/Acme