aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-Geo-Coder-TomTom/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:48:40 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-20 06:48:40 +0000
commit9b109c24d6453aea846c332f453fb689d39ca2c8 (patch)
tree74b2d02890f6b376c36b3ac884532732db90be38 /misc/p5-Geo-Coder-TomTom/Makefile
parent5c3cefb426b4cd20e34b499b0d285043edece9ab (diff)
downloadports-9b109c24d6453aea846c332f453fb689d39ca2c8.tar.gz
ports-9b109c24d6453aea846c332f453fb689d39ca2c8.zip
- Add p5-Geo-Coder-TomTom 0.03
Geo::Coder::TomTom provides an interface to the geocoding service of the TomTom route planner through the unofficial (as-yet unpublished) REST API. WWW: http://search.cpan.org/dist/Geo-Coder-TomTom/
Notes
Notes: svn path=/head/; revision=283971
Diffstat (limited to 'misc/p5-Geo-Coder-TomTom/Makefile')
-rw-r--r--misc/p5-Geo-Coder-TomTom/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/misc/p5-Geo-Coder-TomTom/Makefile b/misc/p5-Geo-Coder-TomTom/Makefile
new file mode 100644
index 000000000000..2faca1d6e494
--- /dev/null
+++ b/misc/p5-Geo-Coder-TomTom/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Geo-Coder-TomTom
+# Date created: 2011-10-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-TomTom
+PORTVERSION= 0.03
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geocode addresses with the TomTom route planner
+
+BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::TomTom.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>