aboutsummaryrefslogtreecommitdiff
path: root/misc/p5-Zen-Koans/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-22 00:21:01 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-22 00:21:01 +0000
commitf40b642a86fd5b9f26e18d1af8ee21280031a0d7 (patch)
treed358991028c124bcbcff2829758c9eea89d77e22 /misc/p5-Zen-Koans/Makefile
parent9ad41a13ae04a35806a6756d81f960dda065d467 (diff)
downloadports-f40b642a86fd5b9f26e18d1af8ee21280031a0d7.tar.gz
ports-f40b642a86fd5b9f26e18d1af8ee21280031a0d7.zip
Adding port misc/p5-Zen-Koans, a Library containing over 100 Zen Koans.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163047
Diffstat (limited to 'misc/p5-Zen-Koans/Makefile')
-rw-r--r--misc/p5-Zen-Koans/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/misc/p5-Zen-Koans/Makefile b/misc/p5-Zen-Koans/Makefile
new file mode 100644
index 000000000000..9b9d8dd52105
--- /dev/null
+++ b/misc/p5-Zen-Koans/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Zen-Koans
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Zen-Koans
+PORTVERSION= 0.04
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/L/LU/LUKEC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Library containing over 100 Zen Koans
+
+MAN3= Zen::Koan.3 Zen::Koans.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>