aboutsummaryrefslogtreecommitdiff
path: root/misc/py-ezc3d
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-22 19:02:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-22 19:02:54 +0000
commit8d69a1fd3921b762c5161db631094411fcbcfbe4 (patch)
treee290711afdc4e71344adc1d5c34b0a554f2c3217 /misc/py-ezc3d
parent0e81319846eea8366a9c100a5d350b704e5f13bc (diff)
downloadports-8d69a1fd3921b762c5161db631094411fcbcfbe4.tar.gz
ports-8d69a1fd3921b762c5161db631094411fcbcfbe4.zip
misc/py-ezc3d: Fix tests
Diffstat (limited to 'misc/py-ezc3d')
-rw-r--r--misc/py-ezc3d/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/misc/py-ezc3d/Makefile b/misc/py-ezc3d/Makefile
index f4bc6778443d..c0489cd1a957 100644
--- a/misc/py-ezc3d/Makefile
+++ b/misc/py-ezc3d/Makefile
@@ -24,6 +24,7 @@ USE_GITHUB= yes
GH_ACCOUNT= pyomeca
GH_TUPLE= google:googletest:3880b13:googletest/external/gtest # https://github.com/pyomeca/ezc3d/issues/256
+TEST_ARGS= ${WRKSRC}/test/python3
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
post-install:
@@ -35,4 +36,19 @@ post-install:
ezc3d/_ezc3d.so \
ezc3d/libezc3d.so
+pre-test: # download test c3d files
+ # download archives
+ @${MKDIR} ${WRKSRC}/test/c3dFiles
+ @cd ${WRKDIR} && ${FETCH_CMD} -q https://github.com/pyomeca/ezc3d-testFiles/archive/master.zip -o ${WRKSRC}/test/c3dFiles/ezc3d-testFiles-master.zip
+.for f in Sample01.zip Sample02.zip
+ @cd ${WRKDIR} && ${FETCH_CMD} -q https://www.c3d.org/data/${f} -o ${WRKSRC}/test/c3dFiles/${f}
+.endfor
+ # extract archives
+.for n in ezc3d-testFiles-master Sample01 Sample02
+ @cd ${WRKSRC}/test/c3dFiles && ${MKDIR} ${n} && cd ${n} && ${TAR} -xf ../${n}.zip
+.endfor
+ # move *.c3d files into a flat folder
+ @${MKDIR} ${WRKSRC}/test/c3dTestFiles
+ @${CP} `${FIND} ${WRKSRC} -name "*.c3d"` ${WRKSRC}/test/c3dTestFiles
+
.include <bsd.port.mk>