aboutsummaryrefslogtreecommitdiff
path: root/misc/py-pexpect
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-11 16:07:44 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-11 16:07:44 +0000
commite3e539b35800cf830f9a13e63f91a627cd7ab30c (patch)
treea93503104113d727ca59996f07cb30ce3643d54c /misc/py-pexpect
parent02c4890c4b31ec20e382f2c07d690bbcfcebe131 (diff)
downloadports-e3e539b35800cf830f9a13e63f91a627cd7ab30c.tar.gz
ports-e3e539b35800cf830f9a13e63f91a627cd7ab30c.zip
add py-pexpect 0.95
A Pure Python Expect-like module
Notes
Notes: svn path=/head/; revision=72910
Diffstat (limited to 'misc/py-pexpect')
-rw-r--r--misc/py-pexpect/Makefile22
-rw-r--r--misc/py-pexpect/distinfo1
-rw-r--r--misc/py-pexpect/pkg-comment1
-rw-r--r--misc/py-pexpect/pkg-descr14
-rw-r--r--misc/py-pexpect/pkg-plist3
5 files changed, 41 insertions, 0 deletions
diff --git a/misc/py-pexpect/Makefile b/misc/py-pexpect/Makefile
new file mode 100644
index 000000000000..9cf8a21a03d6
--- /dev/null
+++ b/misc/py-pexpect/Makefile
@@ -0,0 +1,22 @@
+# ex:ts=8
+# Ports collection makefile for: pexpect
+# Date created: Jan 11, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pexpect
+PORTVERSION= 0.95
+CATEGORIES= misc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-pexpect/distinfo b/misc/py-pexpect/distinfo
new file mode 100644
index 000000000000..d15890a6a347
--- /dev/null
+++ b/misc/py-pexpect/distinfo
@@ -0,0 +1 @@
+MD5 (pexpect-0.95.tgz) = 3f353c310333cdf4c49b79483a6faf0c
diff --git a/misc/py-pexpect/pkg-comment b/misc/py-pexpect/pkg-comment
new file mode 100644
index 000000000000..2bf51232fff1
--- /dev/null
+++ b/misc/py-pexpect/pkg-comment
@@ -0,0 +1 @@
+A Pure Python Expect-like module
diff --git a/misc/py-pexpect/pkg-descr b/misc/py-pexpect/pkg-descr
new file mode 100644
index 000000000000..338749d15efa
--- /dev/null
+++ b/misc/py-pexpect/pkg-descr
@@ -0,0 +1,14 @@
+Pexpect makes Python a better glue for controlling child applications.
+
+Pexpect is a pure Python module for spawning child applications; controlling
+them; and responding to expected patterns in their output. Pexpect works like
+Don Libes' Expect. Pexpect allows your script to spawn a child application
+and control it as if a human were typing commands.
+
+Pexpect can be used for automating interactive applications such as ssh, ftp,
+passwd, telnet, etc. It can be used to a automate setup scripts for duplicating
+software package installations on different servers. It can be used for
+automated software testing. Pexpect is in the spirit of Don Libes' Expect, but
+Pexpect is pure Python. The Pexpect interface was designed to be easy to use.
+
+WWW: http://pexpect.sourceforge.net/
diff --git a/misc/py-pexpect/pkg-plist b/misc/py-pexpect/pkg-plist
new file mode 100644
index 000000000000..336ae69b3127
--- /dev/null
+++ b/misc/py-pexpect/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/pexpect.py
+%%PYTHON_SITELIBDIR%%/pexpect.pyc
+%%PYTHON_SITELIBDIR%%/pexpect.pyo