aboutsummaryrefslogtreecommitdiff
path: root/misc/py-pytorch
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-12-27 00:23:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-12-27 00:23:56 +0000
commitaa45d9f594468859a483ddfbe3074c8dd4ddea84 (patch)
treef9f244f436f85faca1e7949ec47222e2224e0af1 /misc/py-pytorch
parent0dd03d4bd8908e9a64a888b57daeb45237ecdd26 (diff)
downloadports-aa45d9f594468859a483ddfbe3074c8dd4ddea84.tar.gz
ports-aa45d9f594468859a483ddfbe3074c8dd4ddea84.zip
misc/py-pytorch: update 2.1.1 → 2.1.2
Reported by: portscout
Diffstat (limited to 'misc/py-pytorch')
-rw-r--r--misc/py-pytorch/Makefile6
-rw-r--r--misc/py-pytorch/distinfo6
-rw-r--r--misc/py-pytorch/files/patch-CMakeLists.txt26
-rw-r--r--misc/py-pytorch/files/patch-aten_src_ATen_native_sparse_ValidateCompressedIndicesCommon.h14
-rw-r--r--misc/py-pytorch/files/patch-cmake_Dependencies.cmake4
5 files changed, 37 insertions, 19 deletions
diff --git a/misc/py-pytorch/Makefile b/misc/py-pytorch/Makefile
index e604c41e189c..ff7e82b13ec7 100644
--- a/misc/py-pytorch/Makefile
+++ b/misc/py-pytorch/Makefile
@@ -1,7 +1,6 @@
PORTNAME= pytorch
DISTVERSIONPREFIX= v
-DISTVERSION= 2.1.1
-PORTREVISION= 2
+DISTVERSION= 2.1.2
CATEGORIES= misc # machine-learning
MASTER_SITES= https://github.com/pytorch/pytorch/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -24,7 +23,8 @@ BUILD_DEPENDS= cmake:devel/cmake-core \
${LOCALBASE}/include/fxdiv.h:devel/fxdiv \
${PYTHON_PKGNAMEPREFIX}typing-extensions>0:devel/py-typing-extensions@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
-LIB_DEPENDS= libblis.so:math/blis \
+LIB_DEPENDS= libabsl_flags.so:devel/abseil \
+ libblis.so:math/blis \
libmpi.so:net/openmpi \
libonnx.so:misc/onnx \
libopenblas.so:math/openblas \
diff --git a/misc/py-pytorch/distinfo b/misc/py-pytorch/distinfo
index 5b54151ef464..ae8055c20eb0 100644
--- a/misc/py-pytorch/distinfo
+++ b/misc/py-pytorch/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1700419079
-SHA256 (pytorch/pytorch-v2.1.1.tar.gz) = 1aa2aacced3c60c935d05f6d80232f8e99cdcb09eb51ceea697857b90c98d3fa
-SIZE (pytorch/pytorch-v2.1.1.tar.gz) = 283020986
+TIMESTAMP = 1703589606
+SHA256 (pytorch/pytorch-v2.1.2.tar.gz) = 85effbcce037bffa290aea775c9a4bad5f769cb229583450c40055501ee1acd7
+SIZE (pytorch/pytorch-v2.1.2.tar.gz) = 282894457
diff --git a/misc/py-pytorch/files/patch-CMakeLists.txt b/misc/py-pytorch/files/patch-CMakeLists.txt
index 4b319d3c9aac..8968f96b81dd 100644
--- a/misc/py-pytorch/files/patch-CMakeLists.txt
+++ b/misc/py-pytorch/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2023-10-06 19:49:00 UTC
+--- CMakeLists.txt.orig 2023-12-15 02:03:27 UTC
+++ CMakeLists.txt
-@@ -139,7 +139,7 @@ endif()
+@@ -139,7 +139,7 @@ set(CPU_INTEL OFF)
set(CPU_AARCH64 OFF)
set(CPU_INTEL OFF)
@@ -9,7 +9,7 @@
set(CPU_INTEL ON)
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "^(aarch64|arm64)")
set(CPU_AARCH64 ON)
-@@ -164,7 +164,7 @@ include(CMakeDependentOption)
+@@ -164,7 +164,7 @@ option(BUILD_DOCS "Build Caffe2 documentation" OFF)
option(ATEN_NO_TEST "Do not build ATen test binaries" OFF)
option(BUILD_BINARY "Build C++ binaries" OFF)
option(BUILD_DOCS "Build Caffe2 documentation" OFF)
@@ -18,7 +18,16 @@
option(BUILD_PYTHON "Build Python binaries" ON)
option(BUILD_CAFFE2 "Master flag to build Caffe2" OFF)
option(BUILD_LITE_INTERPRETER "Master flag to build Lite Interpreter" OFF)
-@@ -408,15 +408,15 @@ endif()
+@@ -224,7 +224,7 @@ option(USE_LEVELDB "Use LEVELDB" OFF)
+ option(USE_GFLAGS "Use GFLAGS" OFF)
+ option(USE_GLOG "Use GLOG" OFF)
+ option(USE_LEVELDB "Use LEVELDB" OFF)
+-option(USE_LITE_PROTO "Use lite protobuf instead of full." OFF)
++option(USE_LITE_PROTO "Use lite protobuf instead of full." ON) # use lite protobuf to workaround for protobuf-related failure described here: https://github.com/onnx/optimizer/issues/38
+ option(USE_LMDB "Use LMDB" OFF)
+ option(USE_MAGMA "Use MAGMA" ON)
+ option(USE_METAL "Use Metal for Caffe2 iOS build" ON)
+@@ -408,15 +408,15 @@ option(USE_SYSTEM_CPUINFO "Use system-provided cpuinfo
# USE_SYSTEM_LIBS being "OFF".
option(USE_SYSTEM_LIBS "Use all available system-provided libraries." OFF)
option(USE_SYSTEM_CPUINFO "Use system-provided cpuinfo." OFF)
@@ -37,3 +46,12 @@
option(USE_SYSTEM_XNNPACK "Use system-provided xnnpack." OFF)
option(USE_SYSTEM_ZSTD "Use system-provided zstd." OFF)
option(USE_GOLD_LINKER "Use ld.gold to link" OFF)
+@@ -918,7 +918,7 @@ if(NOT MSVC)
+ append_cxx_flag_if_supported("-fno-math-errno" CMAKE_CXX_FLAGS)
+ append_cxx_flag_if_supported("-fno-trapping-math" CMAKE_CXX_FLAGS)
+ append_cxx_flag_if_supported("-Werror=format" CMAKE_CXX_FLAGS)
+- append_cxx_flag_if_supported("-Werror=cast-function-type" CMAKE_CXX_FLAGS)
++ #append_cxx_flag_if_supported("-Werror=cast-function-type" CMAKE_CXX_FLAGS) # workaround for https://github.com/pytorch/pytorch/issues/116416
+ else()
+ # skip unwanted includes from windows.h
+ add_compile_definitions(WIN32_LEAN_AND_MEAN)
diff --git a/misc/py-pytorch/files/patch-aten_src_ATen_native_sparse_ValidateCompressedIndicesCommon.h b/misc/py-pytorch/files/patch-aten_src_ATen_native_sparse_ValidateCompressedIndicesCommon.h
index 70dc6fbd61e2..e4cdf08b4ff3 100644
--- a/misc/py-pytorch/files/patch-aten_src_ATen_native_sparse_ValidateCompressedIndicesCommon.h
+++ b/misc/py-pytorch/files/patch-aten_src_ATen_native_sparse_ValidateCompressedIndicesCommon.h
@@ -1,6 +1,6 @@
---- aten/src/ATen/native/sparse/ValidateCompressedIndicesCommon.h.orig 2023-05-07 08:51:40 UTC
+--- aten/src/ATen/native/sparse/ValidateCompressedIndicesCommon.h.orig 2023-12-15 02:03:27 UTC
+++ aten/src/ATen/native/sparse/ValidateCompressedIndicesCommon.h
-@@ -39,7 +39,7 @@ namespace {
+@@ -40,7 +40,7 @@ INVARIANT_CHECK_FUNC_API
// use `cidx/idx` to refer to `compressed_indices/plain_indices` respectively.
INVARIANT_CHECK_FUNC_API
@@ -9,7 +9,7 @@
#ifdef GPUCC
CUDA_KERNEL_ASSERT(cond && message);
#else
-@@ -57,9 +57,9 @@ INVARIANT_CHECK_FUNC_API _check_first_cidx_is_zero(
+@@ -58,9 +58,9 @@ INVARIANT_CHECK_FUNC_API _check_first_cidx_is_zero(
const index_t& zero) {
const bool invariant = cidx == zero;
if (cdim_name == CDimName::CRow) {
@@ -21,7 +21,7 @@
}
}
-@@ -71,9 +71,9 @@ INVARIANT_CHECK_FUNC_API _check_last_cidx_is_nnz(
+@@ -72,9 +72,9 @@ INVARIANT_CHECK_FUNC_API _check_last_cidx_is_nnz(
const index_t& nnz) {
const bool invariant = cidx == nnz;
if (cdim_name == CDimName::CRow) {
@@ -33,7 +33,7 @@
}
}
-@@ -88,11 +88,11 @@ INVARIANT_CHECK_FUNC_API _check_cidx_nondecreasing_loc
+@@ -89,11 +89,11 @@ INVARIANT_CHECK_FUNC_API _check_cidx_nondecreasing_loc
const auto s_cidx = cidx_next - cidx;
const bool invariant = zero <= s_cidx && s_cidx <= dim;
if (cdim_name == CDimName::CRow) {
@@ -47,7 +47,7 @@
invariant,
"`0 <= ccol_indices[..., 1:] - ccol_indices[..., :-1] <= nrows` is not satisfied.");
}
-@@ -107,9 +107,9 @@ INVARIANT_CHECK_FUNC_API _check_idx_bounds(
+@@ -108,9 +108,9 @@ INVARIANT_CHECK_FUNC_API _check_idx_bounds(
const index_t& dim) {
const bool invariant = zero <= idx && idx < dim;
if (cdim_name == CDimName::CRow) {
@@ -59,7 +59,7 @@
}
}
-@@ -128,14 +128,14 @@ INVARIANT_CHECK_FUNC_API _check_idx_sorted_distinct_va
+@@ -129,14 +129,14 @@ INVARIANT_CHECK_FUNC_API _check_idx_sorted_distinct_va
for (auto* RESTRICT curr = slice_begin + 1; curr < slice_end; ++curr) {
const auto invariant = *(curr - 1) < *curr;
if (cdim_name == CDimName::CRow) {
diff --git a/misc/py-pytorch/files/patch-cmake_Dependencies.cmake b/misc/py-pytorch/files/patch-cmake_Dependencies.cmake
index 165534d123bd..7c673370a258 100644
--- a/misc/py-pytorch/files/patch-cmake_Dependencies.cmake
+++ b/misc/py-pytorch/files/patch-cmake_Dependencies.cmake
@@ -1,6 +1,6 @@
---- cmake/Dependencies.cmake.orig 2022-12-16 00:23:46 UTC
+--- cmake/Dependencies.cmake.orig 2023-12-15 02:03:27 UTC
+++ cmake/Dependencies.cmake
-@@ -339,7 +339,7 @@ if(USE_NNPACK OR USE_QNNPACK OR USE_PYTORCH_QNNPACK OR
+@@ -340,7 +340,7 @@ if(USE_NNPACK OR USE_QNNPACK OR USE_PYTORCH_QNNPACK OR
set(DISABLE_NNPACK_AND_FAMILY ON)
endif()
else()