aboutsummaryrefslogtreecommitdiff
path: root/misc/qbrew/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-25 09:01:33 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-25 09:01:33 +0000
commit3278324d915b235f1c00a39800fa85f8edf5a4a7 (patch)
tree4b8c2d922a6013a5ec240c6bd0282eee330decf1 /misc/qbrew/Makefile
parent48f550240c71565159d3aa7ae9e1aa7e2711e710 (diff)
downloadports-3278324d915b235f1c00a39800fa85f8edf5a4a7.tar.gz
ports-3278324d915b235f1c00a39800fa85f8edf5a4a7.zip
- Honor X11BASE [1]
- Use DATADIR macro - Respect NOPORTDOCS - Use PORTDOCS PR: ports/87901 [1] Submitted by: maintainer [1] Requested by: kris [1]
Notes
Notes: svn path=/head/; revision=146308
Diffstat (limited to 'misc/qbrew/Makefile')
-rw-r--r--misc/qbrew/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/misc/qbrew/Makefile b/misc/qbrew/Makefile
index 51a55a49a579..82c5c67d4a9d 100644
--- a/misc/qbrew/Makefile
+++ b/misc/qbrew/Makefile
@@ -13,12 +13,25 @@ MASTER_SITES= http://www.usermode.org/code/
MAINTAINER= david@usermode.org
COMMENT= A homebrewer's recipe calculator
+USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_QT_VER= 3
+PORTDOCS= *
QT_NONSTANDARD= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --x-includes=${X11BASE}/include \
+ --x-libraries=${X11BASE}/lib
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -E 's,^(SUBDIRS = .*) docs,\1,' \
+ ${WRKSRC}/Makefile.in
+.endif
post-install:
${STRIP_CMD} ${PREFIX}/bin/qbrew
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>