aboutsummaryrefslogtreecommitdiff
path: root/misc/qt4-qtconfig
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-04-20 22:49:12 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-04-20 22:49:12 +0000
commit60bdbec25e431944d2b2fc868b0b05ca3be41118 (patch)
treeb34f93efa6a0ddcefcb99014dd6209e92e834c73 /misc/qt4-qtconfig
parent1a9fb4be04e5a9dc89f708846de0441e8d618a7e (diff)
downloadports-60bdbec25e431944d2b2fc868b0b05ca3be41118.tar.gz
ports-60bdbec25e431944d2b2fc868b0b05ca3be41118.zip
- Add OPTION to disable Phonon support.
- Bump PORTREVISION. PR: 156462 Submitted by: dougb
Notes
Notes: svn path=/head/; revision=272975
Diffstat (limited to 'misc/qt4-qtconfig')
-rw-r--r--misc/qt4-qtconfig/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/misc/qt4-qtconfig/Makefile b/misc/qt4-qtconfig/Makefile
index 979482208769..5fe0393106cf 100644
--- a/misc/qt4-qtconfig/Makefile
+++ b/misc/qt4-qtconfig/Makefile
@@ -7,20 +7,21 @@
PORTNAME= qtconfig
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES?= misc
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt graphical configuration utility
+OPTIONS= PHONON "Add support for Phonon (implies GStreamer)" on
+
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build rcc_build uic_build qt3support corelib \
- gui sql xml phonon phonon-gst
+ gui sql xml
QT_NONSTANDARD= yes
QT_DIST= yes
-USE_GSTREAMER= yes
-
HAS_CONFIGURE= yes
ALL_TARGET= first
@@ -40,6 +41,15 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf -
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_PHONON)
+QT_COMPONENTS+= phonon phonon-gst
+USE_GSTREAMER= yes
+.else
+CONFIGURE_ARGS+= -no-phonon -no-gstreamer
+.endif
+
BUILD_WRKSRC= ${WRKSRC}/tools/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}