aboutsummaryrefslogtreecommitdiff
path: root/misc/qt4-qtdemo/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-01-06 16:16:52 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-01-06 16:16:52 +0000
commit7d5e6b666c579d543fbf4c0996e309e23de8e02e (patch)
treee9ca925ce8537078366a02e4f615c5847746c0b5 /misc/qt4-qtdemo/Makefile
parentb60b2bc8f43a72af43a1f5ff0df9828880c2b7a8 (diff)
downloadports-7d5e6b666c579d543fbf4c0996e309e23de8e02e.tar.gz
ports-7d5e6b666c579d543fbf4c0996e309e23de8e02e.zip
In preparation for Qt 5 ports:
Mk/Uses/qmake.mk: - Add support for out-of-source builds - Add support for Qt 5 ports - Respect WITH_DEBUG Mk/bsd.qt.mk: - Massive rework for Qt 5 ports - Remove '-phonon' from global configure args, thus allow qt4-designer and qt4-qtconfig to be built without Phonon support [1] devel/qmake4: - Improve mkspecs for gcc (mainly sync with linux version) and clang devel/qt4-corelib: - Convert to USES=iconv - Remove ancient patch devel/qt4-designer: - Remove reference to WRKSRC from installed pkgconfig files [2] - Don't build Qt Designer plugin for Phonon from outdated Qt sources. Separate port for plugin will be committed later devel/qt4-assistant-adp, devel/qt4-libqtassistantclient: - Convert to USES=qmake Clean up Qt4 ports: - Update comments - Update description; use common description - Consistently use QT_INCDIR, QT_LIBDIR, etc. - Use options helpers - Convert to new LIB_DEPENDS syntax - Update DESKTOP_ENTRIES to avoid conflicts with Qt 5 ports - Rename/move several ports for unification with Qt 5 ports PR: ports/184620 [1] Reported by: Kevin Zheng <kevinz5000@gmail.com> PR: ports/181141 [2] Reported by: thierry PR: ports/185101 Exp-run by: bdrewery This is mostly solely avilla's work in area51, kudos to him! And a couple commits from myself, so you know who's collecting pointyhats :)
Notes
Notes: svn path=/head/; revision=338902
Diffstat (limited to 'misc/qt4-qtdemo/Makefile')
-rw-r--r--misc/qt4-qtdemo/Makefile33
1 files changed, 18 insertions, 15 deletions
diff --git a/misc/qt4-qtdemo/Makefile b/misc/qt4-qtdemo/Makefile
index d01306741f05..53f995466cb2 100644
--- a/misc/qt4-qtdemo/Makefile
+++ b/misc/qt4-qtdemo/Makefile
@@ -3,18 +3,18 @@
PORTNAME= qtdemo
DISTVERSION= ${QT4_VERSION}
-CATEGORIES?= misc
+PORTREVISION= 1
+CATEGORIES= misc
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt demonstration and example programs
+COMMENT= Qt 4 demonstration and example applications
USES= pkgconfig
USE_QT4= qmake_build moc_build rcc_build uic_build corelib designer \
gui network opengl sql svg qtestlib xml imageformats_run dbus \
script webkit phonon help assistant_run phonon-gst scripttools \
xmlpatterns multimedia
-QT_NONSTANDARD= yes
QT_DIST= yes
HAS_CONFIGURE= yes
@@ -25,9 +25,10 @@ MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
PATH=${WRKSRC}/bin:$$PATH
# qtlogo.png is installed by qt4-gui
-DESKTOP_ENTRIES="Qt Examples and Demos" "${COMMENT}" \
- "${LOCALBASE}/share/pixmaps/qtlogo.png" \
- "${PREFIX}/bin/qtdemo" "Development;Qt;" true
+DESKTOP_ENTRIES="Qt 4 Examples and Demos" "" \
+ "${QT_PREFIX}/share/pixmaps/qtlogo.png" \
+ "${PREFIX}/${QT_BINDIR_REL}/qtdemo" \
+ "Development;Qt;" true
DO_NOT_EXTRACT= doc mkspecs qmake translations \
src/activeqt src/openvg src/s60installs src/s60main src/tools \
@@ -41,26 +42,28 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/demos
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-
post-patch:
- ${REINPLACE_CMD} -e '/app +=/s|"assistant"|"assistant-qt4"|' \
+ ${REINPLACE_CMD} -e '/app +=/s|"assistant"|"assistant${_QT_BINSUFX}"|' \
${BUILD_WRKSRC}/${PORTNAME}/menumanager.cpp \
${WRKSRC}/examples/help/remotecontrol/remotecontrol.cpp \
${WRKSRC}/examples/help/simpletextviewer/assistant.cpp
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs/modules
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
- ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/bin/uic
- ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
+ ${LN} -sf ${QMAKE} ${WRKSRC}/bin/qmake
+ ${LN} -sf ${MOC} ${WRKSRC}/bin/moc
+ ${LN} -sf ${UIC} ${WRKSRC}/bin/uic
+ ${LN} -sf ${RCC} ${WRKSRC}/bin/rcc
post-build:
- cd ${WRKSRC}/examples && ${SETENV} MAKEOBJDIR=. ${MAKE} ${_MAKE_JOBS}
+ cd ${WRKSRC}/examples && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKEFLAGS} ${MAKEFILE} \
+ ${_MAKE_JOBS} ${MAKE_ARGS} ${ALL_TARGET}
post-install:
- cd ${WRKSRC}/examples && ${SETENV} MAKEOBJDIR=. ${MAKE} ${MAKE_ARGS} install
+ cd ${WRKSRC}/examples && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKEFLAGS} ${MAKEFILE} \
+ ${MAKE_ARGS} ${INSTALL_TARGET}
${FIND} -E ${STAGEDIR}${PREFIX}/share/examples/qt4/examples/declarative/cppextensions -regex ".*\.(moc|obj|pch|rcc)" -type d | ${XARGS} ${RM} -r
.include <bsd.port.mk>