aboutsummaryrefslogtreecommitdiff
path: root/misc/sshbuddy
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-11 01:11:12 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-11 01:11:12 +0000
commit5385a2fcf9420f271e6f29cfce564a39e802a0d5 (patch)
treecfcbf0fa38d575fe0556b3b13686454d2a2b4569 /misc/sshbuddy
parent2efbeeddf104c629485cbd1c9a894b96403f5112 (diff)
downloadports-5385a2fcf9420f271e6f29cfce564a39e802a0d5.tar.gz
ports-5385a2fcf9420f271e6f29cfce564a39e802a0d5.zip
- Add stage support
- Use shebangfix instead of a patch file - Add USE_XORG as dependency instead of using BROKEN
Notes
Notes: svn path=/head/; revision=336134
Diffstat (limited to 'misc/sshbuddy')
-rw-r--r--misc/sshbuddy/Makefile14
-rw-r--r--misc/sshbuddy/files/patch-008
2 files changed, 8 insertions, 14 deletions
diff --git a/misc/sshbuddy/Makefile b/misc/sshbuddy/Makefile
index f63ee3a895b1..90ff2388d16b 100644
--- a/misc/sshbuddy/Makefile
+++ b/misc/sshbuddy/Makefile
@@ -12,15 +12,17 @@ COMMENT= Simple and small GUI utility to manage ssh sessions
RUN_DEPENDS= expectk:${PORTSDIR}/lang/expect
+USES= shebangfix
+USE_XORG= x11
+SHEBANG_FILES= ${WRKSRC}/sshbuddy.expk
+SHEBANG_LANG= expectk
+expectk_OLD_CMD= /usr/bin/expectk
+expectk_CMD= ${LOCALBASE}/bin/expectk
+
NO_BUILD= yes
PLIST_FILES= bin/sshbuddy
-.if defined(WITHOUT_X11)
-BROKEN= Broken dependency
-.endif
-
-NO_STAGE= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/sshbuddy.expk ${PREFIX}/bin/sshbuddy
+ ${INSTALL_SCRIPT} ${WRKSRC}/sshbuddy.expk ${STAGEDIR}${PREFIX}/bin/sshbuddy
.include <bsd.port.mk>
diff --git a/misc/sshbuddy/files/patch-00 b/misc/sshbuddy/files/patch-00
deleted file mode 100644
index f8cae8712fa7..000000000000
--- a/misc/sshbuddy/files/patch-00
+++ /dev/null
@@ -1,8 +0,0 @@
---- sshbuddy.expk.orig Fri Dec 31 02:10:35 1999
-+++ sshbuddy.expk Wed Jan 24 04:59:14 2001
-@@ -1,4 +1,4 @@
--#!/usr/bin/expectk
-+#!/usr/local/bin/expectk
- #
- # EDIT THE ABOVE LINE TO POINT TO WHERE expectk LIVES
- #