aboutsummaryrefslogtreecommitdiff
path: root/misc/sshbuddy
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-28 10:16:02 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-28 10:16:02 +0000
commit9766293b0b7d8ceaed50c29a850b962aabbbc405 (patch)
treeca1bf5eddc6e8bedb4108b4bb132b2bb143b5c4a /misc/sshbuddy
parentfe8748bcbd13a8a2939ad302b8a3c5d56408641f (diff)
downloadports-9766293b0b7d8ceaed50c29a850b962aabbbc405.tar.gz
ports-9766293b0b7d8ceaed50c29a850b962aabbbc405.zip
- Chase devel/expect update
Notes
Notes: svn path=/head/; revision=346483
Diffstat (limited to 'misc/sshbuddy')
-rw-r--r--misc/sshbuddy/Makefile14
-rw-r--r--misc/sshbuddy/files/patch-sshbuddy.expk17
2 files changed, 23 insertions, 8 deletions
diff --git a/misc/sshbuddy/Makefile b/misc/sshbuddy/Makefile
index 7e4968b2b7e1..19941c4c91ca 100644
--- a/misc/sshbuddy/Makefile
+++ b/misc/sshbuddy/Makefile
@@ -10,19 +10,17 @@ MASTER_SITES= http://linuxmafia.com/pub/linux/security/sshbuddy/
MAINTAINER= wrighrc@gmail.com
COMMENT= Simple and small GUI utility to manage ssh sessions
-RUN_DEPENDS= expectk:${PORTSDIR}/lang/expect
+RUN_DEPENDS= expect:${PORTSDIR}/lang/expect
-USES= shebangfix
-USE_XORG= x11
-SHEBANG_FILES= ${WRKSRC}/sshbuddy.expk
-SHEBANG_LANG= expectk
-expectk_OLD_CMD= /usr/bin/expectk
-expectk_CMD= ${LOCALBASE}/bin/expectk
+USES= tk
NO_BUILD= yes
PLIST_FILES= bin/sshbuddy
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%WISH%%|${WISH}|' ${WRKSRC}/sshbuddy.expk
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/sshbuddy.expk ${STAGEDIR}${PREFIX}/bin/sshbuddy
+ ${INSTALL_SCRIPT} ${WRKSRC}/sshbuddy.expk ${STAGEDIR}${PREFIX}/bin/sshbuddy
.include <bsd.port.mk>
diff --git a/misc/sshbuddy/files/patch-sshbuddy.expk b/misc/sshbuddy/files/patch-sshbuddy.expk
new file mode 100644
index 000000000000..1980c726841d
--- /dev/null
+++ b/misc/sshbuddy/files/patch-sshbuddy.expk
@@ -0,0 +1,17 @@
+--- sshbuddy.expk.orig 2014-02-28 10:41:40.000000000 +0100
++++ sshbuddy.expk 2014-02-28 10:41:58.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/expectk
++#!%%WISH%%
+ #
+ # EDIT THE ABOVE LINE TO POINT TO WHERE expectk LIVES
+ #
+@@ -10,6 +10,8 @@
+ #
+ # Version Beta1.05
+
++package require Expect
++
+ set expect_path [exec which expect]
+
+ ########################################################################