aboutsummaryrefslogtreecommitdiff
path: root/misc/sword
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-02-06 09:19:47 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-02-06 09:19:47 +0000
commit967e8d2ab08bd07979f0b9c6cd34aa27b8cc48e2 (patch)
tree8644753a6ee100435f3c1a8f07a97d63cb129cb8 /misc/sword
parent151ee75e1b40be17c936dd4bf5329c6f0f4726b1 (diff)
downloadports-967e8d2ab08bd07979f0b9c6cd34aa27b8cc48e2.tar.gz
ports-967e8d2ab08bd07979f0b9c6cd34aa27b8cc48e2.zip
misc/sword: Clean Makefile and assign to new maintainer
Apart from style changes, also remove broken link from MASTER_SITES. PR: 243905 Submitted by: salvadore@
Notes
Notes: svn path=/head/; revision=525370
Diffstat (limited to 'misc/sword')
-rw-r--r--misc/sword/Makefile50
1 files changed, 20 insertions, 30 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 268d62709557..d3760c8d79cd 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -5,48 +5,38 @@ PORTNAME= sword
PORTVERSION= 1.8.1
PORTREVISION= 8
CATEGORIES= misc
-MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v${PORTVERSION:R}/ \
- http://crosswire.org/ftpmirror/pub/sword/source/v${PORTVERSION:R}/
+MASTER_SITES= http://crosswire.org/ftpmirror/pub/sword/source/v${PORTVERSION:R}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= salvadore@FreeBSD.org
COMMENT= Framework for manipulating Bible texts
LICENSE= GPLv2
BUILD_DEPENDS= cppunit-config:devel/cppunit
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-conf --with-zlib
-CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
-INSTALL_TARGET= install-strip
USES= gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
-SUB_FILES= pkg-message
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-conf \
+ --with-zlib
+INSTALL_TARGET= install-strip
+CPPFLAGS+= -DU_USING_ICU_NAMESPACE=1
+
+SUB_FILES= pkg-message
PLIST_SUB= PORTVERSION=${PORTVERSION}
-OPTIONS_DEFINE= CURL CLUCENE
-CLUCENE_DESC= Include indexing capability
-OPTIONS_DEFAULT=CURL CLUCENE
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS= libcurl.so:ftp/curl
-CONFIGURE_ARGS+= --with-curl
-.else
-CONFIGURE_ARGS+= --without-curl
-.endif
-
-.if ${PORT_OPTIONS:MCLUCENE}
-USES+= compiler:c++11-lib
-USE_CXXSTD= gnu++11
-LIB_DEPENDS+= libclucene-core.so:textproc/clucene \
- libicudata.so:devel/icu
-CONFIGURE_ARGS+= --with-clucene=${LOCALBASE} --with-icu
-.else
-CONFIGURE_ARGS+= --without-clucene --without-icu
-.endif
+OPTIONS_DEFINE= CLUCENE CURL
+OPTIONS_DEFAULT= CLUCENE CURL
+CLUCENE_DESC= Include indexing capability
+
+CLUCENE_LIB_DEPENDS= libclucene-core.so:textproc/clucene \
+ libicudata.so:devel/icu
+CLUCENE_USES= compiler:c++11-lib
+CLUCENE_CONFIGURE_WITH= clucene=${LOCALBASE} icu
+
+CURL_LIB_DEPENDS= libcurl.so:ftp/curl
+CURL_CONFIGURE_WITH= curl
post-patch:
@${REINPLACE_CMD} 's|-O3||' ${WRKSRC}/configure