aboutsummaryrefslogtreecommitdiff
path: root/misc/sword
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2012-06-10 01:27:14 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2012-06-10 01:27:14 +0000
commitdd6a120ad933bf0f57d374bf9dd0c7b129db5cfc (patch)
tree5564331eda83f3190e56bbcdf471984e8fa1c332 /misc/sword
parentf2894a6ab80d7139ed139c5d231d34dca04d60d1 (diff)
downloadports-dd6a120ad933bf0f57d374bf9dd0c7b129db5cfc.tar.gz
ports-dd6a120ad933bf0f57d374bf9dd0c7b129db5cfc.zip
- Convert to new options framework
Notes
Notes: svn path=/head/; revision=298897
Diffstat (limited to 'misc/sword')
-rw-r--r--misc/sword/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 6f9807fccf9c..ed65b7636553 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -33,18 +33,20 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_SUB= PORTVERSION=${PORTVERSION}
-.if defined(WITHOUT_CURL)
-CONFIGURE_ARGS+= --without-curl
-.else
+OPTIONS_DEFINE= CURL
+OPTIONS_DEFAULT=CURL
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCURL}
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-curl
+.else
+CONFIGURE_ARGS+= --without-curl
+.endif
run-autotools:: run-autotools-aclocal
-pre-everything::
- @${ECHO_CMD} "Define WITHOUT_CURL to disable remote fetch (curl) support in the installmanager"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in