aboutsummaryrefslogtreecommitdiff
path: root/misc/tellico
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-07-18 20:35:45 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-07-18 20:35:45 +0000
commit727d1ed22b5845276c961b9dcf92861c255d3d26 (patch)
tree36a3eb878f5f7a9c7d3ca350d3301638c47db179 /misc/tellico
parentc96cad25e406891bf70f85c1cf3e235630ba7307 (diff)
downloadports-727d1ed22b5845276c961b9dcf92861c255d3d26.tar.gz
ports-727d1ed22b5845276c961b9dcf92861c255d3d26.zip
Fix build in the face of updated taglib, changes tellico, etc.
This is fallout in the KF5 5.72 exp-run, but otherwise unrelated to the KF5 upgrade. PR: 247907
Notes
Notes: svn path=/head/; revision=542528
Diffstat (limited to 'misc/tellico')
-rw-r--r--misc/tellico/Makefile2
-rw-r--r--misc/tellico/files/patch-CMakeLists.txt32
-rw-r--r--misc/tellico/pkg-descr2
3 files changed, 34 insertions, 2 deletions
diff --git a/misc/tellico/Makefile b/misc/tellico/Makefile
index e5e18e9cdc1d..c4429d089042 100644
--- a/misc/tellico/Makefile
+++ b/misc/tellico/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tellico
DISTVERSION= 3.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc kde
MASTER_SITES= http://tellico-project.org/files/
diff --git a/misc/tellico/files/patch-CMakeLists.txt b/misc/tellico/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..79772f728f1e
--- /dev/null
+++ b/misc/tellico/files/patch-CMakeLists.txt
@@ -0,0 +1,32 @@
+Update to taglib changes what CMake variables are defined (it now produces
+modern CMake bits, but forgets backwards compatibility).
+
+This cascades to the weak FindCDIO module, which was now missing
+library -L flags it needed.
+
+--- CMakeLists.txt.orig 2020-07-18 20:19:02 UTC
++++ CMakeLists.txt
+@@ -127,8 +127,13 @@ set_package_properties(Taglib PROPERTIES
+ URL "https://taglib.org/"
+ TYPE OPTIONAL)
+ if(TAGLIB_FOUND)
+- add_definitions(${TAGLIB_CFLAGS})
+- include_directories(${TAGLIB_INCLUDES})
++ if(TAGLIB_LIBRARIES)
++ # Older taglib
++ add_definitions(${TAGLIB_CFLAGS})
++ include_directories(${TAGLIB_INCLUDES})
++ else()
++ set(TAGLIB_LIBRARIES Taglib::Taglib)
++ endif()
+ endif(TAGLIB_FOUND)
+
+ find_package(Yaz 2.0)
+@@ -171,6 +176,7 @@ set_package_properties(CDIO PROPERTIES
+ TYPE OPTIONAL)
+ if(CDIO_FOUND)
+ include_directories(${CDIO_INCLUDE_DIRS})
++ link_directories(${CDIO_libiso9660_LIBDIR} ${CDIO_libcdio_LIBDIR})
+ endif(CDIO_FOUND)
+
+ find_package(Csv 3.0)
diff --git a/misc/tellico/pkg-descr b/misc/tellico/pkg-descr
index 98f29aa89a98..1781f720236d 100644
--- a/misc/tellico/pkg-descr
+++ b/misc/tellico/pkg-descr
@@ -2,4 +2,4 @@ Tellico is a KDE application for organizing your collections. It provides
default templates for books, bibliographies, videos, music, video games,
coins, stamps, trading cards, comic books, and wines.
-WWW: http://tellico-project.org
+WWW: https://tellico-project.org