aboutsummaryrefslogtreecommitdiff
path: root/misc/tlci
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-09-15 19:58:54 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-09-15 19:58:54 +0000
commit08d7b738f1ee25e417f73a1e70256d2c1a166958 (patch)
treef920ab8ebc30f7715167d9e85407502daf7ea190 /misc/tlci
parentb4a2d2ae31f03c153c7a249c72c99b6123c7244e (diff)
downloadports-08d7b738f1ee25e417f73a1e70256d2c1a166958.tar.gz
ports-08d7b738f1ee25e417f73a1e70256d2c1a166958.zip
Add misc/tlci: Tiny lambda calculus interpreter in C99
PR: 249344 Submitted by: Nico Sonack <nsonack@outlook.com>
Notes
Notes: svn path=/head/; revision=548745
Diffstat (limited to 'misc/tlci')
-rw-r--r--misc/tlci/Makefile24
-rw-r--r--misc/tlci/distinfo3
-rw-r--r--misc/tlci/pkg-descr4
3 files changed, 31 insertions, 0 deletions
diff --git a/misc/tlci/Makefile b/misc/tlci/Makefile
new file mode 100644
index 000000000000..2cf3cf863aaf
--- /dev/null
+++ b/misc/tlci/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= tlci
+DISTVERSION= 0.1.0.2
+CATEGORIES= misc
+MASTER_SITES= https://gitlab.com/herrhotzenplotz/tlci/
+
+MAINTAINER= nsonack@outlook.com
+COMMENT= Tiny Lambda Calculus interpreter
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITLAB= yes
+GL_ACCOUNT= herrhotzenplotz
+GL_COMMIT= 4a3dd51a872f36a513f06efa475922259dee91f1
+
+PLIST_FILES= ${PREFIX}/bin/tlci \
+ ${PREFIX}/man/man8/tlci.8.gz
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/tlci
+
+.include <bsd.port.mk>
diff --git a/misc/tlci/distinfo b/misc/tlci/distinfo
new file mode 100644
index 000000000000..e5b6a789993e
--- /dev/null
+++ b/misc/tlci/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1600187213
+SHA256 (herrhotzenplotz-tlci-4a3dd51a872f36a513f06efa475922259dee91f1_GL0.tar.gz) = f4cd58bd4c2e5f6a8af61ec6a1a87180ac3486738d5c8d4df5736541bfaa94dc
+SIZE (herrhotzenplotz-tlci-4a3dd51a872f36a513f06efa475922259dee91f1_GL0.tar.gz) = 18410
diff --git a/misc/tlci/pkg-descr b/misc/tlci/pkg-descr
new file mode 100644
index 000000000000..7bb3a6eb3a20
--- /dev/null
+++ b/misc/tlci/pkg-descr
@@ -0,0 +1,4 @@
+The tiny lambda calculus interpreter is a portable interpreter
+for an untyped lambda calculus in C99.
+
+WWW: https://gitlab.com/herrhotzenplotz/tlci