aboutsummaryrefslogtreecommitdiff
path: root/misc/xplr/Makefile.crates
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2023-05-25 00:11:20 +0000
committerLewis Cook <lcook@FreeBSD.org>2023-05-25 01:35:03 +0000
commit26f844b5d4560b36584ad7c9d14a1a826203c9ac (patch)
tree90654668883d167c40a7e06c3f9a5b1aba3736be /misc/xplr/Makefile.crates
parent3fe526aea8df4870d6bef3edc4506fe66a955856 (diff)
downloadports-26f844b5d4560b36584ad7c9d14a1a826203c9ac.tar.gz
ports-26f844b5d4560b36584ad7c9d14a1a826203c9ac.zip
misc/xplr: Update to 0.21.2
Diffstat (limited to 'misc/xplr/Makefile.crates')
-rw-r--r--misc/xplr/Makefile.crates123
1 files changed, 60 insertions, 63 deletions
diff --git a/misc/xplr/Makefile.crates b/misc/xplr/Makefile.crates
index c45c10e3f9ba..f61e882a01db 100644
--- a/misc/xplr/Makefile.crates
+++ b/misc/xplr/Makefile.crates
@@ -1,45 +1,40 @@
CARGO_CRATES= ahash-0.7.6 \
- aho-corasick-0.7.20 \
+ aho-corasick-1.0.1 \
android_system_properties-0.1.5 \
anes-0.1.6 \
ansi-to-tui-3.0.0 \
- anstyle-0.3.5 \
- anyhow-1.0.70 \
+ anstyle-1.0.0 \
+ anyhow-1.0.71 \
arrayvec-0.7.2 \
- assert_cmd-2.0.10 \
+ assert_cmd-2.0.11 \
atty-0.2.14 \
autocfg-1.1.0 \
beef-0.5.2 \
bitflags-1.3.2 \
bstr-0.2.17 \
- bstr-1.4.0 \
- bumpalo-3.12.0 \
+ bstr-1.5.0 \
+ bumpalo-3.12.2 \
cassowary-0.3.0 \
cast-0.3.0 \
cc-1.0.79 \
cfg-if-1.0.0 \
chrono-0.4.24 \
- ciborium-0.2.0 \
- ciborium-io-0.2.0 \
- ciborium-ll-0.2.0 \
- clap-3.2.23 \
+ ciborium-0.2.1 \
+ ciborium-io-0.2.1 \
+ ciborium-ll-0.2.1 \
+ clap-3.2.25 \
clap_lex-0.2.4 \
- codespan-reporting-0.11.1 \
- core-foundation-sys-0.8.3 \
+ core-foundation-sys-0.8.4 \
criterion-0.4.0 \
criterion-plot-0.5.0 \
crossbeam-0.8.2 \
- crossbeam-channel-0.5.7 \
+ crossbeam-channel-0.5.8 \
crossbeam-deque-0.8.3 \
crossbeam-epoch-0.9.14 \
crossbeam-queue-0.3.8 \
crossbeam-utils-0.8.15 \
crossterm-0.26.1 \
crossterm_winapi-0.9.0 \
- cxx-1.0.93 \
- cxx-build-1.0.93 \
- cxxbridge-flags-1.0.93 \
- cxxbridge-macro-1.0.93 \
darling-0.14.4 \
darling_core-0.14.4 \
darling_macro-0.14.4 \
@@ -48,39 +43,37 @@ CARGO_CRATES= ahash-0.7.6 \
derive_builder_core-0.11.2 \
derive_builder_macro-0.11.2 \
difflib-0.4.0 \
- dirs-5.0.0 \
+ dirs-5.0.1 \
dirs-next-2.0.0 \
- dirs-sys-0.4.0 \
+ dirs-sys-0.4.1 \
dirs-sys-next-0.1.2 \
doc-comment-0.3.3 \
either-1.8.1 \
- env_logger-0.9.3 \
erased-serde-0.3.25 \
fnv-1.0.7 \
fuzzy-matcher-0.3.7 \
- gethostname-0.4.1 \
- getrandom-0.2.8 \
+ gethostname-0.4.3 \
+ getrandom-0.2.9 \
half-1.8.2 \
hashbrown-0.12.3 \
hermit-abi-0.1.19 \
hermit-abi-0.2.6 \
humansize-2.1.3 \
- humantime-2.1.0 \
- iana-time-zone-0.1.54 \
- iana-time-zone-haiku-0.1.1 \
+ iana-time-zone-0.1.56 \
+ iana-time-zone-haiku-0.1.2 \
ident_case-1.0.1 \
indexmap-1.9.3 \
itertools-0.10.5 \
itoa-1.0.6 \
- js-sys-0.3.61 \
+ jf-0.3.1 \
+ js-sys-0.3.63 \
lazy_static-1.4.0 \
- libc-0.2.140 \
- libm-0.2.6 \
- link-cplusplus-1.0.8 \
+ libc-0.2.144 \
+ libm-0.2.7 \
lock_api-0.4.9 \
log-0.4.17 \
- lscolors-0.13.0 \
- lua-src-544.0.1 \
+ lscolors-0.14.0 \
+ lua-src-546.0.0 \
luajit-src-210.4.5+resty2cf5186 \
memchr-2.5.0 \
memoffset-0.6.5 \
@@ -89,12 +82,11 @@ CARGO_CRATES= ahash-0.7.6 \
mime_guess-2.0.4 \
minimal-lexical-0.2.1 \
mio-0.8.6 \
- mlua-0.8.8 \
+ mlua-0.8.9 \
natord-1.0.9 \
nix-0.24.3 \
nix-0.25.1 \
nom-7.1.3 \
- nu-ansi-term-0.46.0 \
nu-ansi-term-0.47.0 \
num-integer-0.1.45 \
num-traits-0.2.15 \
@@ -102,41 +94,39 @@ CARGO_CRATES= ahash-0.7.6 \
num_threads-0.1.6 \
once_cell-1.17.1 \
oorandom-11.1.3 \
+ option-ext-0.2.0 \
os_str_bytes-6.5.0 \
- overload-0.1.1 \
parking_lot-0.12.1 \
parking_lot_core-0.9.7 \
- path-absolutize-3.0.14 \
- path-dedot-3.0.18 \
+ path-absolutize-3.1.0 \
+ path-dedot-3.1.0 \
pin-utils-0.1.0 \
- pkg-config-0.3.26 \
+ pkg-config-0.3.27 \
plotters-0.3.4 \
plotters-backend-0.3.4 \
plotters-svg-0.3.3 \
- predicates-3.0.2 \
+ predicates-3.0.3 \
predicates-core-1.0.6 \
predicates-tree-1.0.9 \
- proc-macro2-1.0.53 \
- quote-1.0.26 \
+ proc-macro2-1.0.58 \
+ quote-1.0.27 \
ratatui-0.20.1 \
rayon-1.7.0 \
rayon-core-1.11.0 \
redox_syscall-0.2.16 \
redox_users-0.4.3 \
- regex-1.7.3 \
+ regex-1.8.1 \
regex-automata-0.1.10 \
- regex-syntax-0.6.29 \
+ regex-syntax-0.7.1 \
rustc-hash-1.1.0 \
rustversion-1.0.12 \
ryu-1.0.13 \
same-file-1.0.6 \
scopeguard-1.1.0 \
- scratch-1.0.5 \
- serde-1.0.158 \
- serde_derive-1.0.158 \
- serde_json-1.0.94 \
- serde_yaml-0.9.19 \
- shlex-1.1.0 \
+ serde-1.0.163 \
+ serde_derive-1.0.163 \
+ serde_json-1.0.96 \
+ serde_yaml-0.9.21 \
signal-hook-0.3.15 \
signal-hook-mio-0.2.3 \
signal-hook-registry-1.4.1 \
@@ -146,18 +136,17 @@ CARGO_CRATES= ahash-0.7.6 \
snailquote-0.3.1 \
strsim-0.10.0 \
syn-1.0.109 \
- syn-2.0.10 \
+ syn-2.0.16 \
term-0.7.0 \
- termcolor-1.2.0 \
termtree-0.4.1 \
textwrap-0.16.0 \
thiserror-1.0.40 \
thiserror-impl-1.0.40 \
thread_local-1.1.7 \
time-0.1.45 \
- time-0.3.20 \
- time-core-0.1.0 \
- time-macros-0.2.8 \
+ time-0.3.21 \
+ time-core-0.1.1 \
+ time-macros-0.2.9 \
timer-0.2.0 \
tinytemplate-1.2.1 \
tui-input-0.7.0 \
@@ -168,7 +157,7 @@ CARGO_CRATES= ahash-0.7.6 \
unicode-segmentation-1.10.1 \
unicode-width-0.1.10 \
unicode_categories-0.1.1 \
- unsafe-libyaml-0.2.7 \
+ unsafe-libyaml-0.2.8 \
utf8parse-0.2.1 \
version_check-0.9.4 \
vte-0.11.0 \
@@ -177,25 +166,33 @@ CARGO_CRATES= ahash-0.7.6 \
walkdir-2.3.3 \
wasi-0.10.0+wasi-snapshot-preview1 \
wasi-0.11.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.84 \
- wasm-bindgen-backend-0.2.84 \
- wasm-bindgen-macro-0.2.84 \
- wasm-bindgen-macro-support-0.2.84 \
- wasm-bindgen-shared-0.2.84 \
- web-sys-0.3.61 \
+ wasm-bindgen-0.2.86 \
+ wasm-bindgen-backend-0.2.86 \
+ wasm-bindgen-macro-0.2.86 \
+ wasm-bindgen-macro-support-0.2.86 \
+ wasm-bindgen-shared-0.2.86 \
+ web-sys-0.3.63 \
which-4.4.0 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-util-0.1.5 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
- windows-0.43.0 \
- windows-0.46.0 \
+ windows-0.48.0 \
windows-sys-0.45.0 \
+ windows-sys-0.48.0 \
windows-targets-0.42.2 \
+ windows-targets-0.48.0 \
windows_aarch64_gnullvm-0.42.2 \
+ windows_aarch64_gnullvm-0.48.0 \
windows_aarch64_msvc-0.42.2 \
+ windows_aarch64_msvc-0.48.0 \
windows_i686_gnu-0.42.2 \
+ windows_i686_gnu-0.48.0 \
windows_i686_msvc-0.42.2 \
+ windows_i686_msvc-0.48.0 \
windows_x86_64_gnu-0.42.2 \
+ windows_x86_64_gnu-0.48.0 \
windows_x86_64_gnullvm-0.42.2 \
- windows_x86_64_msvc-0.42.2
+ windows_x86_64_gnullvm-0.48.0 \
+ windows_x86_64_msvc-0.42.2 \
+ windows_x86_64_msvc-0.48.0