aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-11-07 21:51:14 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-11-07 21:51:14 +0000
commit020349626824c725f56c5940811118513a4d1d45 (patch)
tree35a2df170ed9781cc70ed69c4c74cf515dc10922 /misc
parentfc5805c46b3bbbdf9ffb68cf99d69812c55a6d2b (diff)
downloadports-020349626824c725f56c5940811118513a4d1d45.tar.gz
ports-020349626824c725f56c5940811118513a4d1d45.zip
- add Geo::Coder::Google 0.03
Geo::Coder::Google provides a geocoding functionality using Google Maps API. WWW: http://search.cpan.org/dist/Geo-Coder-Google/
Notes
Notes: svn path=/head/; revision=222522
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Coder-Google/Makefile35
-rw-r--r--misc/p5-Geo-Coder-Google/distinfo3
-rw-r--r--misc/p5-Geo-Coder-Google/pkg-descr3
-rw-r--r--misc/p5-Geo-Coder-Google/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d7657c5c2e39..3ed0176960db 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -408,6 +408,7 @@
SUBDIR += p5-File-CounterFile
SUBDIR += p5-File-Sort
SUBDIR += p5-Geo-Cache
+ SUBDIR += p5-Geo-Coder-Google
SUBDIR += p5-Geo-Postcodes
SUBDIR += p5-Geo-Postcodes-DK
SUBDIR += p5-Geo-Postcodes-NO
diff --git a/misc/p5-Geo-Coder-Google/Makefile b/misc/p5-Geo-Coder-Google/Makefile
new file mode 100644
index 000000000000..73f7bb409b2e
--- /dev/null
+++ b/misc/p5-Geo-Coder-Google/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Geo-Coder-Google
+# Date created: 2008-11-06
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-Google
+PORTVERSION= 0.03
+CATEGORIES= misc perl5 geography
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Google Maps Geocoding API
+
+RUN_DEPENDS= p5-YAML-Syck>=0.1:${PORTSDIR}/textproc/p5-YAML-Syck \
+ p5-libwww>=5.5:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::Google.3
+
+# The coordinates can be updated by anyone. It might change again in the future.
+post-patch:
+ @${REINPLACE_CMD} -e 's/-122.397323/-122.397711/' ${WRKSRC}/t/01_live.t
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Encode>=0:${PORTSDIR}/converters/p5-Encode
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-Google/distinfo b/misc/p5-Geo-Coder-Google/distinfo
new file mode 100644
index 000000000000..84a91606545b
--- /dev/null
+++ b/misc/p5-Geo-Coder-Google/distinfo
@@ -0,0 +1,3 @@
+MD5 (Geo-Coder-Google-0.03.tar.gz) = d10c3b978d7c0a83306126363fec5eb5
+SHA256 (Geo-Coder-Google-0.03.tar.gz) = 2e2cdb1e14eceadb22fd0b13f7bb46122b079503d7f13674db7b8214af46ba74
+SIZE (Geo-Coder-Google-0.03.tar.gz) = 3574
diff --git a/misc/p5-Geo-Coder-Google/pkg-descr b/misc/p5-Geo-Coder-Google/pkg-descr
new file mode 100644
index 000000000000..45b736ee45e2
--- /dev/null
+++ b/misc/p5-Geo-Coder-Google/pkg-descr
@@ -0,0 +1,3 @@
+Geo::Coder::Google provides a geocoding functionality using Google Maps API.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-Google/
diff --git a/misc/p5-Geo-Coder-Google/pkg-plist b/misc/p5-Geo-Coder-Google/pkg-plist
new file mode 100644
index 000000000000..79be12e365f1
--- /dev/null
+++ b/misc/p5-Geo-Coder-Google/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Geo/Coder/Google.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Google/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo