aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-16 21:41:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-16 21:41:38 +0000
commit194fc80cd2300ec6947eeb80a9d27935a791108f (patch)
tree44abc6d60661b0688c415a2b33bcc5aed8266a4f /misc
parentb906ced0b0141e504419fc9a0f38588539777637 (diff)
downloadports-194fc80cd2300ec6947eeb80a9d27935a791108f.tar.gz
ports-194fc80cd2300ec6947eeb80a9d27935a791108f.zip
- Update to 1.41.8
PR: 136795 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
Notes
Notes: svn path=/head/; revision=237946
Diffstat (limited to 'misc')
-rw-r--r--misc/e2fsprogs-libblkid/Makefile5
-rw-r--r--misc/e2fsprogs-libuuid/Makefile7
2 files changed, 7 insertions, 5 deletions
diff --git a/misc/e2fsprogs-libblkid/Makefile b/misc/e2fsprogs-libblkid/Makefile
index 03045e65e283..bf677ae70cb2 100644
--- a/misc/e2fsprogs-libblkid/Makefile
+++ b/misc/e2fsprogs-libblkid/Makefile
@@ -19,6 +19,7 @@ CONFIGURE_ARGS= --enable-elf-shlibs
WITHOUT_NLS= yes
MASTERDIR= ${.CURDIR}/../../sysutils/e2fsprogs
MAKE_ARGS= LIB_SUBDIRS=lib/blkid
+USE_GMAKE= yes
USE_LDCONFIG= yes
ALL_TARGET= libs
INSTALL_TARGET= install install-shlibs
@@ -32,7 +33,7 @@ pre-build:
${MKDIR} ${WRKSRC}/lib/blkid/elfshared
post-build:
- cd ${WRKSRC}/lib/uuid && ${MAKE}
- cd ${INSTALL_WRKSRC} && ${MAKE} check
+ cd ${WRKSRC}/lib/uuid && ${GMAKE}
+ cd ${INSTALL_WRKSRC} && ${GMAKE} check
.include "${MASTERDIR}/Makefile"
diff --git a/misc/e2fsprogs-libuuid/Makefile b/misc/e2fsprogs-libuuid/Makefile
index 2b1179ea698b..d99af0db816f 100644
--- a/misc/e2fsprogs-libuuid/Makefile
+++ b/misc/e2fsprogs-libuuid/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTREVISION= 1
+PORTREVISION= 0
CATEGORIES= misc devel
PKGNAMESUFFIX= -libuuid
@@ -18,6 +18,7 @@ CONFIGURE_ARGS= --enable-elf-shlibs
WITHOUT_NLS= yes
MASTERDIR= ${.CURDIR}/../../sysutils/e2fsprogs
MAKE_ARGS= LIB_SUBDIRS=lib/uuid
+USE_GMAKE= yes
USE_LDCONFIG= yes
ALL_TARGET= libs
INSTALL_TARGET= install install-shlibs
@@ -47,8 +48,8 @@ pre-build:
# failure to launch uuidd is fine (one might be running, or we may lack
# privileges); if it works, it'll quit after 50 seconds
post-build:
- cd ${WRKSRC}/misc && ${MAKE} uuidgen uuidgen.1 uuidd uuidd.8
- ( ulimit -t 5 ; cd ${INSTALL_WRKSRC} && { ../../misc/uuidd -T50 || true ; ${MAKE} check ; } )
+ cd ${WRKSRC}/misc && ${GMAKE} uuidgen uuidgen.1 uuidd uuidd.8
+ cd ${INSTALL_WRKSRC} && ( ulimit -t 5 && ${GMAKE} check )
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/misc/uuidgen ${PREFIX}/bin/