aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-06-20 17:46:19 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-06-20 17:47:20 +0000
commit3aee942fbf503522990bf84545bfe10e6141f016 (patch)
tree897ffc43671952f5e098b66ab79a5dc3795e3144 /misc
parent19ef893e159ac8729af50a9c8f48b0369583266b (diff)
downloadports-3aee942fbf503522990bf84545bfe10e6141f016.tar.gz
ports-3aee942fbf503522990bf84545bfe10e6141f016.zip
misc/mnn: Update 1.1.0 -> 1.2.0
Reported by: portscout
Diffstat (limited to 'misc')
-rw-r--r--misc/mnn/Makefile3
-rw-r--r--misc/mnn/distinfo6
-rw-r--r--misc/mnn/files/patch-CMakeLists.txt6
-rw-r--r--misc/mnn/files/patch-tools_converter_CMakeLists.txt8
-rw-r--r--misc/mnn/files/patch-tools_train_CMakeLists.txt26
-rw-r--r--misc/mnn/pkg-plist1
6 files changed, 29 insertions, 21 deletions
diff --git a/misc/mnn/Makefile b/misc/mnn/Makefile
index 973caf4b88bd..880e3ce89689 100644
--- a/misc/mnn/Makefile
+++ b/misc/mnn/Makefile
@@ -1,6 +1,5 @@
PORTNAME= mnn
-DISTVERSION= 1.1.0
-PORTREVISION= 2
+DISTVERSION= 1.2.0
CATEGORIES= misc # machine-learning
MAINTAINER= yuri@FreeBSD.org
diff --git a/misc/mnn/distinfo b/misc/mnn/distinfo
index 5a82b9131daf..00de57b88da2 100644
--- a/misc/mnn/distinfo
+++ b/misc/mnn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604696072
-SHA256 (alibaba-MNN-1.1.0_GH0.tar.gz) = 51ba1390a73ed042e38cefa03d62502bfa6e808fe2258cf678f67faa7361099a
-SIZE (alibaba-MNN-1.1.0_GH0.tar.gz) = 6363974
+TIMESTAMP = 1624209262
+SHA256 (alibaba-MNN-1.2.0_GH0.tar.gz) = b0e32d28e1b1c64904d6c1f810a48238430cf4ef5e8fdcd2ea4600e52c8a82ef
+SIZE (alibaba-MNN-1.2.0_GH0.tar.gz) = 103892968
diff --git a/misc/mnn/files/patch-CMakeLists.txt b/misc/mnn/files/patch-CMakeLists.txt
index d690a6beaf55..b817e27b5a62 100644
--- a/misc/mnn/files/patch-CMakeLists.txt
+++ b/misc/mnn/files/patch-CMakeLists.txt
@@ -1,7 +1,7 @@
---- CMakeLists.txt.orig 2020-09-20 17:36:43 UTC
+--- CMakeLists.txt.orig 2021-06-11 09:17:13 UTC
+++ CMakeLists.txt
-@@ -268,7 +268,6 @@ include_directories(${CMAKE_CURRENT_LIST_DIR}/include/
- ${CMAKE_CURRENT_LIST_DIR}/source/
+@@ -304,7 +304,6 @@ include_directories(${CMAKE_CURRENT_LIST_DIR}/include/
+ ${CMAKE_CURRENT_LIST_DIR}/codegen/
${CMAKE_CURRENT_LIST_DIR}/schema/current/
${CMAKE_CURRENT_LIST_DIR}/3rd_party/
- ${CMAKE_CURRENT_LIST_DIR}/3rd_party/flatbuffers/include
diff --git a/misc/mnn/files/patch-tools_converter_CMakeLists.txt b/misc/mnn/files/patch-tools_converter_CMakeLists.txt
index 4d549b285fa7..c82129bedf8c 100644
--- a/misc/mnn/files/patch-tools_converter_CMakeLists.txt
+++ b/misc/mnn/files/patch-tools_converter_CMakeLists.txt
@@ -1,10 +1,10 @@
---- tools/converter/CMakeLists.txt.orig 2020-05-23 09:34:50 UTC
+--- tools/converter/CMakeLists.txt.orig 2021-06-11 09:17:13 UTC
+++ tools/converter/CMakeLists.txt
-@@ -40,6 +40,7 @@ IF(MNN_BUILD_CONVERTER)
+@@ -43,6 +43,7 @@ IF(MNN_BUILD_CONVERTER)
IF(MNN_BUILD_SHARED_LIBS)
- add_library(MNNConvertDeps SHARED ${COMMON_SRC} ${MNN_CONVERTER_BACKENDS_OBJECTS} ${CMAKE_CURRENT_LIST_DIR}/../../3rd_party/flatbuffers/src/util.cpp)
+ add_library(MNNConvertDeps SHARED ${COMMON_SRC} ${MNN_CONVERTER_BACKENDS_OBJECTS} ${CMAKE_CURRENT_LIST_DIR}/../../3rd_party/flatbuffers/src/util.cpp $<TARGET_OBJECTS:MNNUtils>)
add_dependencies(MNNConvertDeps MNN)
+ install(TARGETS MNNConvertDeps LIBRARY DESTINATION lib)
ELSE()
- add_library(MNNConvertDeps STATIC ${COMMON_SRC} ${MNN_CONVERTER_BACKENDS_OBJECTS} ${CMAKE_CURRENT_LIST_DIR}/../../3rd_party/flatbuffers/src/util.cpp)
+ add_library(MNNConvertDeps STATIC ${COMMON_SRC} ${MNN_CONVERTER_BACKENDS_OBJECTS} ${CMAKE_CURRENT_LIST_DIR}/../../3rd_party/flatbuffers/src/util.cpp)
ENDIF()
diff --git a/misc/mnn/files/patch-tools_train_CMakeLists.txt b/misc/mnn/files/patch-tools_train_CMakeLists.txt
index aacece0f36a7..94555bc38aec 100644
--- a/misc/mnn/files/patch-tools_train_CMakeLists.txt
+++ b/misc/mnn/files/patch-tools_train_CMakeLists.txt
@@ -1,10 +1,18 @@
---- tools/train/CMakeLists.txt.orig 2020-05-23 09:17:28 UTC
+--- tools/train/CMakeLists.txt.orig 2021-06-11 09:17:13 UTC
+++ tools/train/CMakeLists.txt
-@@ -28,6 +28,7 @@ else()
- add_library(MNNTrain ${MNN_LIBARY_TYPE} ${GRAD} ${BASIC_INCLUDE} ${PARAMETER} ${OPTIMIZER} ${MODULES} ${DATALOADER} ${TRANSFORMER} ${MODELS} ${DATASETS})
- endif()
- target_link_libraries(MNNTrain ${MNN_DEPS})
-+install(TARGETS MNNTrain LIBRARY DESTINATION lib)
-
- add_executable(transformer.out ${CMAKE_CURRENT_LIST_DIR}/source/exec/transformerExecution.cpp)
- target_link_libraries(transformer.out MNNTrain)
+@@ -30,6 +30,7 @@ endif()
+ IF(MNN_SEP_BUILD)
+ add_library(MNNTrain SHARED ${MNN_TRAIN_SRCS})
+ target_link_libraries(MNNTrain MNN MNN_Express)
++ install(TARGETS MNNTrain LIBRARY DESTINATION lib)
+ ELSE()
+ add_library(MNNTrain OBJECT ${MNN_TRAIN_SRCS})
+ ENDIF()
+@@ -56,6 +57,7 @@ list(APPEND MNN_TRAIN_TOOLS dataTransformer.out)
+ list(APPEND MNN_TRAIN_TOOLS runTrainDemo.out)
+ foreach(TARGET ${MNN_TRAIN_TOOLS})
+ target_link_libraries(${TARGET} PRIVATE ${MNN_DEPS})
++ install(TARGETS MNNTrain LIBRARY DESTINATION lib)
+ IF(MNN_SEP_BUILD)
+ target_link_libraries(${TARGET} PRIVATE MNNTrain)
+ ENDIF()
diff --git a/misc/mnn/pkg-plist b/misc/mnn/pkg-plist
index 28e6c4d4ebec..b6b8563fafbd 100644
--- a/misc/mnn/pkg-plist
+++ b/misc/mnn/pkg-plist
@@ -27,6 +27,7 @@ include/MNN/Tensor.hpp
include/MNN/expr/Expr.hpp
include/MNN/expr/ExprCreator.hpp
include/MNN/expr/MathOp.hpp
+include/MNN/expr/Module.hpp
include/MNN/expr/NeuralNetWorkOp.hpp
include/MNN/expr/Optimizer.hpp
lib/libMNN.so