aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-13 00:34:19 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-09-13 00:34:19 +0000
commit3f7c619439e8053fe6d83639ae44c2f79dabcc45 (patch)
tree7cdcbf6d99342c27eb84358916a8b67459820f4a /misc
parent828d6b7645473b8f034c1eb3c63343da843c2405 (diff)
downloadports-3f7c619439e8053fe6d83639ae44c2f79dabcc45.tar.gz
ports-3f7c619439e8053fe6d83639ae44c2f79dabcc45.zip
o style changes
o honor PREFIX PR: 30390 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=47776
Diffstat (limited to 'misc')
-rw-r--r--misc/sh-utils/Makefile30
1 files changed, 25 insertions, 5 deletions
diff --git a/misc/sh-utils/Makefile b/misc/sh-utils/Makefile
index 7cacdcdb1cc6..5883d7b8f6b1 100644
--- a/misc/sh-utils/Makefile
+++ b/misc/sh-utils/Makefile
@@ -15,13 +15,15 @@ MAINTAINER= clefevre@citeweb.net
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
-GNU_CONFIGURE= yes
+# Global variables
+#
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g
USE_GMAKE= yes
-
-INSTALL_INFO?= install-info
+# PREFIX isn't honored. force it w/ prefix.
+MAKE_ARGS= prefix=${PREFIX}
MAN1= gbasename.1 gchroot.1 gdate.1 gdirname.1 gecho.1 genv.1 \
gexpr.1 gfalse.1 ggroups.1 ghostid.1 ghostname.1 gid.1 \
@@ -29,15 +31,33 @@ MAN1= gbasename.1 gchroot.1 gdate.1 gdirname.1 gecho.1 genv.1 \
gprintf.1 gpwd.1 gsleep.1 gstty.1 gsu.1 gtee.1 gtest.1 \
gtrue.1 gtty.1 guname.1 gusers.1 gwho.1 gwhoami.1 gyes.1
-post-extract:
+# Local variables
+#
+
+INSTALL_INFO?= install-info
+
+# Post-extract
+#
+
+post-extract: remove-info-files
+
+remove-info-files:
@${RM} -f ${WRKSRC}/doc/${PORTNAME}.info*
+# Patch
+#
+
do-patch:
.if !defined(WITH_SUID)
@${PERL} -pi -e "s/u\+s/u\+w/g" ${WRKSRC}/src/Makefile.in
.endif
-post-install:
+# Post-install
+#
+
+post-install: install-info
+
+install-info:
@${INSTALL_INFO} ${PREFIX}/info/${PORTNAME}.info ${PREFIX}/info/dir
.include <bsd.port.mk>