aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2001-03-20 13:35:56 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2001-03-20 13:35:56 +0000
commit5d4bcffd01271e9da4db5a4a7df59d3511bae938 (patch)
treeaa76699095450673d91d6db540f66414f119bcdf /misc
parent2d45762f817af164cb28b3f4ebbd949cb321f05e (diff)
downloadports-5d4bcffd01271e9da4db5a4a7df59d3511bae938.tar.gz
ports-5d4bcffd01271e9da4db5a4a7df59d3511bae938.zip
Add dummy getmntent() func.
PR: ports/24570 Submitted by: Roman Shterenzon<roman@xpert.com>
Notes
Notes: svn path=/head/; revision=40104
Diffstat (limited to 'misc')
-rw-r--r--misc/rpm/Makefile2
-rw-r--r--misc/rpm/files/patch-bi18
-rw-r--r--misc/rpm/files/patch-bj14
3 files changed, 30 insertions, 4 deletions
diff --git a/misc/rpm/Makefile b/misc/rpm/Makefile
index 29ca9a71b1c9..28b2e845d576 100644
--- a/misc/rpm/Makefile
+++ b/misc/rpm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rpm
PORTVERSION= 3.0.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= misc
MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/ \
ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/
diff --git a/misc/rpm/files/patch-bi b/misc/rpm/files/patch-bi
index d4e23f73235b..2f4b57a890a3 100644
--- a/misc/rpm/files/patch-bi
+++ b/misc/rpm/files/patch-bi
@@ -1,6 +1,18 @@
---- lib/fs.c.orig Thu Nov 2 12:54:47 2000
-+++ lib/fs.c Thu Nov 2 12:55:32 2000
-@@ -129,8 +129,10 @@
+--- lib/fs.c.orig Wed Jun 14 21:34:30 2000
++++ lib/fs.c Tue Mar 20 22:24:58 2001
+@@ -12,6 +12,11 @@
+ /*@only@*/ /*@null@*/ static const char ** fsnames = NULL;
+ static int numFilesystems = 0;
+
++/* dummy getmntent() for FreeBSD */
++our_mntent *getmntent(FILE *filep) {
++ return NULL;
++}
++
+ void freeFilesystems(void)
+ {
+ if (filesystems) {
+@@ -129,8 +134,10 @@
# if GETMNTENT_ONE || GETMNTENT_TWO
mtab = fopen(MOUNTED, "r");
if (!mtab) {
diff --git a/misc/rpm/files/patch-bj b/misc/rpm/files/patch-bj
new file mode 100644
index 000000000000..b48019f66759
--- /dev/null
+++ b/misc/rpm/files/patch-bj
@@ -0,0 +1,14 @@
+--- system.h.orig Tue Mar 20 22:24:05 2001
++++ system.h Tue Mar 20 22:24:30 2001
+@@ -351,9 +351,9 @@
+ # elif HAVE_STRUCT_MNTTAB
+ # include <stdio.h>
+ # include <mnttab.h>
+- struct our_mntent {
++ typedef struct our_mntent {
+ char * our_mntdir;
+- };
++ } our_mntent;
+ struct our_mntent *getmntent(FILE *filep);
+ # define our_mntent struct our_mntent
+ # else