aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-26 09:11:26 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-26 09:11:26 +0000
commit7d3f37d405826fd4d7e67a0e5016be19a1ad99f9 (patch)
treedca6df5deb060bb30c22916895e2ab2b8996fc35 /misc
parentca3baf0899287b715233fa9678b55d3d06f58471 (diff)
downloadports-7d3f37d405826fd4d7e67a0e5016be19a1ad99f9.tar.gz
ports-7d3f37d405826fd4d7e67a0e5016be19a1ad99f9.zip
New port: misc/openhmd: API and drivers for immersive technology
Notes
Notes: svn path=/head/; revision=475352
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/openhmd/Makefile26
-rw-r--r--misc/openhmd/distinfo3
-rw-r--r--misc/openhmd/files/patch-CMakeLists.txt16
-rw-r--r--misc/openhmd/pkg-descr4
5 files changed, 50 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index a06d02c61fa7..8796332fb4f3 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -303,6 +303,7 @@
SUBDIR += opencyc
SUBDIR += openhab2
SUBDIR += openhab2-addons
+ SUBDIR += openhmd
SUBDIR += openmvg
SUBDIR += openr2
SUBDIR += orange3
diff --git a/misc/openhmd/Makefile b/misc/openhmd/Makefile
new file mode 100644
index 000000000000..5fd07f75121b
--- /dev/null
+++ b/misc/openhmd/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= OpenHMD
+DISTVERSION= 0.2.0-215
+DISTVERSIONSUFFIX= -g6f91c10
+CATEGORIES= misc
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= API and drivers for immersive technology
+
+LICENSE= BSL
+xLICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libhidapi.so:comms/hidapi
+
+USES= cmake:outsource
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/openhmd.h \
+ lib/libopenhmd.so \
+ lib/libopenhmd.so.0 \
+ lib/libopenhmd.so.0.1.0
+
+.include <bsd.port.mk>
diff --git a/misc/openhmd/distinfo b/misc/openhmd/distinfo
new file mode 100644
index 000000000000..0c9c39156162
--- /dev/null
+++ b/misc/openhmd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532595494
+SHA256 (OpenHMD-OpenHMD-0.2.0-215-g6f91c10_GH0.tar.gz) = 725f363ae2004d32594ef5b2877937718001e60908ff5dea4322bffaf4cdfc05
+SIZE (OpenHMD-OpenHMD-0.2.0-215-g6f91c10_GH0.tar.gz) = 116599
diff --git a/misc/openhmd/files/patch-CMakeLists.txt b/misc/openhmd/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..7862c1fb8e8c
--- /dev/null
+++ b/misc/openhmd/files/patch-CMakeLists.txt
@@ -0,0 +1,16 @@
+--- CMakeLists.txt.orig 2018-07-11 16:24:43 UTC
++++ CMakeLists.txt
+@@ -150,10 +150,10 @@ endif (UNIX)
+ link_libraries(${LIBS})
+ add_library(openhmd-shared SHARED ${openhmd_source_files})
+ SET_TARGET_PROPERTIES(openhmd-shared PROPERTIES OUTPUT_NAME openhmd CLEAN_DIRECT_OUTPUT 1 VERSION ${LIB_VERSION_STRING} SOVERSION ${LIB_VERSION_MAJOR})
+-add_library(openhmd-static STATIC ${openhmd_source_files})
+-SET_TARGET_PROPERTIES(openhmd-static PROPERTIES OUTPUT_NAME openhmd CLEAN_DIRECT_OUTPUT 1)
++#add_library(openhmd-static STATIC ${openhmd_source_files})
++#SET_TARGET_PROPERTIES(openhmd-static PROPERTIES OUTPUT_NAME openhmd CLEAN_DIRECT_OUTPUT 1)
+ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_CURRENT_DIR}/)
+
+ #install properties
+-install (TARGETS openhmd-shared openhmd-static DESTINATION lib)
++install (TARGETS openhmd-shared DESTINATION lib)
+ install (FILES include/openhmd.h DESTINATION include)
diff --git a/misc/openhmd/pkg-descr b/misc/openhmd/pkg-descr
new file mode 100644
index 000000000000..3f95317bf68b
--- /dev/null
+++ b/misc/openhmd/pkg-descr
@@ -0,0 +1,4 @@
+This project aims to provide a Free and Open Source API and drivers for
+immersive technology, such as head mounted displays with built in head tracking.
+
+WWW: https://github.com/OpenHMD/OpenHMD