aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2002-10-14 14:02:14 +0000
committerJames E. Housley <jeh@FreeBSD.org>2002-10-14 14:02:14 +0000
commitc5613691662aeecb8ba88de0edbe3298f9776584 (patch)
tree363d58b127f108309af25a0347bed7d94cae59ea /misc
parentdc15068a6d1ccc34fad3484ffd189a32bd831c37 (diff)
downloadports-c5613691662aeecb8ba88de0edbe3298f9776584.tar.gz
ports-c5613691662aeecb8ba88de0edbe3298f9776584.zip
The misc/amanda-{client,server} ports force user/group to operator.
This should be site-overridable. PR: 44032 Submitted-by: Phil Homewood <pdh@snapgear.com>
Notes
Notes: svn path=/head/; revision=68040
Diffstat (limited to 'misc')
-rw-r--r--misc/amanda-server/Makefile36
-rw-r--r--misc/amanda25-server/Makefile36
-rw-r--r--misc/amanda26-server/Makefile36
-rw-r--r--misc/amanda32-server/Makefile36
4 files changed, 132 insertions, 12 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 2b0852c3b031..9de0d2080bb6 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -41,8 +41,12 @@ pre-fetch:
@${ECHO} " The default is `uname -n`"
@${ECHO} " AMANDA_TAPE=tape to specify the default tape device"
@${ECHO} " The default is /dev/nrsa0"
- @${ECHO} " AMANDA_CONFIG=config to specify the default configuation"
+ @${ECHO} " AMANDA_CONFIG=config to specify the default configuration"
@${ECHO} " The default is user"
+ @${ECHO} " AMANDA_USER=user to specify the default user"
+ @${ECHO} " The default is operator"
+ @${ECHO} " AMANDA_GROUP=group to specify the default group"
+ @${ECHO} " The default is operator"
@${ECHO} ""
RUN_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
@@ -51,7 +55,6 @@ BUILD_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --with-user=operator --with-group=operator \
--without-client --disable-libtool --prefix=${PREFIX}
MAN8= amadmin.8 amcheck.8 amcheckdb.8 amcleanup.8 amdd.8 \
@@ -98,6 +101,18 @@ CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
.endif
+.if defined (AMANDA_USER)
+CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
+.else
+CONFIGURE_ARGS+= --with-user=operator
+.endif
+
+.if defined (AMANDA_GROUP)
+CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
+.else
+CONFIGURE_ARGS+= --with-group=operator
+.endif
+
#
# Before 4.0, pre-CAM scsiio.h existed
.if ${OSVERSION} < 400000
@@ -122,12 +137,15 @@ pre-fetch:
@${ECHO} " AMANDA_GNUTAR_LISTDIR=dir to specify the directory that"
@${ECHO} " the gnutar index files should live in"
@${ECHO} " The default is /var/amanda/gnutar-lists"
+ @${ECHO} " AMANDA_USER=user to specify the default user"
+ @${ECHO} " The default is operator"
+ @${ECHO} " AMANDA_GROUP=group to specify the default group"
+ @${ECHO} " The default is operator"
@${ECHO} ""
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --with-user=operator --with-group=operator \
--without-server --disable-libtool --prefix=${PREFIX}
MAN8= amanda.8 amrecover.8 amrestore.8
@@ -159,6 +177,18 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR}
.endif
+.if defined (AMANDA_USER)
+CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
+.else
+CONFIGURE_ARGS+= --with-user=operator
+.endif
+
+.if defined (AMANDA_GROUP)
+CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
+.else
+CONFIGURE_ARGS+= --with-group=operator
+.endif
+
.endif
.include <bsd.port.post.mk>
diff --git a/misc/amanda25-server/Makefile b/misc/amanda25-server/Makefile
index 2b0852c3b031..9de0d2080bb6 100644
--- a/misc/amanda25-server/Makefile
+++ b/misc/amanda25-server/Makefile
@@ -41,8 +41,12 @@ pre-fetch:
@${ECHO} " The default is `uname -n`"
@${ECHO} " AMANDA_TAPE=tape to specify the default tape device"
@${ECHO} " The default is /dev/nrsa0"
- @${ECHO} " AMANDA_CONFIG=config to specify the default configuation"
+ @${ECHO} " AMANDA_CONFIG=config to specify the default configuration"
@${ECHO} " The default is user"
+ @${ECHO} " AMANDA_USER=user to specify the default user"
+ @${ECHO} " The default is operator"
+ @${ECHO} " AMANDA_GROUP=group to specify the default group"
+ @${ECHO} " The default is operator"
@${ECHO} ""
RUN_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
@@ -51,7 +55,6 @@ BUILD_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --with-user=operator --with-group=operator \
--without-client --disable-libtool --prefix=${PREFIX}
MAN8= amadmin.8 amcheck.8 amcheckdb.8 amcleanup.8 amdd.8 \
@@ -98,6 +101,18 @@ CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
.endif
+.if defined (AMANDA_USER)
+CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
+.else
+CONFIGURE_ARGS+= --with-user=operator
+.endif
+
+.if defined (AMANDA_GROUP)
+CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
+.else
+CONFIGURE_ARGS+= --with-group=operator
+.endif
+
#
# Before 4.0, pre-CAM scsiio.h existed
.if ${OSVERSION} < 400000
@@ -122,12 +137,15 @@ pre-fetch:
@${ECHO} " AMANDA_GNUTAR_LISTDIR=dir to specify the directory that"
@${ECHO} " the gnutar index files should live in"
@${ECHO} " The default is /var/amanda/gnutar-lists"
+ @${ECHO} " AMANDA_USER=user to specify the default user"
+ @${ECHO} " The default is operator"
+ @${ECHO} " AMANDA_GROUP=group to specify the default group"
+ @${ECHO} " The default is operator"
@${ECHO} ""
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --with-user=operator --with-group=operator \
--without-server --disable-libtool --prefix=${PREFIX}
MAN8= amanda.8 amrecover.8 amrestore.8
@@ -159,6 +177,18 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR}
.endif
+.if defined (AMANDA_USER)
+CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
+.else
+CONFIGURE_ARGS+= --with-user=operator
+.endif
+
+.if defined (AMANDA_GROUP)
+CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
+.else
+CONFIGURE_ARGS+= --with-group=operator
+.endif
+
.endif
.include <bsd.port.post.mk>
diff --git a/misc/amanda26-server/Makefile b/misc/amanda26-server/Makefile
index 2b0852c3b031..9de0d2080bb6 100644
--- a/misc/amanda26-server/Makefile
+++ b/misc/amanda26-server/Makefile
@@ -41,8 +41,12 @@ pre-fetch:
@${ECHO} " The default is `uname -n`"
@${ECHO} " AMANDA_TAPE=tape to specify the default tape device"
@${ECHO} " The default is /dev/nrsa0"
- @${ECHO} " AMANDA_CONFIG=config to specify the default configuation"
+ @${ECHO} " AMANDA_CONFIG=config to specify the default configuration"
@${ECHO} " The default is user"
+ @${ECHO} " AMANDA_USER=user to specify the default user"
+ @${ECHO} " The default is operator"
+ @${ECHO} " AMANDA_GROUP=group to specify the default group"
+ @${ECHO} " The default is operator"
@${ECHO} ""
RUN_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
@@ -51,7 +55,6 @@ BUILD_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --with-user=operator --with-group=operator \
--without-client --disable-libtool --prefix=${PREFIX}
MAN8= amadmin.8 amcheck.8 amcheckdb.8 amcleanup.8 amdd.8 \
@@ -98,6 +101,18 @@ CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
.endif
+.if defined (AMANDA_USER)
+CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
+.else
+CONFIGURE_ARGS+= --with-user=operator
+.endif
+
+.if defined (AMANDA_GROUP)
+CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
+.else
+CONFIGURE_ARGS+= --with-group=operator
+.endif
+
#
# Before 4.0, pre-CAM scsiio.h existed
.if ${OSVERSION} < 400000
@@ -122,12 +137,15 @@ pre-fetch:
@${ECHO} " AMANDA_GNUTAR_LISTDIR=dir to specify the directory that"
@${ECHO} " the gnutar index files should live in"
@${ECHO} " The default is /var/amanda/gnutar-lists"
+ @${ECHO} " AMANDA_USER=user to specify the default user"
+ @${ECHO} " The default is operator"
+ @${ECHO} " AMANDA_GROUP=group to specify the default group"
+ @${ECHO} " The default is operator"
@${ECHO} ""
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --with-user=operator --with-group=operator \
--without-server --disable-libtool --prefix=${PREFIX}
MAN8= amanda.8 amrecover.8 amrestore.8
@@ -159,6 +177,18 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR}
.endif
+.if defined (AMANDA_USER)
+CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
+.else
+CONFIGURE_ARGS+= --with-user=operator
+.endif
+
+.if defined (AMANDA_GROUP)
+CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
+.else
+CONFIGURE_ARGS+= --with-group=operator
+.endif
+
.endif
.include <bsd.port.post.mk>
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index 2b0852c3b031..9de0d2080bb6 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -41,8 +41,12 @@ pre-fetch:
@${ECHO} " The default is `uname -n`"
@${ECHO} " AMANDA_TAPE=tape to specify the default tape device"
@${ECHO} " The default is /dev/nrsa0"
- @${ECHO} " AMANDA_CONFIG=config to specify the default configuation"
+ @${ECHO} " AMANDA_CONFIG=config to specify the default configuration"
@${ECHO} " The default is user"
+ @${ECHO} " AMANDA_USER=user to specify the default user"
+ @${ECHO} " The default is operator"
+ @${ECHO} " AMANDA_GROUP=group to specify the default group"
+ @${ECHO} " The default is operator"
@${ECHO} ""
RUN_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
@@ -51,7 +55,6 @@ BUILD_DEPENDS= ${LOCALBASE}/sbin/amrecover:${PORTSDIR}/misc/amanda-client
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --with-user=operator --with-group=operator \
--without-client --disable-libtool --prefix=${PREFIX}
MAN8= amadmin.8 amcheck.8 amcheckdb.8 amcleanup.8 amdd.8 \
@@ -98,6 +101,18 @@ CONFIGURE_ARGS+= --with-tape-device=${AMANDA_TAPE}
CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
.endif
+.if defined (AMANDA_USER)
+CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
+.else
+CONFIGURE_ARGS+= --with-user=operator
+.endif
+
+.if defined (AMANDA_GROUP)
+CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
+.else
+CONFIGURE_ARGS+= --with-group=operator
+.endif
+
#
# Before 4.0, pre-CAM scsiio.h existed
.if ${OSVERSION} < 400000
@@ -122,12 +137,15 @@ pre-fetch:
@${ECHO} " AMANDA_GNUTAR_LISTDIR=dir to specify the directory that"
@${ECHO} " the gnutar index files should live in"
@${ECHO} " The default is /var/amanda/gnutar-lists"
+ @${ECHO} " AMANDA_USER=user to specify the default user"
+ @${ECHO} " The default is operator"
+ @${ECHO} " AMANDA_GROUP=group to specify the default group"
+ @${ECHO} " The default is operator"
@${ECHO} ""
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--with-amandahosts --with-fqdn \
--with-dump-honor-nodump --with-buffered-dump \
- --with-user=operator --with-group=operator \
--without-server --disable-libtool --prefix=${PREFIX}
MAN8= amanda.8 amrecover.8 amrestore.8
@@ -159,6 +177,18 @@ CONFIGURE_ARGS+= --with-config=${AMANDA_CONFIG}
CONFIGURE_ARGS+= --with-gnutar-listdir=${AMANDA_GNUTAR_LISTDIR}
.endif
+.if defined (AMANDA_USER)
+CONFIGURE_ARGS+= --with-user=${AMANDA_USER}
+.else
+CONFIGURE_ARGS+= --with-user=operator
+.endif
+
+.if defined (AMANDA_GROUP)
+CONFIGURE_ARGS+= --with-group=${AMANDA_GROUP}
+.else
+CONFIGURE_ARGS+= --with-group=operator
+.endif
+
.endif
.include <bsd.port.post.mk>