aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:08:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-08-21 14:08:06 +0000
commitc9cf6c61132115ca4b6476190fe9576d06ee06db (patch)
treea29fe29c38d5df1895cfbe84019093fae61a6b42 /misc
parentb100cd9f05b8e71f0cd2e142eafe47d54108a79c (diff)
downloadports-c9cf6c61132115ca4b6476190fe9576d06ee06db.tar.gz
ports-c9cf6c61132115ca4b6476190fe9576d06ee06db.zip
- Convert to new perl framework
Notes
Notes: svn path=/head/; revision=325134
Diffstat (limited to 'misc')
-rw-r--r--misc/help2man/Makefile3
-rw-r--r--misc/p5-Geo-Coder-Bing/Makefile3
-rw-r--r--misc/p5-Geo-Coder-Geocoder-US/Makefile3
-rw-r--r--misc/p5-Geo-Coder-Google/Makefile3
-rw-r--r--misc/p5-Geo-Coder-Googlev3/Makefile3
-rw-r--r--misc/p5-Geo-Coder-Many/Makefile3
-rw-r--r--misc/p5-Geo-Coder-Mapquest/Makefile3
-rw-r--r--misc/p5-Geo-Coder-Multimap/Makefile3
-rw-r--r--misc/p5-Geo-Coder-Navteq/Makefile3
-rw-r--r--misc/p5-Geo-Coder-OSM/Makefile3
-rw-r--r--misc/p5-Geo-Coder-Ovi/Makefile3
-rw-r--r--misc/p5-Geo-Coder-PlaceFinder/Makefile3
-rw-r--r--misc/p5-Geo-Coder-TomTom/Makefile3
-rw-r--r--misc/p5-Text-FIGlet/Makefile3
14 files changed, 27 insertions, 15 deletions
diff --git a/misc/help2man/Makefile b/misc/help2man/Makefile
index d107ea3cc602..1d17959701d3 100644
--- a/misc/help2man/Makefile
+++ b/misc/help2man/Makefile
@@ -15,8 +15,7 @@ OPTIONS_DEFINE= NLS
CFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-USE_PERL5= yes
-USES= gmake
+USES= gmake perl5
INFO= ${PORTNAME}
MAN1= ${PORTNAME}.1
diff --git a/misc/p5-Geo-Coder-Bing/Makefile b/misc/p5-Geo-Coder-Bing/Makefile
index 5e030a347aa8..467a36cc0e89 100644
--- a/misc/p5-Geo-Coder-Bing/Makefile
+++ b/misc/p5-Geo-Coder-Bing/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
p5-libwww>=6.02:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::Bing.3
diff --git a/misc/p5-Geo-Coder-Geocoder-US/Makefile b/misc/p5-Geo-Coder-Geocoder-US/Makefile
index 9abd00b38fc7..e617ead733e8 100644
--- a/misc/p5-Geo-Coder-Geocoder-US/Makefile
+++ b/misc/p5-Geo-Coder-Geocoder-US/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::Geocoder::US.3
diff --git a/misc/p5-Geo-Coder-Google/Makefile b/misc/p5-Geo-Coder-Google/Makefile
index 0e98fb8ff569..8ed8fcb10798 100644
--- a/misc/p5-Geo-Coder-Google/Makefile
+++ b/misc/p5-Geo-Coder-Google/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::Google.3 \
Geo::Coder::Google::V2.3 \
diff --git a/misc/p5-Geo-Coder-Googlev3/Makefile b/misc/p5-Geo-Coder-Googlev3/Makefile
index 0bce5e0fa7c1..dc0d3509ce79 100644
--- a/misc/p5-Geo-Coder-Googlev3/Makefile
+++ b/misc/p5-Geo-Coder-Googlev3/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::Googlev3.3
diff --git a/misc/p5-Geo-Coder-Many/Makefile b/misc/p5-Geo-Coder-Many/Makefile
index b4a2ac4f8ef1..580f854186a7 100644
--- a/misc/p5-Geo-Coder-Many/Makefile
+++ b/misc/p5-Geo-Coder-Many/Makefile
@@ -32,7 +32,8 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject \
p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::Many.3 \
Geo::Coder::Many::Bing.3 \
diff --git a/misc/p5-Geo-Coder-Mapquest/Makefile b/misc/p5-Geo-Coder-Mapquest/Makefile
index 61ab40574fc4..be093216eb3b 100644
--- a/misc/p5-Geo-Coder-Mapquest/Makefile
+++ b/misc/p5-Geo-Coder-Mapquest/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
p5-libwww>=6.02:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::Mapquest.3
diff --git a/misc/p5-Geo-Coder-Multimap/Makefile b/misc/p5-Geo-Coder-Multimap/Makefile
index 66a30587db47..6c0e9b5bc8be 100644
--- a/misc/p5-Geo-Coder-Multimap/Makefile
+++ b/misc/p5-Geo-Coder-Multimap/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::Multimap.3
diff --git a/misc/p5-Geo-Coder-Navteq/Makefile b/misc/p5-Geo-Coder-Navteq/Makefile
index d954098c79c0..844a1e10e9b5 100644
--- a/misc/p5-Geo-Coder-Navteq/Makefile
+++ b/misc/p5-Geo-Coder-Navteq/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::Navteq.3
diff --git a/misc/p5-Geo-Coder-OSM/Makefile b/misc/p5-Geo-Coder-OSM/Makefile
index 56237c621a6a..6343ac73b6cf 100644
--- a/misc/p5-Geo-Coder-OSM/Makefile
+++ b/misc/p5-Geo-Coder-OSM/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::OSM.3
diff --git a/misc/p5-Geo-Coder-Ovi/Makefile b/misc/p5-Geo-Coder-Ovi/Makefile
index 5c7e62539eb5..343e9ef3b3ea 100644
--- a/misc/p5-Geo-Coder-Ovi/Makefile
+++ b/misc/p5-Geo-Coder-Ovi/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::Ovi.3
diff --git a/misc/p5-Geo-Coder-PlaceFinder/Makefile b/misc/p5-Geo-Coder-PlaceFinder/Makefile
index 6e11d2d9142b..92f13e367bdc 100644
--- a/misc/p5-Geo-Coder-PlaceFinder/Makefile
+++ b/misc/p5-Geo-Coder-PlaceFinder/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::PlaceFinder.3
diff --git a/misc/p5-Geo-Coder-TomTom/Makefile b/misc/p5-Geo-Coder-TomTom/Makefile
index 4c906a268ee3..eb6c86e27397 100644
--- a/misc/p5-Geo-Coder-TomTom/Makefile
+++ b/misc/p5-Geo-Coder-TomTom/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN3= Geo::Coder::TomTom.3
diff --git a/misc/p5-Text-FIGlet/Makefile b/misc/p5-Text-FIGlet/Makefile
index 2f5adc5e11d5..d18a54933439 100644
--- a/misc/p5-Text-FIGlet/Makefile
+++ b/misc/p5-Text-FIGlet/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= ${LOCALBASE}/bin/figlet:${PORTSDIR}/misc/figlet
TEST_DEPENDS= p5-Test-Differences>=0:${PORTSDIR}/devel/p5-Test-Differences \
p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
-PERL_CONFIGURE= yes
+USE_PERL5= configure
+USES= perl5
MAN1= charmap.pl.1 \
figlet.pl.1 \