aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-11-01 21:41:24 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-11-01 21:41:24 +0000
commitd100b8a362944ceef70551468757f4892cb1f6d0 (patch)
treeabb3124417421530be657b5ef8b074c1924fc3b5 /misc
parent043bec08e1c7d7c173e13c0ad3f753acc13fa8c7 (diff)
downloadports-d100b8a362944ceef70551468757f4892cb1f6d0.tar.gz
ports-d100b8a362944ceef70551468757f4892cb1f6d0.zip
FreeGuide is a TV guide program. It uses parser programs to extract TV
information from web pages and stores them for viewing without the need to connect to the Internet. The viewer allows the user to view television listings and create customised TV guides by selecting programmes and by building up a favourites list. It works with listings for many countries. WWW: http://freeguide-tv.sf.net/ PR: 88088 Submitted by: Stephen Hurd <shurd@sasktel.net>
Notes
Notes: svn path=/head/; revision=146953
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/freeguide/Makefile42
-rw-r--r--misc/freeguide/distinfo2
-rw-r--r--misc/freeguide/files/patch-ViewerFrame.java13
-rw-r--r--misc/freeguide/files/patch-build.xml60
-rw-r--r--misc/freeguide/files/patch-freeguide18
-rw-r--r--misc/freeguide/pkg-descr9
-rw-r--r--misc/freeguide/pkg-plist29
8 files changed, 174 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 468d5fae3695..ac0588c4f7e5 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -91,6 +91,7 @@
SUBDIR += fortune-mod-futurama
SUBDIR += fortuneit
SUBDIR += freedialog
+ SUBDIR += freeguide
SUBDIR += freshmeat-submit
SUBDIR += ftdi-eeprom
SUBDIR += ftree
diff --git a/misc/freeguide/Makefile b/misc/freeguide/Makefile
new file mode 100644
index 000000000000..592630e0d247
--- /dev/null
+++ b/misc/freeguide/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: freeguide
+# Date Created: 27 October 2005
+# Whom: Stephen Hurd <shurd@sasktel.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freeguide
+PORTVERSION= 0.8.6
+CATEGORIES= misc java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freeguide-tv
+DISTNAME= FreeGuide-${PORTVERSION}
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= An interactive TV guide which will create personalized TV listings
+
+RUN_DEPENDS= tv_cat:${PORTSDIR}/textproc/p5-xmltv
+
+USE_JAVA= yes
+USE_JIKES= no
+JAVA_VERSION= 1.4+
+USE_ANT= yes
+MANCOMPRESSED= yes
+MAN1= freeguide.1
+
+MAKE_ARGS= -Dinstall_share_dir=${PREFIX}/share \
+ -Dinstall_man1_dir=${MAN1PREFIX} \
+ -Dinstall_java_bin=${JAVA} \
+ -Dinstall_real_doc_dir=${DOCSDIR} \
+ -Dinstall_bin_dir=${PREFIX}/bin \
+ -Dinstall_doc_dir=${DOCSDIR} \
+ -Dinstall_java_share_dir=${JAVASHAREDIR} \
+ -Dinstall_jar_dir=${JAVAJARDIR}
+ALL_TARGET= FreeGuide-Linux-NoXMLTV
+INSTALL_TARGET= install-Linux-NoXMLTV-files
+
+do-install:
+ @(cd ${BUILD_WRKSRC}; \
+ ${ANT} ${MAKE_ARGS} ${INSTALL_TARGET})
+
+.include <bsd.port.mk>
diff --git a/misc/freeguide/distinfo b/misc/freeguide/distinfo
new file mode 100644
index 000000000000..30a1bd321ce2
--- /dev/null
+++ b/misc/freeguide/distinfo
@@ -0,0 +1,2 @@
+MD5 (FreeGuide-0.8.6.tar.gz) = 447a958355e30a0c964fb78348b99769
+SIZE (FreeGuide-0.8.6.tar.gz) = 7574967
diff --git a/misc/freeguide/files/patch-ViewerFrame.java b/misc/freeguide/files/patch-ViewerFrame.java
new file mode 100644
index 000000000000..12862ecb2b6f
--- /dev/null
+++ b/misc/freeguide/files/patch-ViewerFrame.java
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- src/program/gui/viewer/ViewerFrame.java Thu Oct 27 00:18:55 2005
++++ src/program/gui/viewer/ViewerFrame.java Thu Oct 27 00:34:18 2005
+@@ -1502,7 +1502,7 @@
+ String[] cmds = Utils.substitute(
+ FreeGuide.prefs.commandline.getStrings( "browser_command" ),
+ "%filename%",
+- programme.getLink().toString().replace("%","%%") );
++ programme.getLink().toString().replaceAll("%","%%") );
+
+ Utils.execNoWait(cmds);
+
diff --git a/misc/freeguide/files/patch-build.xml b/misc/freeguide/files/patch-build.xml
new file mode 100644
index 000000000000..077e5a85ca2b
--- /dev/null
+++ b/misc/freeguide/files/patch-build.xml
@@ -0,0 +1,60 @@
+$FreeBSD$
+
+--- build.xml Thu Oct 27 18:40:07 2005
++++ build.xml Fri Oct 28 16:43:14 2005
+@@ -29,8 +29,7 @@
+ </target>
+
+ <target name="install-Linux-NoXMLTV-files"
+- description="install all the files for linux"
+- depends="FreeGuide-Linux-NoXMLTV" >
++ description="install all the files for linux">
+
+ <!-- These properties are passed in from the rpm .spec file:
+ install_share_dir = ~/.rpm/tmp/FreeGuide-0.8.2-root//usr/share
+@@ -39,10 +38,7 @@
+ install_real_doc_dir = /usr/doc/freeguide
+ -->
+
+- <property name="install_jar_dir"
+- location="${install_share_dir}/freeguide" />
+-
+- <property name="install_pixmap_dir" location="${install_share_dir}/pixmaps/freeguide" />
++ <property name="install_pixmap_dir" location="${install_java_share_dir}/pixmaps/freeguide" />
+
+ <mkdir dir="${install_jar_dir}" />
+ <copy file="${dist}/${freeguideversion}-Linux-NoXMLTV.jar"
+@@ -58,11 +54,13 @@
+ </fileset>
+ </copy>
+
+- <copy tofile="${install_share_dir}/pixmaps/freeguide.png" file="${src}/images/logo-32x32.png" />
++ <copy tofile="${install_java_share_dir}/pixmaps/freeguide.png" file="${src}/images/logo-32x32.png" />
+
+ <!-- Creating the launch script: first we need to copy the source launch script, then we replace the string "__ANT_DOC_DIRECTORY__" with the docs directory, and then we move it into place and make it executable. -->
+ <copy file="${src}/install/linux/freeguide" tofile="${src}/install/linux/freeguide.tmp" />
+ <replace file="${src}/install/linux/freeguide.tmp" token="__ANT_DOC_DIRECTORY__" value="${install_real_doc_dir}" />
++ <replace file="${src}/install/linux/freeguide.tmp" token="__ANT_JAR_PATH__" value="${install_jar_dir}/FreeGuide.jar" />
++ <replace file="${src}/install/linux/freeguide.tmp" token="__ANT_JAVA_BIN__" value="${install_java_bin}" />
+ <mkdir dir="${install_bin_dir}" />
+ <move file="${src}/install/linux/freeguide.tmp" tofile="${install_bin_dir}/freeguide" />
+ <chmod file="${install_bin_dir}/freeguide" perm="a+x" />
+@@ -70,8 +68,8 @@
+ <mkdir dir="${install_share_dir}/applications" />
+ <copy file="${src}/install/linux/freeguide.desktop" todir="${install_share_dir}/applications/" />
+
+- <mkdir dir="${install_share_dir}/man/man1" />
+- <copy file="${build}/freeguide.1.gz" todir="${install_share_dir}/man/man1/" />
++ <mkdir dir="${install_man1_dir}/man/man1" />
++ <copy file="${build}/freeguide.1.gz" todir="${install_man1_dir}/man/man1/" />
+
+ <mkdir dir="${install_doc_dir}" />
+ <copy todir="${install_doc_dir}/">
+@@ -79,7 +77,6 @@
+ <include name="*.html" />
+ <include name="*.png" />
+ <include name="*.css" />
+- <include name="COPYING" />
+ <include name="TODO" />
+ <exclude name="bugreport.html" />
+ </fileset>
diff --git a/misc/freeguide/files/patch-freeguide b/misc/freeguide/files/patch-freeguide
new file mode 100644
index 000000000000..913f85cce3d1
--- /dev/null
+++ b/misc/freeguide/files/patch-freeguide
@@ -0,0 +1,18 @@
+$FreeBSD$
+
+--- src/install/linux/freeguide Thu Oct 27 00:18:55 2005
++++ src/install/linux/freeguide Thu Oct 27 01:10:30 2005
+@@ -1,11 +1,11 @@
+ #!/bin/sh
+-FREEGUIDE_JAR=/usr/share/freeguide/FreeGuide.jar
++FREEGUIDE_JAR=__ANT_JAR_PATH__
+ # Load default settings from config file (if it exists)
+ if [ -f "$HOME/.freeguiderc" ]; then
+ . "$HOME/.freeguiderc"
+ fi
+ if [ -z "$JAVACMD" ]; then
+- JAVACMD=java
++ JAVACMD=__ANT_JAVA_BIN__
+ fi
+ $JAVACMD $FREEGUIDE_OPTS -jar $FREEGUIDE_JAR \
+ --doc_directory "__ANT_DOC_DIRECTORY__" "$@"
diff --git a/misc/freeguide/pkg-descr b/misc/freeguide/pkg-descr
new file mode 100644
index 000000000000..c31f6de48363
--- /dev/null
+++ b/misc/freeguide/pkg-descr
@@ -0,0 +1,9 @@
+FreeGuide is a TV guide program. It uses parser programs to extract TV
+information from web pages and stores them for viewing without the need to
+connect to the Internet. The viewer allows the user to view television listings
+and create customised TV guides by selecting programmes and by building up a
+favourites list.
+
+It works with listings for many countries.
+
+WWW: http://freeguide-tv.sf.net/
diff --git a/misc/freeguide/pkg-plist b/misc/freeguide/pkg-plist
new file mode 100644
index 000000000000..852b81fa0ec5
--- /dev/null
+++ b/misc/freeguide/pkg-plist
@@ -0,0 +1,29 @@
+@comment $FreeBSD$
+bin/freeguide
+share/applications/freeguide.desktop
+%%DOCSDIR%%/FAQ.html
+%%DOCSDIR%%/FreeGuide-0_7-Linux-MetalLookAndFeel.png
+%%DOCSDIR%%/INSTALL-linux-noxmltv.html
+%%DOCSDIR%%/LookAndFeel.html
+%%DOCSDIR%%/README.html
+%%DOCSDIR%%/TODO
+%%DOCSDIR%%/contributors.html
+%%DOCSDIR%%/design.html
+%%DOCSDIR%%/developers-compiling.html
+%%DOCSDIR%%/developers-cvs.html
+%%DOCSDIR%%/developers-translating.html
+%%DOCSDIR%%/developers.html
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/stylesheet.css
+%%DOCSDIR%%/timezone.html
+%%DOCSDIR%%/userguide.html
+%%JAVAJARDIR%%/FreeGuide.jar
+share/java/pixmaps/freeguide.png
+share/java/pixmaps/freeguide/logo-16x16.png
+share/java/pixmaps/freeguide/logo-32x32.png
+share/java/pixmaps/freeguide/logo-48x48.png
+share/java/pixmaps/freeguide/logo-64x64.png
+share/java/pixmaps/freeguide/logo-72x72.png
+share/java/pixmaps/freeguide/logo-96x96.png
+@dirrm share/java/pixmaps/freeguide
+@dirrm %%DOCSDIR%%