aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-22 06:26:32 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-09-22 06:29:22 +0000
commitd37893d25e54a580b0c7f9ceaef3f6a3814815da (patch)
treea9bf671cc7b24854f3a0a9b8c9978978fe8f46aa /misc
parent8197a73f5816c4b4eab43e2c91d7795b38515898 (diff)
downloadports-d37893d25e54a580b0c7f9ceaef3f6a3814815da.tar.gz
ports-d37893d25e54a580b0c7f9ceaef3f6a3814815da.zip
misc/mc: handling of the port's options had been improved (+)
- Use correct helper for X11 option, which is --with-x, not --enable-x - Do not pass bogus --without-smb-foobar=... options when SMB support is disabled - Allow to build with Aspell support in the internal editor while here PR: 258632
Diffstat (limited to 'misc')
-rw-r--r--misc/mc/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 60fe6d95024e..ea04ec6871d2 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mc
PORTVERSION= 4.8.27
+PORTREVISION= 1
CATEGORIES= misc shells
MASTER_SITES= http://ftp.midnight-commander.org/ \
https://ftp.osuosl.org/pub/midnightcommander/
@@ -24,18 +25,22 @@ CONFIGURE_ENV= ZIP=${LOCALBASE}/bin/zip UNZIP=${UNZIP_NATIVE_CMD}
PORTDOCS= AUTHORS FAQ HACKING MAINTAINERS NEWS README *.txt
-OPTIONS_DEFINE= DOCS EDITOR EXTATTR ICONV NLS SFTP SMB SUBSHELL X11
+OPTIONS_DEFINE= ASPELL DOCS EDITOR EXTATTR ICONV NLS SFTP SMB SUBSHELL X11
OPTIONS_DEFAULT= EDITOR ICONV SFTP SLANG SMB SUBSHELL X11
OPTIONS_SINGLE= SCREEN
OPTIONS_SINGLE_SCREEN= SLANG NCURSES
OPTIONS_SUB= yes
+ASPELL_DESC= Aspell support for internal editor
EDITOR_DESC= Build with internal editor
EXTATTR_DESC= Extended attributes support
SCREEN_DESC= Screen library
SFTP_DESC= Support for SFTP (via libssh)
SUBSHELL_DESC= Build with subshell support
+ASPELL_LIB_DEPENDS= libaspell.so:textproc/aspell
+ASPELL_CONFIGURE_ENABLE=aspell
+
EDITOR_CONFIGURE_WITH= internal-edit
EXTATTR_LIB_DEPENDS= libe2p.so:sysutils/e2fsprogs
@@ -58,13 +63,13 @@ SLANG_LIB_DEPENDS= libslang.so:devel/libslang2
SLANG_CONFIGURE_ON= --with-screen=slang --with-slang-includes=${LOCALBASE}/include
SMB_CONFIGURE_ENABLE= vfs-smb
-SMB_CONFIGURE_WITH= smb-configdir=${LOCALBASE}/etc \
- smb-codepagedir=${LOCALBASE}/etc/codepages
+SMB_CONFIGURE_ON= --with-smb-configdir=${LOCALBASE}/etc \
+ --with-smb-codepagedir=${LOCALBASE}/etc/codepages
SUBSHELL_CONFIGURE_WITH=subshell
SUBSHELL_SUB_FILES= pkg-message
-X11_CONFIGURE_ENABLE= x
+X11_CONFIGURE_WITH= x
X11_USES= xorg
X11_USE= xorg=x11,xext
X11_VARS= CONFLICTS_INSTALL+="mc-nox11-[0-9]*"