aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
commite1bfdfbe5665c963621e06f6bbfbbc2c000a804e (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /misc
parentf57bc4af665126de839ff734a08e57726e84da84 (diff)
downloadports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.tar.gz
ports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.zip
Add DOCS options to ports that should have one.
Also various fixes related to said option. PR: 230864 Submitted by: mat exp-runs by: antoine
Notes
Notes: svn path=/head/; revision=479406
Diffstat (limited to 'misc')
-rw-r--r--misc/artikulate/Makefile2
-rw-r--r--misc/elixir-mime/Makefile2
-rw-r--r--misc/elixir-uuid/Makefile2
-rw-r--r--misc/erlang-mimerl/Makefile2
-rw-r--r--misc/erlang-mimetypes/Makefile2
-rw-r--r--misc/kdeedu-data/Makefile2
-rw-r--r--misc/kgeography/Makefile2
-rw-r--r--misc/klettres/Makefile2
-rw-r--r--misc/ktouch/Makefile2
-rw-r--r--misc/kwordquiz/Makefile2
-rw-r--r--misc/libkeduvocdocument/Makefile2
-rw-r--r--misc/parley/Makefile2
-rw-r--r--misc/qbrew/Makefile2
-rw-r--r--misc/sloccount/Makefile2
-rw-r--r--misc/susv2/Makefile2
-rw-r--r--misc/susv3/Makefile2
-rw-r--r--misc/susv4/Makefile2
-rw-r--r--misc/vdmfec/Makefile2
-rw-r--r--misc/vifm/Makefile2
19 files changed, 38 insertions, 0 deletions
diff --git a/misc/artikulate/Makefile b/misc/artikulate/Makefile
index 48314c630d84..98f91fe9219f 100644
--- a/misc/artikulate/Makefile
+++ b/misc/artikulate/Makefile
@@ -19,4 +19,6 @@ USE_QT= core dbus gui multimedia network qml quick sql testlib widgets \
buildtools_build qmake_build
USE_LDCONFIG= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/elixir-mime/Makefile b/misc/elixir-mime/Makefile
index a3373256b69e..2a1612b1b470 100644
--- a/misc/elixir-mime/Makefile
+++ b/misc/elixir-mime/Makefile
@@ -17,4 +17,6 @@ GH_ACCOUNT= elixir-lang
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/elixir-uuid/Makefile b/misc/elixir-uuid/Makefile
index 5cfcdf2f8dee..b7cf2825f656 100644
--- a/misc/elixir-uuid/Makefile
+++ b/misc/elixir-uuid/Makefile
@@ -16,4 +16,6 @@ GH_ACCOUNT= zyro
ELIXIR_APP_NAME=uuid
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/erlang-mimerl/Makefile b/misc/erlang-mimerl/Makefile
index 63319acc4b1d..f50951aff412 100644
--- a/misc/erlang-mimerl/Makefile
+++ b/misc/erlang-mimerl/Makefile
@@ -14,4 +14,6 @@ USES= erlang:rebar3
USE_GITHUB= yes
GH_ACCOUNT= benoitc
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/erlang-mimetypes/Makefile b/misc/erlang-mimetypes/Makefile
index 79bf86a2afdc..39c9bf76b597 100644
--- a/misc/erlang-mimetypes/Makefile
+++ b/misc/erlang-mimetypes/Makefile
@@ -14,4 +14,6 @@ USES= erlang:rebar3
USE_GITHUB= yes
GH_ACCOUNT= spawngrid
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/kdeedu-data/Makefile b/misc/kdeedu-data/Makefile
index 700983b4bdc2..dff312190d21 100644
--- a/misc/kdeedu-data/Makefile
+++ b/misc/kdeedu-data/Makefile
@@ -18,4 +18,6 @@ USE_QT= buildtools_build qmake_build
CMAKE_ARGS= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Core=TRUE \
-DQMAKE_EXECUTABLE:PATH=${QMAKE}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/kgeography/Makefile b/misc/kgeography/Makefile
index d53a5186ae49..f67228e06268 100644
--- a/misc/kgeography/Makefile
+++ b/misc/kgeography/Makefile
@@ -13,4 +13,6 @@ USE_KDE= auth codecs config configwidgets coreaddons crash doctools ecm \
USE_QT= core dbus gui widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/klettres/Makefile b/misc/klettres/Makefile
index 832f18ae6149..00dc2c26f9ae 100644
--- a/misc/klettres/Makefile
+++ b/misc/klettres/Makefile
@@ -14,4 +14,6 @@ USE_KDE= attica auth codecs completion config configwidgets coreaddons \
USE_QT= core dbus gui network phonon4 svg widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/ktouch/Makefile b/misc/ktouch/Makefile
index 060bc9054eea..99a72b6367b9 100644
--- a/misc/ktouch/Makefile
+++ b/misc/ktouch/Makefile
@@ -17,4 +17,6 @@ USE_QT= core dbus gui network qml quick script sql testlib widgets \
buildtools_build qmake_build
USE_XORG= ice sm x11 xcb xext xkbfile
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/kwordquiz/Makefile b/misc/kwordquiz/Makefile
index 86d6b3406ce6..64c60763b79d 100644
--- a/misc/kwordquiz/Makefile
+++ b/misc/kwordquiz/Makefile
@@ -17,4 +17,6 @@ USE_KDE= attica auth bookmarks codecs completion config configwidgets \
USE_QT= core dbus gui network phonon4 printsupport widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/libkeduvocdocument/Makefile b/misc/libkeduvocdocument/Makefile
index 4213eef6d7f0..b4624d4cd9bb 100644
--- a/misc/libkeduvocdocument/Makefile
+++ b/misc/libkeduvocdocument/Makefile
@@ -12,4 +12,6 @@ USE_KDE= archive config coreaddons ecm i18n kio service
USE_QT= core gui xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/parley/Makefile b/misc/parley/Makefile
index 413ddd5499c7..f5ee3c8aa3b5 100644
--- a/misc/parley/Makefile
+++ b/misc/parley/Makefile
@@ -22,4 +22,6 @@ USE_QT= concurrent core dbus gui location network multimedia qml quick \
buildtools_build qmake_build
USE_XORG= x11 xrender
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/misc/qbrew/Makefile b/misc/qbrew/Makefile
index 540a73b9f94f..912f17190ca2 100644
--- a/misc/qbrew/Makefile
+++ b/misc/qbrew/Makefile
@@ -19,6 +19,8 @@ QMAKE_ENV+= BINDIR="${PREFIX}/bin" \
DATADIR="${DATADIR}" \
DOCDIR="${DOCSDIR}"
+OPTIONS_DEFINE= DOCS
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qbrew
diff --git a/misc/sloccount/Makefile b/misc/sloccount/Makefile
index e16c0435b8ae..0789813c9836 100644
--- a/misc/sloccount/Makefile
+++ b/misc/sloccount/Makefile
@@ -21,6 +21,8 @@ INSTALL_TARGET= install_programs install_man
PORTDOCS= ChangeLog README TODO sloccount.html
+OPTIONS_DEFINE= DOCS
+
post-install:
.for file in lexcount1 c_count java_count php_count
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${file}
diff --git a/misc/susv2/Makefile b/misc/susv2/Makefile
index 2f34848fa66a..26749c2b6737 100644
--- a/misc/susv2/Makefile
+++ b/misc/susv2/Makefile
@@ -16,6 +16,8 @@ USES= tar:bzip2
NO_BUILD= yes
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
diff --git a/misc/susv3/Makefile b/misc/susv3/Makefile
index 23eb460dc3ae..e78307f40341 100644
--- a/misc/susv3/Makefile
+++ b/misc/susv3/Makefile
@@ -16,6 +16,8 @@ USES= tar:bzip2
NO_BUILD= yes
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
diff --git a/misc/susv4/Makefile b/misc/susv4/Makefile
index ea54aac7e40b..6c33773db9bd 100644
--- a/misc/susv4/Makefile
+++ b/misc/susv4/Makefile
@@ -20,6 +20,8 @@ NO_ARCH= yes
NO_BUILD= yes
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
diff --git a/misc/vdmfec/Makefile b/misc/vdmfec/Makefile
index 5f084954cb9b..6c6e941a3fe9 100644
--- a/misc/vdmfec/Makefile
+++ b/misc/vdmfec/Makefile
@@ -24,6 +24,8 @@ PLIST_FILES= bin/vdm_decode \
bin/vdmfec \
man/man1/vdmfec.1.gz
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/misc/vifm/Makefile b/misc/vifm/Makefile
index e439d03dc42e..c5b79d5d5ef9 100644
--- a/misc/vifm/Makefile
+++ b/misc/vifm/Makefile
@@ -18,4 +18,6 @@ CONFIGURE_ARGS= --without-gtk
USE_GITHUB= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>