aboutsummaryrefslogtreecommitdiff
path: root/multimedia/aegisub/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2012-10-18 09:15:43 +0000
committerJason E. Hale <jhale@FreeBSD.org>2012-10-18 09:15:43 +0000
commit7d00fc0a420371190ef9ac3a90645c0832332b96 (patch)
tree638ed5d4cad13cdd368815a7a2b941433769ffa6 /multimedia/aegisub/Makefile
parentff96836264c085389eb8ca6b70baf36dd474f890 (diff)
downloadports-7d00fc0a420371190ef9ac3a90645c0832332b96.tar.gz
ports-7d00fc0a420371190ef9ac3a90645c0832332b96.zip
- Update MASTER_SITES
- Drop ABI version numbers from LIB_DEPENDS - Trim Makefile header - Remove indefinite article from COMMENT PR: ports/172508 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Approved by: makc, avilla (mentors, implicit) Feature safe: yes
Notes
Notes: svn path=/head/; revision=306054
Diffstat (limited to 'multimedia/aegisub/Makefile')
-rw-r--r--multimedia/aegisub/Makefile33
1 files changed, 13 insertions, 20 deletions
diff --git a/multimedia/aegisub/Makefile b/multimedia/aegisub/Makefile
index 15220773c3aa..3fd69f36347b 100644
--- a/multimedia/aegisub/Makefile
+++ b/multimedia/aegisub/Makefile
@@ -1,30 +1,24 @@
-# New ports collection makefile for: aegisub
-# Date created: 2nd March 2010
-# Whom: Leinier Cruz Salfran <salfrancl@yahoo.es>
-#
+# Created by: Leinier Cruz Salfran <salfrancl@yahoo.es>
# $FreeBSD$
-# $MCom: ports-stable/multimedia/aegisub/Makefile,v 0.14 2010/03/10 17:02:00 salfrancl Exp $
-# $Id: Makefile,v 0.14 2010/03/10 17:02:00 salfrancl Exp $
-#
PORTNAME= aegisub
PORTVERSION= 2.1.9
PORTREVISION= 1
CATEGORIES= multimedia
-MASTER_SITES= http://ftp.aegisub.org/pub/releases/ \
- http://ftp2.aegisub.org/pub/releases/ \
- ftp://ftp.aegisub.org/pub/releases/ \
- ftp://ftp2.aegisub.org/pub/releases/ \
+MASTER_SITES= http://ftp.aegisub.org/pub/archives/releases/source/ \
+ ftp://ftp.aegisub.org/pub/archives/releases/srouce/ \
+ ftp://ftp2.aegisub.org/pub/archives/releases/source/ \
GOOGLE_CODE:ffms
+PROJECTHOST= ffmpegsource
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${FFMS_DISTFILE}:ffms
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A cross-platform subtitle editor
+COMMENT= Cross-platform subtitle editor
LICENSE= BSD
-LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
OPTIONS_DEFINE= DEBUG PROFILE GCOV EFENCE ASS ALSA OPENAL PORTAUDIO PULSEAUDIO \
FFMPEG HUNSPELL LUA DOCS
@@ -55,7 +49,6 @@ CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PROJECTHOST= ffmpegsource
FFMS_NAME= ffms
FFMS_VERSION= 2.17
FFMS_DISTNAME= ${FFMS_NAME}-${FFMS_VERSION}-src
@@ -78,7 +71,7 @@ WITH_PROFILE= yes
.endif
.if ${PORT_OPTIONS:MEFENCE}
-LIB_DEPENDS+= efence.0:${PORTSDIR}/devel/ElectricFence
+LIB_DEPENDS+= efence:${PORTSDIR}/devel/ElectricFence
CONFIGURE_ARGS+= --enable-efence
WITH_PROFILE= yes
.endif
@@ -88,13 +81,13 @@ CONFIGURE_ARGS+= --enable-profile
.endif
.if ${PORT_OPTIONS:MASS}
-LIB_DEPENDS+= ass.5:${PORTSDIR}/multimedia/libass
+LIB_DEPENDS+= ass:${PORTSDIR}/multimedia/libass
.else
CONFIGURE_ARGS+= --without-libass
.endif
.if ${PORT_OPTIONS:MALSA}
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
.else
CONFIGURE_ARGS+= --without-alsa
.endif
@@ -116,13 +109,13 @@ CONFIGURE_ARGS+= --without-portaudio
.endif
.if ${PORT_OPTIONS:MPULSEAUDIO}
-LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
+LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
.else
CONFIGURE_ARGS+= --without-pulseaudio
.endif
.if ${PORT_OPTIONS:MFFMPEG}
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ENV+= FFMS_CFLAGS="${FFMS_CFLAGS}" FFMS_LIBS="${FFMS_LIBS}"
CONFIGURE_ARGS+= --with-provider-video=ffmpegsource \
--with-provider-audio=ffmpegsource
@@ -132,7 +125,7 @@ CONFIGURE_ARGS+= --without-ffms
.endif
.if ${PORT_OPTIONS:MHUNSPELL}
-LIB_DEPENDS+= hunspell-1.3.0:${PORTSDIR}/textproc/hunspell
+LIB_DEPENDS+= hunspell-1.3:${PORTSDIR}/textproc/hunspell
.else
CONFIGURE_ARGS+= --without-hunspell
.endif