aboutsummaryrefslogtreecommitdiff
path: root/multimedia/audacious-plugins
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-03-09 09:37:17 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-03-09 09:38:26 +0000
commitda94eff6286a1ac7aeba47ab9f0bbf5db6aa15f5 (patch)
tree4b26cc276ae20b7ef7f8294a62184f17a5e82e01 /multimedia/audacious-plugins
parent56fc27c31c340e3054fb08073c70c7bdd3f2dfda (diff)
downloadports-da94eff6286a1ac7aeba47ab9f0bbf5db6aa15f5.tar.gz
ports-da94eff6286a1ac7aeba47ab9f0bbf5db6aa15f5.zip
multimedia/audacious-plugins: Update to 4.3
Release changelog: https://audacious-media-player.org/news/56-audacious-4-3-released - Added flavors for gtk3 (legacy) and qt6 - Convert port to use meson NOTE: not all plugins are available in all flavors. Especially the qt6 flavor is missing qthotkey and qtaudio.
Diffstat (limited to 'multimedia/audacious-plugins')
-rw-r--r--multimedia/audacious-plugins/Makefile194
-rw-r--r--multimedia/audacious-plugins/distinfo6
-rw-r--r--multimedia/audacious-plugins/files/patch-src_aac_meson.build8
-rw-r--r--multimedia/audacious-plugins/files/patch-src_lirc_meson.build16
-rw-r--r--multimedia/audacious-plugins/pkg-plist151
5 files changed, 262 insertions, 113 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index bf99e2e4de96..8947865228bd 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -1,6 +1,5 @@
PORTNAME= audacious-plugins
-PORTVERSION= 4.2
-PORTREVISION= 1
+PORTVERSION= 4.3
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.audacious-media-player.org/
@@ -17,163 +16,192 @@ LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libfreetype.so:print/freetype2 \
libmpg123.so:audio/mpg123
-FLAVORS= qt5 gtk2
+FLAVORS= qt5 qt6 gtk2 gtk3
FLAVOR?= ${FLAVORS:[1]}
USES= compiler:c++11-lib gettext-tools gmake gnome iconv \
- localbase pkgconfig tar:bzip2 xorg
+ localbase meson pkgconfig tar:bzip2 xorg
USE_GNOME= glib20 libxml2 gdkpixbuf2
USE_XORG= x11
-qt5_CONFLICTS_INSTALL= audacious-plugins-gtk2
+qt5_CONFLICTS_INSTALL= audacious-plugins-qt6 audacious-plugins-gtk2 audacious-plugins-gtk3
qt5_RUN_DEPENDS= audacious:multimedia/audacious@qt5
qt5_BUILD_DEPENDS= audacious:multimedia/audacious@qt5
+qt6_PKGNAMESUFFIX= -qt6
+qt6_CONFLICTS_INSTALL= audacious-plugins audacious-plugins-gtk2 audacious-plugins-gtk3
+qt6_RUN_DEPENDS= audacious:multimedia/audacious@qt6
+qt6_BUILD_DEPENDS= audacious:multimedia/audacious@qt6
+
gtk2_PKGNAMESUFFIX= -gtk2
-gtk2_CONFLICTS_INSTALL= audacious-plugins
+gtk2_CONFLICTS_INSTALL= audacious-plugins audacious-plugins-qt6 audacious-plugins-gtk3
gtk2_LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
gtk2_RUN_DEPENDS= audacious:multimedia/audacious@gtk2
gtk2_BUILD_DEPENDS= audacious:multimedia/audacious@gtk2
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-console --disable-mms --disable-soxr \
- --enable-gnomeshortcuts
+gtk3_PKGNAMESUFFIX= -gtk3
+gtk3_CONFLICTS_INSTALL= audacious-plugins audacious-plugins-qt6 audacious-plugins-gtk2
+gtk3_LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
+gtk3_RUN_DEPENDS= audacious:multimedia/audacious@gtk3
+gtk3_BUILD_DEPENDS= audacious:multimedia/audacious@gtk3
+
+MESON_ARGS= -Dconsole=false -Dmms=false -Dsoxr=false -Dcoreaudio=false
.if ${FLAVOR} == qt5
-CONFIGURE_ARGS+= --enable-qt --disable-gtk
+MESON_ARGS+= -Dqt=true -Dqt6=false -Dgtk=false -Dgtk3=false
USES+= qt:5
USE_QT= core gui multimedia network widgets x11extras
-PLIST_SUB= QT5="" GTK2="@comment "
+PLIST_SUB= QT="" QT5="" GTK="@comment "
+.elif ${FLAVOR} == qt6
+MESON_ARGS+= -Dqt=true -Dqt6=true -Dgtk=false -Dgtk3=false
+USES+= qt:6
+USE_QT= base multimedia
+PLIST_SUB= QT="" QT5="@comment " GTK="@comment "
.elif ${FLAVOR} == gtk2
-CONFIGURE_ARGS+= --disable-qt --enable-gtk --enable-hotkey
-USE_GNOME+= gtk20 cairo
-PLIST_SUB= QT5="@comment " GTK2=""
+MESON_ARGS+= -Dqt=false -Dqt6=false -Dgtk=true -Dgtk3=false -Dhotkey=true
+USE_GNOME+= cairo gtk20
+PLIST_SUB= QT="@comment " QT6="@comment " GTK=""
+.elif ${FLAVOR} == gtk3
+MESON_ARGS+= -Dqt=false -Dqt6=false -Dgtk=true -Dgtk3=true -Dhotkey=true
+USE_GNOME+= cairo gtk30
+PLIST_SUB= QT="@comment " QT6="@comment " GTK=""
.endif
OPTIONS_DEFINE= AAC ADPLUG AMIDI BS2B CDDA CUE FFMPEG FLAC LAME LIRC \
- MODPLUG MPRIS NEON NLS NOTIFY OPENGL OPENMPT SAMPLERATE \
+ MODPLUG MPG123 MPRIS NEON NLS NOTIFY OPENGL OPENMPT SAMPLERATE \
SCROBBLER SID SNDFILE SPEEDPITCH VORBIS WAVPACK
OPTIONS_MULTI= OUTPUT
-OPTIONS_MULTI_OUTPUT= ALSA FILEWRITER JACK OSS PULSEAUDIO SDL SNDIO
+OPTIONS_MULTI_OUTPUT= ALSA FILEWRITER JACK OSS PIPEWIRE PULSEAUDIO SDL SNDIO
OPTIONS_DEFAULT= AAC ADPLUG CDDA CUE FILEWRITER FFMPEG FLAC MPRIS \
- NEON NLS NOTIFY OPENMPT OSS PULSEAUDIO SCROBBLER \
- SID VORBIS WAVPACK
-OPTIONS_SUB= yes
+ MPG123 NEON NLS NOTIFY OPENMPT OSS PIPEWIRE PULSEAUDIO \
+ SCROBBLER SID VORBIS WAVPACK
+OPTIONS_SUB= yes
-.if ${FLAVOR} == gtk2
+.if ${FLAVOR} == gtk2 || ${FLAVOR} == gtk3
OPTIONS_DEFINE+= AOSD
OPTIONS_DEFAULT+= AOSD
.endif
-ADPLUG_DESC= ADPLUG plugin
-AMIDI_DESC= Amidi decoder
-AOSD_DESC= Audacious OSD
-BS2B_DESC= BS2B effect
-FILEWRITER_DESC=File writer
-MPRIS_DESC= NPRIS plugin
-NEON_DESC= Neon plugin
-OPENMPT_DESC= OpenMPT plugin
-SCROBBLER_DESC= Scrobbler decoder
-SID_DESC= Sound chip emulator of Commodore
-SPEEDPITCH_DESC=Speed and Pitch plugin
+ADPLUG_DESC= ADPLUG plugin
+AMIDI_DESC= Amidi decoder
+AOSD_DESC= Audacious OSD
+BS2B_DESC= BS2B effect
+FILEWRITER_DESC= File writer
+MPRIS_DESC= NPRIS plugin
+NEON_DESC= Neon plugin
+OPENMPT_DESC= OpenMPT plugin
+SCROBBLER_DESC= Scrobbler decoder
+SID_DESC= Sound chip emulator of Commodore
+SPEEDPITCH_DESC= Speed and Pitch plugin
AAC_LIB_DEPENDS= libfaad.so:audio/faad
-AAC_CONFIGURE_ENABLE= aac
+AAC_MESON_TRUE= aac
ADPLUG_LIB_DEPENDS= libadplug.so:audio/libadplug \
libbinio.so:devel/libbinio
-ADPLUG_CONFIGURE_ENABLE= adplug
+ADPLUG_MESON_TRUE= adplug
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
-ALSA_CONFIGURE_ENABLE= alsa
+ALSA_MESON_TRUE= alsa
AMIDI_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
-AMIDI_CONFIGURE_ENABLE= amidiplug
+AMIDI_MESON_TRUE= amidiplug
AOSD_USES= xorg
AOSD_USE= gnome=pango xorg=xrender
AOSD_LIB_DEPENDS= libXcomposite.so:x11/libXcomposite
-AOSD_CONFIGURE_ENABLE= aosd
+AOSD_MESON_TRUE= aosd
BS2B_LIB_DEPENDS= libbs2b.so:audio/libbs2b
-BS2B_CONFIGURE_ENABLE= bs2b
+BS2B_MESON_TRUE= bs2b
CDDA_LIB_DEPENDS= libcdio_cdda.so:sysutils/libcdio-paranoia \
libcddb.so:audio/libcddb \
libcdio.so:sysutils/libcdio
-CDDA_CONFIGURE_ENABLE= cdaudio
+CDDA_MESON_TRUE= cdaudio
CUE_LIB_DEPENDS= libcue.so:textproc/libcue
-CUE_CONFIGURE_ENABLE= cue
-FILEWRITER_CONFIGURE_ENABLE= filewriter
+CUE_MESON_TRUE= cue
+FILEWRITER_MESON_TRUE= filewriter
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
-FFMPEG_CONFIGURE_WITH= ffmpeg=ffmpeg
+FFMPEG_MESON_TRUE= ffaudio
FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
-FLAC_CONFIGURE_ENABLE= flac
+FLAC_MESON_TRUE= flac
JACK_LIB_DEPENDS= libjack.so:audio/jack \
libsamplerate.so:audio/libsamplerate
-JACK_CONFIGURE_ENABLE= jack
+JACK_MESON_TRUE= jack
LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
-LAME_CONFIGURE_ENABLE= filewriter_mp3
LIRC_LIB_DEPENDS= liblirc_client.so:comms/lirc
-LIRC_CONFIGURE_ENABLE= lirc
+LIRC_MESON_TRUE= lirc
MODPLUG_LIB_DEPENDS= libmodplug.so:audio/libmodplug
-MODPLUG_CONFIGURE_ENABLE= modplug
-MPRIS_CONFIGURE_ENABLE= mpris2
+MODPLUG_MESON_TRUE= modplug
+MPRIS_MESON_TRUE= mpris2
NEON_LIB_DEPENDS= libneon.so:www/neon
-NEON_CONFIGURE_ENABLE= neon
+NEON_MESON_TRUE= neon
+MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
+MPG123_MESON_TRUE= mpg123
NLS_USES= gettext-runtime
-NLS_CONFIGURE_ENABLE= nls
NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
-NOTIFY_CONFIGURE_ENABLE=notify
+NOTIFY_MESON_TRUE= notify
OPENGL_USES= gl
OPENGL_USE= gl=gl
.if ${FLAVOR} == qt5
OPENGL_USE+= qt=opengl
-OPENGL_CONFIGURE_ENABLE=qtglspectrum
-.elif ${FLAVOR} == gtk2
-OPENGL_CONFIGURE_ENABLE=glspectrum
.endif
+OPENGL_MESON_TRUE= gl-spectrum
OPENMPT_LIB_DEPENDS= libopenmpt.so:audio/libopenmpt
-OPENMPT_CONFIGURE_ENABLE= openmpt
-OSS_CONFIGURE_ENABLE= oss4
+OPENMPT_MESON_TRUE= openmpt
+OPUS_LIB_DEPENDS= libopusfile.so:audio/opusfile \
+ libopus.so:audio/opus
+OPUS_MESON_TRUE= opus
+OSS_MESON_TRUE= oss
+PIPEWIRE_LIB_DEPENDS= libpipewire-0.3.so:multimedia/pipewire
+PIPEWIRE_MESON_TRUE= pipewire
PULSEAUDIO_LIB_DEPENDS= libpulse-mainloop-glib.so:audio/pulseaudio
-PULSEAUDIO_CONFIGURE_ENABLE= pulse
+PULSEAUDIO_MESON_TRUE= pulse
SAMPLERATE_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate
-SAMPLERATE_CONFIGURE_ENABLE= resample
+SAMPLERATE_MESON_TRUE= resample
SCROBBLER_LIB_DEPENDS= libcurl.so:ftp/curl
-SCROBBLER_CONFIGURE_ENABLE= scrobbler2
-SDL_CONFIGURE_ON= --enable-sdlout --with-libsdl=2
-SDL_CONFIGURE_OFF= --disable-sdlout
+SCROBBLER_MESON_TRUE= scrobbler2
+SDL_MESON_TRUE= sdlout
SDL_USES= sdl
SDL_USE= SDL=sdl2
SID_LIB_DEPENDS= libsidplayfp.so:audio/libsidplayfp
-SID_CONFIGURE_ENABLE= sid
+SID_MESON_TRUE= sid
SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
-SNDFILE_CONFIGURE_ENABLE= sndfile
+SNDFILE_MESON_TRUE= sndfile
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
-SNDIO_CONFIGURE_ENABLE= sndio
-SPEEDPITCH_CONFIGURE_ENABLE= speedpitch
+SNDIO_MESON_TRUE= sndio
+SPEEDPITCH_MESON_TRUE= speedpitch
SPEEDPITCH_IMPLIES= SAMPLERATE
VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg
-VORBIS_CONFIGURE_ENABLE=vorbis
+VORBIS_MESON_TRUE= vorbis
WAVPACK_LIB_DEPENDS= libwavpack.so:audio/wavpack
-WAVPACK_CONFIGURE_ENABLE= wavpack
+WAVPACK_MESON_TRUE= wavpack
-post-patch:
- @${REINPLACE_CMD} -e 's| $${MFLAGS}||g' \
- ${WRKSRC}/buildsys.mk.in
- @${FIND} ${WRKSRC} -type f -name 'Makefile' \
- | ${XARGS} ${REINPLACE_CMD} -e 's| -Wno-bool-operation||'
-
-post-patch-NLS-off:
- ${REINPLACE_CMD} -e 's,po,,' ${WRKSRC}/Makefile
+.include <bsd.port.options.mk>
-post-install:
- @${FIND} ${STAGEDIR}${PREFIX}/lib/audacious/ -name "*.so" \
- -exec ${STRIP_CMD} {} \;
+.if ${PORT_OPTIONS:MFILEWRITER}
+.if ${PORT_OPTIONS:MFLAC}
+MESON_ARGS+= -Dfilewriter-flac=true
+.else
+MESON_ARGS+= -Dfilewriter-flac=false
+.endif
+.if ${PORT_OPTIONS:MLAME}
+MESON_ARGS+= -Dfilewriter-mp3=true
+.else
+MESON_ARGS+= -Dfilewriter-mp3=false
+.endif
+.if ${PORT_OPTIONS:MVORBIS}
+MESON_ARGS+= -Dfilewriter-ogg=true
+.else
+MESON_ARGS+= -Dfilewriter-ogg=false
+.endif
+.else
+MESON_ARGS+= -Dfilewriter-flac=false -Dfilewriter-mp3=false -Dfilewriter-ogg=false
+.endif
-post-install-ADPLUG-on:
- ${INSTALL_LIB} ${WRKSRC}/src/adplug/adplug.so \
- ${STAGEDIR}${PREFIX}/lib/audacious/Input
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/src/aac/meson.build \
+ ${WRKSRC}/src/lirc/meson.build
-post-install-OPENMPT-on:
- ${INSTALL_LIB} ${WRKSRC}/src/openmpt/openmpt.so \
- ${STAGEDIR}${PREFIX}/lib/audacious/Input
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e "/^subdir('po')/d" ${WRKSRC}/meson.build
.include <bsd.port.mk>
diff --git a/multimedia/audacious-plugins/distinfo b/multimedia/audacious-plugins/distinfo
index a8d09ec1b313..a7ab95a74296 100644
--- a/multimedia/audacious-plugins/distinfo
+++ b/multimedia/audacious-plugins/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1657443742
-SHA256 (audacious-plugins-4.2.tar.bz2) = 6fa0f69c3a1041eb877c37109513ab4a2a0a56a77d9e8c13a1581cf1439a417f
-SIZE (audacious-plugins-4.2.tar.bz2) = 1947472
+TIMESTAMP = 1678125312
+SHA256 (audacious-plugins-4.3.tar.bz2) = 662ef6c8c4bd70d0f35fd1c5f08b91549b9436638b65f8a1a33956b09df89fc6
+SIZE (audacious-plugins-4.3.tar.bz2) = 1932184
diff --git a/multimedia/audacious-plugins/files/patch-src_aac_meson.build b/multimedia/audacious-plugins/files/patch-src_aac_meson.build
new file mode 100644
index 000000000000..03c51d67524c
--- /dev/null
+++ b/multimedia/audacious-plugins/files/patch-src_aac_meson.build
@@ -0,0 +1,8 @@
+--- src/aac/meson.build.orig 2023-03-05 17:51:20 UTC
++++ src/aac/meson.build
+@@ -1,4 +1,4 @@
+-faad_dep = cxx.find_library('faad', required: false)
++faad_dep = cxx.find_library('faad', dirs: ['%%LOCALBASE%%/lib'], required: false)
+ have_aac = faad_dep.found() and cxx.has_header('neaacdec.h')
+
+
diff --git a/multimedia/audacious-plugins/files/patch-src_lirc_meson.build b/multimedia/audacious-plugins/files/patch-src_lirc_meson.build
new file mode 100644
index 000000000000..2bb50e040eef
--- /dev/null
+++ b/multimedia/audacious-plugins/files/patch-src_lirc_meson.build
@@ -0,0 +1,16 @@
+--- src/lirc/meson.build.orig 2023-03-05 17:51:20 UTC
++++ src/lirc/meson.build
+@@ -1,4 +1,4 @@
+-lirc_dep = cxx.find_library('lirc', required: false)
++lirc_dep = cxx.find_library('lirc_client', dirs: ['%%LOCALBASE%%/lib'], required: false)
+ have_lirc = lirc_dep.found() and cxx.has_header('lirc/lirc_client.h')
+
+
+@@ -7,7 +7,6 @@ if have_lirc
+ 'lirc.cc',
+ dependencies: [audacious_dep, glib_dep, lirc_dep],
+ name_prefix: '',
+- link_args: ['-llirc_client'],
+ install: true,
+ install_dir: general_plugin_dir
+ )
diff --git a/multimedia/audacious-plugins/pkg-plist b/multimedia/audacious-plugins/pkg-plist
index 1e7c990c9be9..d2677c627cf8 100644
--- a/multimedia/audacious-plugins/pkg-plist
+++ b/multimedia/audacious-plugins/pkg-plist
@@ -11,38 +11,37 @@ lib/audacious/Effect/compressor.so
lib/audacious/Effect/crossfade.so
lib/audacious/Effect/crystalizer.so
lib/audacious/Effect/echo.so
-%%GTK2%%lib/audacious/Effect/ladspa.so
+%%GTK%%lib/audacious/Effect/ladspa.so
lib/audacious/Effect/mixer.so
%%SAMPLERATE%%lib/audacious/Effect/resample.so
lib/audacious/Effect/silence-removal.so
%%SPEEDPITCH%%lib/audacious/Effect/speed-pitch.so
lib/audacious/Effect/stereo.so
lib/audacious/Effect/voice_removal.so
-%%GTK2%%lib/audacious/General/alarm.so
-%%GTK2%%lib/audacious/General/albumart.so
-%%QT5%%lib/audacious/General/albumart-qt.so
-%%GTK2%%%%AOSD%%lib/audacious/General/aosd.so
+%%GTK%%lib/audacious/General/albumart.so
+%%QT%%lib/audacious/General/albumart-qt.so
+%%GTK%%%%AOSD%%lib/audacious/General/aosd.so
%%CDDA%%lib/audacious/General/cd-menu-items.so
lib/audacious/General/delete-files.so
-%%GTK2%%lib/audacious/General/gtkui.so
-%%GTK2%%lib/audacious/General/hotkey.so
+%%GTK%%lib/audacious/General/gtkui.so
+%%GTK%%lib/audacious/General/hotkey.so
%%LIRC%%lib/audacious/General/lirc.so
-%%QT5%%lib/audacious/General/lyricwiki-qt.so
+%%QT%%lib/audacious/General/lyricwiki-qt.so
%%MPRIS%%lib/audacious/General/mpris2.so
%%NOTIFY%%lib/audacious/General/notify.so
-%%GTK2%%lib/audacious/General/playlist-manager.so
-%%QT5%%lib/audacious/General/playlist-manager-qt.so
-%%QT5%%lib/audacious/General/qthotkey.so
-%%QT5%%lib/audacious/General/qtui.so
+%%GTK%%lib/audacious/General/playlist-manager.so
+%%QT%%lib/audacious/General/playlist-manager-qt.so
+%%QT%%%%QT5%%lib/audacious/General/qthotkey.so
+%%QT%%lib/audacious/General/qtui.so
%%SCROBBLER%%lib/audacious/General/scrobbler.so
-%%GTK2%%lib/audacious/General/search-tool.so
-%%QT5%%lib/audacious/General/search-tool-qt.so
-%%GTK2%%lib/audacious/General/skins.so
-%%QT5%%lib/audacious/General/skins-qt.so
-%%QT5%%lib/audacious/General/song-info-qt.so
+%%GTK%%lib/audacious/General/search-tool.so
+%%QT%%lib/audacious/General/search-tool-qt.so
+%%GTK%%lib/audacious/General/skins.so
+%%QT%%lib/audacious/General/skins-qt.so
+%%QT%%lib/audacious/General/song-info-qt.so
lib/audacious/General/song_change.so
-%%GTK2%%lib/audacious/General/statusicon.so
-%%QT5%%lib/audacious/General/statusicon-qt.so
+%%GTK%%lib/audacious/General/statusicon.so
+%%QT%%lib/audacious/General/statusicon-qt.so
%%AAC%%lib/audacious/Input/aac-raw.so
%%AMIDI%%lib/audacious/Input/amidi-plug.so
%%CDDA%%lib/audacious/Input/cdaudio-ng.so
@@ -65,19 +64,20 @@ lib/audacious/Input/xsf.so
%%FILEWRITER%%lib/audacious/Output/filewriter.so
%%JACK%%lib/audacious/Output/jack-ng.so
%%OSS%%lib/audacious/Output/oss4.so
+%%PIPEWIRE%%lib/audacious/Output/pipewire.so
%%PULSEAUDIO%%lib/audacious/Output/pulse_audio.so
-%%QT5%%lib/audacious/Output/qtaudio.so
+%%QT%%%%QT5%%lib/audacious/Output/qtaudio.so
%%SDL%%lib/audacious/Output/sdlout.so
%%SNDIO%%lib/audacious/Output/sndio-ng.so
lib/audacious/Transport/gio.so
%%NEON%%lib/audacious/Transport/neon.so
-%%GTK2%%lib/audacious/Visualization/blur_scope.so
-%%QT5%%lib/audacious/Visualization/blur_scope-qt.so
-%%GTK2%%lib/audacious/Visualization/cairo-spectrum.so
-%%QT5%%lib/audacious/Visualization/qt-spectrum.so
-%%GTK2%%%%OPENGL%%lib/audacious/Visualization/gl-spectrum.so
-%%QT5%%%%OPENGL%%lib/audacious/Visualization/gl-spectrum-qt.so
-%%QT5%%lib/audacious/Visualization/vumeter-qt.so
+%%GTK%%lib/audacious/Visualization/blur_scope.so
+%%QT%%lib/audacious/Visualization/blur_scope-qt.so
+%%GTK%%lib/audacious/Visualization/cairo-spectrum.so
+%%QT%%lib/audacious/Visualization/qt-spectrum.so
+%%GTK%%%%OPENGL%%lib/audacious/Visualization/gl-spectrum.so
+%%QT%%%%OPENGL%%lib/audacious/Visualization/gl-spectrum-qt.so
+%%QT%%lib/audacious/Visualization/vumeter-qt.so
share/audacious/Skins/Classic/balance.png
share/audacious/Skins/Classic/cbuttons.png
share/audacious/Skins/Classic/eq_ex.png
@@ -117,6 +117,101 @@ share/audacious/Skins/Classic1.3/volume.png
share/audacious/Skins/Default/cbuttons.png
share/audacious/Skins/Default/eq_ex.png
share/audacious/Skins/Default/eqmain.png
+share/audacious/Skins/Default/gtk-2.0/Arrows/arrow-down.png
+share/audacious/Skins/Default/gtk-2.0/Arrows/arrow-insens.png
+share/audacious/Skins/Default/gtk-2.0/Arrows/arrow-left.png
+share/audacious/Skins/Default/gtk-2.0/Arrows/arrow-right.png
+share/audacious/Skins/Default/gtk-2.0/Arrows/arrow-up.png
+share/audacious/Skins/Default/gtk-2.0/Buttons/button-insensitive.png
+share/audacious/Skins/Default/gtk-2.0/Buttons/button-normal.png
+share/audacious/Skins/Default/gtk-2.0/Buttons/button-prelight.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/check1.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/check2.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/check3.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/check4.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/check5.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/check6.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/option1.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/option2.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/option3.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/option4.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/option5.png
+share/audacious/Skins/Default/gtk-2.0/Check-Radio/option6.png
+share/audacious/Skins/Default/gtk-2.0/Frame-Gap/frame-gap-end.png
+share/audacious/Skins/Default/gtk-2.0/Frame-Gap/frame-gap-start.png
+share/audacious/Skins/Default/gtk-2.0/Frame-Gap/frame.png
+share/audacious/Skins/Default/gtk-2.0/Handles/handle-h.png
+share/audacious/Skins/Default/gtk-2.0/Handles/handle-v.png
+share/audacious/Skins/Default/gtk-2.0/Lines/line-h.png
+share/audacious/Skins/Default/gtk-2.0/Lines/line-v.png
+share/audacious/Skins/Default/gtk-2.0/ListHeaders/list_header-insens.png
+share/audacious/Skins/Default/gtk-2.0/ListHeaders/list_header-prelight.png
+share/audacious/Skins/Default/gtk-2.0/ListHeaders/list_header-pressed.png
+share/audacious/Skins/Default/gtk-2.0/ListHeaders/list_header.png
+share/audacious/Skins/Default/gtk-2.0/Menu-Menubar/menu.png
+share/audacious/Skins/Default/gtk-2.0/Menu-Menubar/menubar-item-active.png
+share/audacious/Skins/Default/gtk-2.0/Menu-Menubar/menubar-item.png
+share/audacious/Skins/Default/gtk-2.0/Menu-Menubar/menubar.png
+share/audacious/Skins/Default/gtk-2.0/Others/null.png
+share/audacious/Skins/Default/gtk-2.0/Others/ruler.png
+share/audacious/Skins/Default/gtk-2.0/Panel/panel-bg.png
+share/audacious/Skins/Default/gtk-2.0/ProgressBar/progressbar-horiz.png
+share/audacious/Skins/Default/gtk-2.0/ProgressBar/trough-progressbar-horiz.png
+share/audacious/Skins/Default/gtk-2.0/Range/slider-horiz-prelight.png
+share/audacious/Skins/Default/gtk-2.0/Range/slider-horiz.png
+share/audacious/Skins/Default/gtk-2.0/Range/slider-vert-prelight.png
+share/audacious/Skins/Default/gtk-2.0/Range/slider-vert.png
+share/audacious/Skins/Default/gtk-2.0/Range/trough-horizontal.png
+share/audacious/Skins/Default/gtk-2.0/Range/trough-vertical.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/scroll-thumb-horiz-pre.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/scroll-thumb-horiz.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/scroll-thumb-vert-pre.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/scroll-thumb-vert.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/slider-horiz-pre.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/slider-horiz.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/slider-vert-pre.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/slider-vert.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/stepper-down-prelight.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/stepper-down.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/stepper-left-prelight.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/stepper-left.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/stepper-right-prelight.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/stepper-right.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/stepper-up-prelight.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/stepper-up.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/trough-scrollbar-horiz.png
+share/audacious/Skins/Default/gtk-2.0/Scrollbars/trough-scrollbar-vert.png
+share/audacious/Skins/Default/gtk-2.0/Shadows/shadow-in.png
+share/audacious/Skins/Default/gtk-2.0/Shadows/shadow-out.png
+share/audacious/Skins/Default/gtk-2.0/Shadows/text-.png
+share/audacious/Skins/Default/gtk-2.0/Shadows/text-entry.png
+share/audacious/Skins/Default/gtk-2.0/Spin/spin-down-disable.png
+share/audacious/Skins/Default/gtk-2.0/Spin/spin-down-prelight.png
+share/audacious/Skins/Default/gtk-2.0/Spin/spin-down.png
+share/audacious/Skins/Default/gtk-2.0/Spin/spin-up-disable.png
+share/audacious/Skins/Default/gtk-2.0/Spin/spin-up-prelight.png
+share/audacious/Skins/Default/gtk-2.0/Spin/spin-up.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/gap-bottom-left.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/gap-bottom-right.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/gap-left-bottom.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/gap-left-top.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/gap-right-bottom.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/gap-right-top.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/gap-top-current.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/gap-top-left.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/gap-top-right.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/notebook.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/tab-bottom-active.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/tab-bottom.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/tab-left-active.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/tab-left.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/tab-right-active.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/tab-right.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/tab-top-active.png
+share/audacious/Skins/Default/gtk-2.0/Tabs/tab-top.png
+share/audacious/Skins/Default/gtk-2.0/Toolbar/toolbar.png
+share/audacious/Skins/Default/gtk-2.0/gtkrc
+share/audacious/Skins/Default/gtk-2.0/panel.rc
share/audacious/Skins/Default/main.png
share/audacious/Skins/Default/monoster.png
share/audacious/Skins/Default/nums_ex.png
@@ -125,6 +220,7 @@ share/audacious/Skins/Default/pledit.png
share/audacious/Skins/Default/pledit.txt
share/audacious/Skins/Default/posbar.png
share/audacious/Skins/Default/shufrep.png
+share/audacious/Skins/Default/skin-classic.hints
share/audacious/Skins/Default/skin.hints
share/audacious/Skins/Default/text.png
share/audacious/Skins/Default/titlebar.png
@@ -230,6 +326,7 @@ share/audacious/Skins/TinyPlayer/volume.png
%%NLS%%share/locale/pl/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/pt_PT/LC_MESSAGES/audacious-plugins.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/ru/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/si/LC_MESSAGES/audacious-plugins.mo
%%NLS%%share/locale/sk/LC_MESSAGES/audacious-plugins.mo