aboutsummaryrefslogtreecommitdiff
path: root/multimedia/audacious-plugins
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2023-03-13 21:20:50 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2023-03-13 21:20:50 +0000
commitf1eca3188595af4cdbe4c3576bc8fbad4340a721 (patch)
tree4925b8f8e133f07d7f1c5086d17bed80baf2df0e /multimedia/audacious-plugins
parent0dc71261d600a3ba5bb946b9ee0e37462ff4f70f (diff)
downloadports-f1eca3188595af4cdbe4c3576bc8fbad4340a721.tar.gz
ports-f1eca3188595af4cdbe4c3576bc8fbad4340a721.zip
multimedia/audacious-plugins: Import upstreamed build patches
- Expose OPUS option and enable it by default - Fix lame detection which enables mp3 filewriter plugin (suggested by upstream developer Thomas Lange) Obtained from: https://github.com/audacious-media-player/audacious-plugins/pull/132
Diffstat (limited to 'multimedia/audacious-plugins')
-rw-r--r--multimedia/audacious-plugins/Makefile14
-rw-r--r--multimedia/audacious-plugins/files/patch-src_aac_meson.build13
-rw-r--r--multimedia/audacious-plugins/files/patch-src_filewriter_meson.build18
-rw-r--r--multimedia/audacious-plugins/files/patch-src_lirc_meson.build14
-rw-r--r--multimedia/audacious-plugins/pkg-plist1
5 files changed, 48 insertions, 12 deletions
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index 2b8f1da7de7d..da2e020eb874 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -1,5 +1,6 @@
PORTNAME= audacious-plugins
PORTVERSION= 4.3
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= http://distfiles.audacious-media-player.org/
@@ -24,6 +25,10 @@ USES= compiler:c++11-lib gettext-tools gmake gnome iconv \
USE_GNOME= glib20 libxml2 gdkpixbuf2
USE_XORG= x11
+CONFIGURE_ENV= LIBRARY_PATH="${LOCALBASE}/lib"
+MAKE_ENV= LIBRARY_PATH="${LOCALBASE}/lib"
+MESON_ARGS= -Dconsole=false -Dmms=false -Dsoxr=false -Dcoreaudio=false
+
qt5_CONFLICTS_INSTALL= audacious-plugins-qt6 audacious-plugins-gtk2 audacious-plugins-gtk3
qt5_RUN_DEPENDS= audacious:multimedia/audacious@qt5
qt5_BUILD_DEPENDS= audacious:multimedia/audacious@qt5
@@ -45,8 +50,6 @@ gtk3_LIB_DEPENDS= libharfbuzz.so:print/harfbuzz
gtk3_RUN_DEPENDS= audacious:multimedia/audacious@gtk3
gtk3_BUILD_DEPENDS= audacious:multimedia/audacious@gtk3
-MESON_ARGS= -Dconsole=false -Dmms=false -Dsoxr=false -Dcoreaudio=false
-
.if ${FLAVOR} == qt5
MESON_ARGS+= -Dqt=true -Dqt6=false -Dgtk=false -Dgtk3=false
USES+= qt:5
@@ -68,12 +71,12 @@ PLIST_SUB= QT="@comment " QT6="@comment " GTK=""
.endif
OPTIONS_DEFINE= AAC ADPLUG AMIDI BS2B CDDA CUE FFMPEG FLAC LAME LIRC \
- MODPLUG MPG123 MPRIS NEON NLS NOTIFY OPENGL OPENMPT SAMPLERATE \
- SCROBBLER SID SNDFILE SPEEDPITCH VORBIS WAVPACK
+ MODPLUG MPG123 MPRIS NEON NLS NOTIFY OPENGL OPENMPT OPUS \
+ SAMPLERATE SCROBBLER SID SNDFILE SPEEDPITCH VORBIS WAVPACK
OPTIONS_MULTI= OUTPUT
OPTIONS_MULTI_OUTPUT= ALSA FILEWRITER JACK OSS PIPEWIRE PULSEAUDIO SDL SNDIO
OPTIONS_DEFAULT= AAC ADPLUG CDDA CUE FILEWRITER FFMPEG FLAC MPRIS \
- MPG123 NEON NLS NOTIFY OPENMPT OSS PIPEWIRE PULSEAUDIO \
+ MPG123 NEON NLS NOTIFY OPENMPT OPUS OSS PIPEWIRE PULSEAUDIO \
SCROBBLER SID VORBIS WAVPACK
OPTIONS_SUB= yes
@@ -200,6 +203,7 @@ MESON_ARGS+= -Dfilewriter-flac=false -Dfilewriter-mp3=false -Dfilewriter-ogg=fal
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/src/aac/meson.build \
+ ${WRKSRC}/src/filewriter/meson.build \
${WRKSRC}/src/lirc/meson.build
post-patch-NLS-off:
diff --git a/multimedia/audacious-plugins/files/patch-src_aac_meson.build b/multimedia/audacious-plugins/files/patch-src_aac_meson.build
index 03c51d67524c..536ee6b8e1bb 100644
--- a/multimedia/audacious-plugins/files/patch-src_aac_meson.build
+++ b/multimedia/audacious-plugins/files/patch-src_aac_meson.build
@@ -1,8 +1,15 @@
--- src/aac/meson.build.orig 2023-03-05 17:51:20 UTC
+++ src/aac/meson.build
-@@ -1,4 +1,4 @@
+@@ -1,6 +1,10 @@
-faad_dep = cxx.find_library('faad', required: false)
-+faad_dep = cxx.find_library('faad', dirs: ['%%LOCALBASE%%/lib'], required: false)
- have_aac = faad_dep.found() and cxx.has_header('neaacdec.h')
+-have_aac = faad_dep.found() and cxx.has_header('neaacdec.h')
++faad_dep = dependency('faad2', required: false)
++if not faad_dep.found()
++ faad_dep = cxx.find_library('faad', has_headers: 'neaacdec.h', required: false)
++endif
++
++have_aac = faad_dep.found()
+ if have_aac
+ shared_module('aac-raw',
diff --git a/multimedia/audacious-plugins/files/patch-src_filewriter_meson.build b/multimedia/audacious-plugins/files/patch-src_filewriter_meson.build
new file mode 100644
index 000000000000..147769b8249f
--- /dev/null
+++ b/multimedia/audacious-plugins/files/patch-src_filewriter_meson.build
@@ -0,0 +1,18 @@
+--- src/filewriter/meson.build.orig 2023-03-05 17:51:20 UTC
++++ src/filewriter/meson.build
+@@ -34,9 +34,13 @@ if get_option('filewriter-mp3')
+
+
+ if get_option('filewriter-mp3')
+- lame_dep = cxx.find_library('mp3lame', required: false)
++ lame_dep = dependency('lame', required: false)
+
+- if lame_dep.found() and cxx.has_header('lame/lame.h')
++ if not lame_dep.found()
++ lame_dep = cxx.find_library('mp3lame', has_headers: 'lame/lame.h', required: false)
++ endif
++
++ if lame_dep.found()
+ filewriter_deps += [lame_dep]
+ filewriter_srcs += ['mp3.cc']
+
diff --git a/multimedia/audacious-plugins/files/patch-src_lirc_meson.build b/multimedia/audacious-plugins/files/patch-src_lirc_meson.build
index 2bb50e040eef..0b4c2295d061 100644
--- a/multimedia/audacious-plugins/files/patch-src_lirc_meson.build
+++ b/multimedia/audacious-plugins/files/patch-src_lirc_meson.build
@@ -1,12 +1,18 @@
--- src/lirc/meson.build.orig 2023-03-05 17:51:20 UTC
+++ src/lirc/meson.build
-@@ -1,4 +1,4 @@
+@@ -1,13 +1,16 @@
-lirc_dep = cxx.find_library('lirc', required: false)
-+lirc_dep = cxx.find_library('lirc_client', dirs: ['%%LOCALBASE%%/lib'], required: false)
- have_lirc = lirc_dep.found() and cxx.has_header('lirc/lirc_client.h')
+-have_lirc = lirc_dep.found() and cxx.has_header('lirc/lirc_client.h')
++lirc_dep = dependency('lirc', required: false)
++if not lirc_dep.found()
++ lirc_dep = cxx.find_library('lirc_client', has_headers: 'lirc/lirc_client.h', required: false)
++endif
++have_lirc = lirc_dep.found()
-@@ -7,7 +7,6 @@ if have_lirc
++
+ if have_lirc
+ shared_module('lirc',
'lirc.cc',
dependencies: [audacious_dep, glib_dep, lirc_dep],
name_prefix: '',
diff --git a/multimedia/audacious-plugins/pkg-plist b/multimedia/audacious-plugins/pkg-plist
index d2677c627cf8..cdbf5e195376 100644
--- a/multimedia/audacious-plugins/pkg-plist
+++ b/multimedia/audacious-plugins/pkg-plist
@@ -52,6 +52,7 @@ lib/audacious/Input/metronom.so
%%MODPLUG%%lib/audacious/Input/modplug.so
%%ADPLUG%%lib/audacious/Input/adplug.so
%%OPENMPT%%lib/audacious/Input/openmpt.so
+%%OPUS%%lib/audacious/Input/opus.so
lib/audacious/Input/psf2.so
%%SID%%lib/audacious/Input/sid.so
%%SNDFILE%%lib/audacious/Input/sndfile.so