aboutsummaryrefslogtreecommitdiff
path: root/multimedia/avifile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-06-08 13:11:07 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-06-08 13:11:07 +0000
commitd1a6ae4207e528165b9a71b1bcb7f05de3361936 (patch)
treeee4a6118bc99baa4ee33d9451587a3aab7e7ef3b /multimedia/avifile
parent82697c520e77410e902ff017f45e980b9774e01d (diff)
downloadports-d1a6ae4207e528165b9a71b1bcb7f05de3361936.tar.gz
ports-d1a6ae4207e528165b9a71b1bcb7f05de3361936.zip
Fix build when WINE is installed.
Abort the build when GNU pth is installed. Remove the WITH_MGA knob. PR: 27961 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=43642
Diffstat (limited to 'multimedia/avifile')
-rw-r--r--multimedia/avifile/Makefile13
-rw-r--r--multimedia/avifile/files/patch-Makefile-libwin32Makefile10
-rw-r--r--multimedia/avifile/files/patch-aa2
-rw-r--r--multimedia/avifile/files/patch-videocodecMakefile10
4 files changed, 26 insertions, 9 deletions
diff --git a/multimedia/avifile/Makefile b/multimedia/avifile/Makefile
index 529dd15dca58..defce24ec892 100644
--- a/multimedia/avifile/Makefile
+++ b/multimedia/avifile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= avifile
PORTVERSION= 0.60.20010429
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://ernie.eit.uni-kl.de/avifile/ \
http://divx.euro.ru/ \
@@ -34,9 +35,6 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-win32-path=${LOCALBASE}/lib/win32 \
--enable-release --with-gnu-ld
-.if defined(WITH_MGA)
-CONFIGURE_ARGS+=--enable-mga
-.endif
PLIST_SUB= LIB_VERSION="${LIB_VERSION}"
@@ -59,10 +57,11 @@ DIFF?= /usr/bin/diff
.include <bsd.port.pre.mk>
pre-extract:
-.if !defined(WITH_MGA)
- @${ECHO_MSG} "You can enable special MGA support by building with -DWITH_MGA."
-.endif
-
+ @if [ -f ${LOCALBASE}/lib/libpth.so ]; then \
+ ${ECHO_MSG} "Error: This packet does not compile when the \
+packet 'pth' is installed.";\
+ ${FALSE};\
+ fi
do-configure:
(cd ${WRKSRC} && aclocal && ./autogen.sh &&\
${CONFIGURE_ENV} ./configure ${CONFIGURE_ARGS})
diff --git a/multimedia/avifile/files/patch-Makefile-libwin32Makefile b/multimedia/avifile/files/patch-Makefile-libwin32Makefile
new file mode 100644
index 000000000000..b4a50e254f77
--- /dev/null
+++ b/multimedia/avifile/files/patch-Makefile-libwin32Makefile
@@ -0,0 +1,10 @@
+--- plugins/libwin32/Makefile.am.orig Wed Jun 6 00:03:19 2001
++++ plugins/libwin32/Makefile.am Wed Jun 6 00:03:37 2001
+@@ -12,6 +12,6 @@
+
+ libwin32_la_LDFLAGS = -module -version-info 0:0:0
+
+-CPPFLAGS = @CPPFLAGS@ -Iloader -Iloader/wine -Ivideocodec -Iaudiodec -IDirectShow
++CPPFLAGS = -Iloader -Iloader/wine -Ivideocodec -Iaudiodec -IDirectShow @CPPFLAGS@
+
+ LIBS = @AVILIBDEPLIB@
diff --git a/multimedia/avifile/files/patch-aa b/multimedia/avifile/files/patch-aa
index bf397cb1b906..8ec08f839b93 100644
--- a/multimedia/avifile/files/patch-aa
+++ b/multimedia/avifile/files/patch-aa
@@ -7,5 +7,3 @@
-#include <SDL/SDL_keysym.h>
+#include <SDL11/SDL_keysym.h>
#endif
-
-
diff --git a/multimedia/avifile/files/patch-videocodecMakefile b/multimedia/avifile/files/patch-videocodecMakefile
new file mode 100644
index 000000000000..6d5d8b0e5d06
--- /dev/null
+++ b/multimedia/avifile/files/patch-videocodecMakefile
@@ -0,0 +1,10 @@
+--- plugins/libwin32/videocodec/Makefile.am.orig Mon Jun 4 20:47:34 2001
++++ plugins/libwin32/videocodec/Makefile.am Mon Jun 4 20:47:52 2001
+@@ -5,6 +5,6 @@
+ libvideocodec_la_SOURCES=DS_VideoDecoder.cpp VideoEncoder.cpp \
+ VideoDecoder.cpp Module.cpp VideoCodec.cpp
+
+-CPPFLAGS = @CPPFLAGS@ -I../loader -I../DirectShow
++CPPFLAGS = -I../loader -I../DirectShow @CPPFLAGS@
+
+ LIBS=