aboutsummaryrefslogtreecommitdiff
path: root/multimedia/bmp-extra-plugins/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-21 19:45:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-21 19:45:29 +0000
commit959fdf9a38e1fee6b2ed51f532b7c140d5325bdf (patch)
tree771e19f113faa9b6dba9923ca9c8ab840fded669 /multimedia/bmp-extra-plugins/Makefile
parenta124bba59cd252ba8f377abdbecdcae4e1f6747d (diff)
downloadports-959fdf9a38e1fee6b2ed51f532b7c140d5325bdf.tar.gz
ports-959fdf9a38e1fee6b2ed51f532b7c140d5325bdf.zip
Add bmp-extra-plugins, collection of plugins for Beep Media Player:
Input: musepack, mplayer General: xf86audio, status Output: crossfade, ogg, arts Visualization: blursk, minilcd, wmdiscotux PR: ports/71979 Submitted by: Jan Srzednicki <w@wrzask.pl>
Notes
Notes: svn path=/head/; revision=122085
Diffstat (limited to 'multimedia/bmp-extra-plugins/Makefile')
-rw-r--r--multimedia/bmp-extra-plugins/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/multimedia/bmp-extra-plugins/Makefile b/multimedia/bmp-extra-plugins/Makefile
new file mode 100644
index 000000000000..cb75630fe6ee
--- /dev/null
+++ b/multimedia/bmp-extra-plugins/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: bmp-extra-plugins
+# Date created: Tue Sep 21 17:09:43 CEST 2004
+# Whom: Jan Srzednicki <w@wrzask.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bmp-extra-plugins
+PORTVERSION= 0.2.2
+CATEGORIES= multimedia audio
+MASTER_SITES= http://www.t17.ikarnet.pl/~wiget/bmp-extra-plugins/download/
+
+MAINTAINER= w@wrzask.pl
+COMMENT= A collection of additional plugins for beep media player
+
+LIB_DEPENDS= beep.2:${PORTSDIR}/multimedia/beep-media-player \
+ vorbis.3:${PORTSDIR}/audio/libvorbis \
+ artsc.0:${PORTSDIR}/audio/arts
+
+USE_GNOME= gtk20 libglade2 esound
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_BZIP2= yes
+USE_LIBTOOL_VER= 15
+
+CONFIGURE_ARGS+= --with-ogg=${LOCALBASE} \
+ --with-vorbis=${LOCALBASE}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>