aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvbcut/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-03-12 04:08:20 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-03-12 04:08:20 +0000
commitf10a38b217675658e1fe39f326044f438b1b3cc7 (patch)
treeb008fd5ba54874438b4e3e416b29fde41df0c61b /multimedia/dvbcut/Makefile
parent7c60d1ddd469499f213f2aa0946e675d24cc4375 (diff)
downloadports-f10a38b217675658e1fe39f326044f438b1b3cc7.tar.gz
ports-f10a38b217675658e1fe39f326044f438b1b3cc7.zip
Fix build on gcc-based architectures:
cc1plus: error: unrecognized command line option "-std=gnu++11" While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=495420
Diffstat (limited to 'multimedia/dvbcut/Makefile')
-rw-r--r--multimedia/dvbcut/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/dvbcut/Makefile b/multimedia/dvbcut/Makefile
index 401dd6063335..3be880096dba 100644
--- a/multimedia/dvbcut/Makefile
+++ b/multimedia/dvbcut/Makefile
@@ -20,12 +20,13 @@ LIB_DEPENDS= liba52.so:audio/liba52 \
libavutil.so:multimedia/ffmpeg
RUN_DEPENDS:= ${BUILD_DEPENDS}
+USES= compiler:c++11-lang desktop-file-utils pkgconfig \
+ qmake:outsource shared-mime-info
+
USE_GITHUB= yes
GH_ACCOUNT= bernhardu
GH_PROJECT= dvbcut-deb
-USES= qmake:outsource pkgconfig desktop-file-utils shared-mime-info
-
CXXFLAGS+= -I${LOCALBASE}/include \
-I${LOCALBASE}/include/libavcodec \
-I${LOCALBASE}/include/libavformat \