aboutsummaryrefslogtreecommitdiff
path: root/multimedia/dvdauthor
diff options
context:
space:
mode:
authorPierre Beyssac <pb@FreeBSD.org>2005-03-14 13:52:41 +0000
committerPierre Beyssac <pb@FreeBSD.org>2005-03-14 13:52:41 +0000
commit7969f2c5372b2f04e20eb8952a6f9b8f8fce2b06 (patch)
tree85ec4f40efd746389a423aed34e7d0daf05ac17c /multimedia/dvdauthor
parent2ac8a5d047ea1513fe71ce9e96a0cf577d680f95 (diff)
downloadports-7969f2c5372b2f04e20eb8952a6f9b8f8fce2b06.tar.gz
ports-7969f2c5372b2f04e20eb8952a6f9b8f8fce2b06.zip
Update to 0.6.11.
PR: ports/77539 Submitted by: Phil Oleson <oz at nixil dot net>
Notes
Notes: svn path=/head/; revision=131197
Diffstat (limited to 'multimedia/dvdauthor')
-rw-r--r--multimedia/dvdauthor/Makefile9
-rw-r--r--multimedia/dvdauthor/distinfo4
-rw-r--r--multimedia/dvdauthor/files/patch-Makefile.in10
-rw-r--r--multimedia/dvdauthor/files/patch-dvdvob.c11
-rw-r--r--multimedia/dvdauthor/files/patch-readxml.c21
-rw-r--r--multimedia/dvdauthor/files/patch-subgen-image.c11
-rw-r--r--multimedia/dvdauthor/pkg-plist12
7 files changed, 7 insertions, 71 deletions
diff --git a/multimedia/dvdauthor/Makefile b/multimedia/dvdauthor/Makefile
index ba8e8aab43f3..ac17536804cb 100644
--- a/multimedia/dvdauthor/Makefile
+++ b/multimedia/dvdauthor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dvdauthor
-PORTVERSION= 0.6.10
-PORTREVISION= 5
+PORTVERSION= 0.6.11
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -48,6 +47,7 @@ LIB_DEPENDS+= fribidi.0:${PORTSDIR}/converters/fribidi
.endif
.if defined(WITH_ICONV)
USE_ICONV= yes
+CONFIGURE_ENV+= CFLAGS="-DICONV_CONV=yes"
.endif
.if defined(WITH_IMAGEMAGICK)
LIB_DEPENDS+= Magick.8:${PORTSDIR}/graphics/ImageMagick
@@ -78,11 +78,6 @@ post-install:
${MKDIR} ${PREFIX}/share/doc/dvdauthor
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dvdauthor
${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${PREFIX}/share/doc/dvdauthor
- ${INSTALL_DATA} ${WRKSRC}/lib.txt ${PREFIX}/share/doc/dvdauthor
- ${INSTALL_DATA} ${WRKSRC}/menu.txt ${PREFIX}/share/doc/dvdauthor
- for i in dvdauthor ex-title examples index languages manpages spumux; do \
- ${INSTALL_DATA} ${WRKSRC}/doc/$$i.html ${PREFIX}/share/doc/dvdauthor; \
- done
.endif
.include <bsd.port.post.mk>
diff --git a/multimedia/dvdauthor/distinfo b/multimedia/dvdauthor/distinfo
index ef555fc7adc7..e4dc2af13274 100644
--- a/multimedia/dvdauthor/distinfo
+++ b/multimedia/dvdauthor/distinfo
@@ -1,2 +1,2 @@
-MD5 (dvdauthor-0.6.10.tar.gz) = e98243cd2a12bd723680dd49536f7318
-SIZE (dvdauthor-0.6.10.tar.gz) = 240010
+MD5 (dvdauthor-0.6.11.tar.gz) = d2c45879e4cfb95d410bf603af891e07
+SIZE (dvdauthor-0.6.11.tar.gz) = 288452
diff --git a/multimedia/dvdauthor/files/patch-Makefile.in b/multimedia/dvdauthor/files/patch-Makefile.in
deleted file mode 100644
index 63813b66cb11..000000000000
--- a/multimedia/dvdauthor/files/patch-Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.in.orig Thu Jan 15 20:42:47 2004
-+++ Makefile.in Tue Jan 20 17:24:46 2004
-@@ -13,6 +13,7 @@
- FLEX=flex
-
- CPPFLAGS = -DSYSCONFDIR="\"$(sysconfdir)\""
-+LDFLAGS += -L@libdir@
- LIBS = @LIBS@ @LIBICONV@
- XML_LIBS = @XML_LIBS@
- MAGICK_LIBS = @MAGICK_LIBS@
diff --git a/multimedia/dvdauthor/files/patch-dvdvob.c b/multimedia/dvdauthor/files/patch-dvdvob.c
deleted file mode 100644
index 0d867f240e4b..000000000000
--- a/multimedia/dvdauthor/files/patch-dvdvob.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/dvdvob.c.orig Sun Mar 14 22:13:26 2004
-+++ src/dvdvob.c Wed Aug 11 19:52:52 2004
-@@ -1148,7 +1148,7 @@
- printpts(pts1);
- fprintf(stderr,"\n");
- ach->audpts[ach->numaudpts-1].pts[1]=pts0;
-- noshow:
-+ noshow:;
- }
- ach->audpts[ach->numaudpts].pts[0]=pts0;
- ach->audpts[ach->numaudpts].pts[1]=pts1;
diff --git a/multimedia/dvdauthor/files/patch-readxml.c b/multimedia/dvdauthor/files/patch-readxml.c
deleted file mode 100644
index 9c022018774a..000000000000
--- a/multimedia/dvdauthor/files/patch-readxml.c
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/readxml.c.orig Fri Mar 12 23:57:39 2004
-+++ src/readxml.c Sun Dec 5 20:19:28 2004
-@@ -221,13 +221,13 @@
- char *utf8tolocal(const char *in)
- {
- iconv_t c=get_conv();
-- int inlen=strlen(in);
-- int outlen=inlen*5;
-+ size_t inlen=strlen(in);
-+ size_t outlen=inlen*5;
- char *r=malloc(outlen+1);
- char *out=r;
-- int v;
-+ size_t v;
-
-- v=iconv(c,ICONV_CAST &in,&inlen,&out,&outlen);
-+ v=iconv(c,&in,&inlen,&out,&outlen);
- if(v==-1) {
- fprintf(stderr,"ERR: Cannot convert UTF8 string '%s': %s\n",in,strerror(errno));
- exit(1);
-
diff --git a/multimedia/dvdauthor/files/patch-subgen-image.c b/multimedia/dvdauthor/files/patch-subgen-image.c
deleted file mode 100644
index 743989f996fd..000000000000
--- a/multimedia/dvdauthor/files/patch-subgen-image.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/subgen-image.c.orig Sun Dec 19 22:38:27 2004
-+++ src/subgen-image.c Sun Dec 19 22:38:44 2004
-@@ -177,7 +177,7 @@
- p.r=pdata[x*4];
- p.g=pdata[x*4+1];
- p.b=pdata[x*4+2];
-- p.t=255-pdata[x*4+3];
-+ p.t=pdata[x*4+3];
- putpixel(s,y*s->width+x,&p);
- }
- }
diff --git a/multimedia/dvdauthor/pkg-plist b/multimedia/dvdauthor/pkg-plist
index 710625e75995..7ea886a11cf6 100644
--- a/multimedia/dvdauthor/pkg-plist
+++ b/multimedia/dvdauthor/pkg-plist
@@ -4,15 +4,9 @@ bin/dvdunauthor
bin/mpeg2desc
bin/spumux
bin/spuunmux
+share/dvdauthor/dvdauthor.xsd
+share/dvdauthor/spumux.xsd
+@dirrm share/dvdauthor
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
-%%PORTDOCS%%%%DOCSDIR%%/dvdauthor.html
-%%PORTDOCS%%%%DOCSDIR%%/ex-title.html
-%%PORTDOCS%%%%DOCSDIR%%/examples.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/languages.html
-%%PORTDOCS%%%%DOCSDIR%%/lib.txt
-%%PORTDOCS%%%%DOCSDIR%%/manpages.html
-%%PORTDOCS%%%%DOCSDIR%%/menu.txt
-%%PORTDOCS%%%%DOCSDIR%%/spumux.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%