aboutsummaryrefslogtreecommitdiff
path: root/multimedia/ffmpeg/files
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-10-21 06:50:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-10-21 06:50:49 +0000
commit84e727457fdc2975f0a263fbb4bfc22b21825f8b (patch)
treee47add3bbee702c6a79ccf6bb15c6635d9a06264 /multimedia/ffmpeg/files
parentfc92501e435eda1b9aa2b58f992259cffdd38b01 (diff)
downloadports-84e727457fdc2975f0a263fbb4bfc22b21825f8b.tar.gz
ports-84e727457fdc2975f0a263fbb4bfc22b21825f8b.zip
multimedia/ffmpeg: update to 3.4
Notable changes: - i386/amd64 now depend on NASM per https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/4f9297ac3b39 - NETCDF is now MYSOFA but the dependency doesn't exist in ports yet - SCHROEDINGER is gone per https://git.ffmpeg.org/gitweb/ffmpeg.git/commitdiff/220b24c7c9 - DRM, LIBRSVG2, LIBXML2 are new options - ABI isn't completely compatible: some structs have changed Minor cleanup: - Don't pass --disable-{in,out}dev when it's already blocked by disabled dependency - Drop redundant "Enable" from option descriptions - Switch CDIO_DESC to use Mk/bsd.options.desc.mk Changes: https://git.ffmpeg.org/gitweb/ffmpeg.git/blob/n3.4:/Changelog ABI: https://abi-laboratory.pro/tracker/timeline/ffmpeg/ PR: 223057 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=452570
Diffstat (limited to 'multimedia/ffmpeg/files')
-rw-r--r--multimedia/ffmpeg/files/patch-configure48
-rw-r--r--multimedia/ffmpeg/files/patch-libavcodec_libopenjpegdec.c33
-rw-r--r--multimedia/ffmpeg/files/patch-libavcodec_libopenjpegenc.c42
3 files changed, 3 insertions, 120 deletions
diff --git a/multimedia/ffmpeg/files/patch-configure b/multimedia/ffmpeg/files/patch-configure
index 8b2681614fea..871a5a3c7741 100644
--- a/multimedia/ffmpeg/files/patch-configure
+++ b/multimedia/ffmpeg/files/patch-configure
@@ -1,15 +1,6 @@
---- configure.orig 2017-09-12 00:51:31 UTC
+--- configure.orig 2017-10-15 15:59:36 UTC
+++ configure
-@@ -1875,6 +1875,8 @@ HEADERS_LIST="
- machine_ioctl_meteor_h
- malloc_h
- opencv2_core_core_c_h
-+ openjpeg_2_3_openjpeg_h
-+ openjpeg_2_2_openjpeg_h
- openjpeg_2_1_openjpeg_h
- openjpeg_2_0_openjpeg_h
- openjpeg_1_5_openjpeg_h
-@@ -3262,12 +3264,7 @@ target_os_default=$(tolower $(uname -s))
+@@ -3371,12 +3371,7 @@ target_os_default=$(tolower $(uname -s))
host_os=$target_os_default
# machine
@@ -23,18 +14,7 @@
cpu="generic"
intrinsics="none"
-@@ -5807,6 +5804,10 @@ enabled libopencv && { check_header opencv2/co
- enabled libopenh264 && require_pkg_config openh264 wels/codec_api.h WelsGetCodecVersion
- enabled libopenjpeg && { { check_lib openjpeg-2.1/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
- check_lib openjpeg-2.1/openjpeg.h opj_version -lopenjp2 ||
-+ { check_lib openjpeg-2.2/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
-+ check_lib openjpeg-2.2/openjpeg.h opj_version -lopenjp2 ||
-+ { check_lib openjpeg-2.3/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
-+ check_lib openjpeg-2.3/openjpeg.h opj_version -lopenjp2 ||
- { check_lib openjpeg-2.0/openjpeg.h opj_version -lopenjp2 -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
- { check_lib openjpeg-1.5/openjpeg.h opj_version -lopenjpeg -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
- { check_lib openjpeg.h opj_version -lopenjpeg -DOPJ_STATIC && add_cppflags -DOPJ_STATIC; } ||
-@@ -6295,6 +6296,9 @@ elif enabled llvm_gcc; then
+@@ -6491,6 +6486,9 @@ elif enabled llvm_gcc; then
elif enabled clang; then
check_cflags -mllvm -stack-alignment=16
check_cflags -mstack-alignment=16
@@ -44,25 +24,3 @@
check_cflags -Qunused-arguments
check_cflags -Werror=implicit-function-declaration
check_cflags -Werror=missing-prototypes
-@@ -6900,7 +6904,7 @@ exec_prefix=\${prefix}
- libdir=$libdir
- includedir=$incdir
-
--Name: $name
-+Name: ${name}${build_suffix}
- Description: $comment
- Version: $version
- Requires: $(enabled shared || echo $requires)
-@@ -6914,10 +6918,10 @@ EOF
- mkdir -p doc/examples/pc-uninstalled
- includedir=${source_path}
- [ "$includedir" = . ] && includedir="\${pcfiledir}/../../.."
-- cat <<EOF > doc/examples/pc-uninstalled/${name}-uninstalled.pc
-+ cat <<EOF > doc/examples/pc-uninstalled/${name}${build_suffix}-uninstalled.pc
- prefix=
- exec_prefix=
--libdir=\${pcfiledir}/../../../$name
-+libdir=\${pcfiledir}/../../../${name}${build_suffix}.pc
- includedir=${includedir}
-
- Name: $name
diff --git a/multimedia/ffmpeg/files/patch-libavcodec_libopenjpegdec.c b/multimedia/ffmpeg/files/patch-libavcodec_libopenjpegdec.c
deleted file mode 100644
index 0eec4b9778c7..000000000000
--- a/multimedia/ffmpeg/files/patch-libavcodec_libopenjpegdec.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- libavcodec/libopenjpegdec.c.orig 2017-09-12 00:51:33 UTC
-+++ libavcodec/libopenjpegdec.c
-@@ -34,7 +34,11 @@
- #include "internal.h"
- #include "thread.h"
-
--#if HAVE_OPENJPEG_2_1_OPENJPEG_H
-+#if HAVE_OPENJPEG_2_3_OPENJPEG_H
-+# include <openjpeg-2.3/openjpeg.h>
-+#elif HAVE_OPENJPEG_2_2_OPENJPEG_H
-+# include <openjpeg-2.2/openjpeg.h>
-+#elif HAVE_OPENJPEG_2_1_OPENJPEG_H
- # include <openjpeg-2.1/openjpeg.h>
- #elif HAVE_OPENJPEG_2_0_OPENJPEG_H
- # include <openjpeg-2.0/openjpeg.h>
-@@ -44,7 +48,7 @@
- # include <openjpeg.h>
- #endif
-
--#if HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
-+#if HAVE_OPENJPEG_2_3_OPENJPEG_H || HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
- # define OPENJPEG_MAJOR_VERSION 2
- # define OPJ(x) OPJ_##x
- #else
-@@ -429,7 +433,7 @@ static int libopenjpeg_decode_frame(AVCo
- opj_stream_set_read_function(stream, stream_read);
- opj_stream_set_skip_function(stream, stream_skip);
- opj_stream_set_seek_function(stream, stream_seek);
--#if HAVE_OPENJPEG_2_1_OPENJPEG_H
-+#if HAVE_OPENJPEG_2_3_OPENJPEG_H || HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H
- opj_stream_set_user_data(stream, &reader, NULL);
- #elif HAVE_OPENJPEG_2_0_OPENJPEG_H
- opj_stream_set_user_data(stream, &reader);
diff --git a/multimedia/ffmpeg/files/patch-libavcodec_libopenjpegenc.c b/multimedia/ffmpeg/files/patch-libavcodec_libopenjpegenc.c
deleted file mode 100644
index 4095524a8343..000000000000
--- a/multimedia/ffmpeg/files/patch-libavcodec_libopenjpegenc.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- libavcodec/libopenjpegenc.c.orig 2017-09-12 00:51:33 UTC
-+++ libavcodec/libopenjpegenc.c
-@@ -32,7 +32,11 @@
- #include "avcodec.h"
- #include "internal.h"
-
--#if HAVE_OPENJPEG_2_1_OPENJPEG_H
-+#if HAVE_OPENJPEG_2_3_OPENJPEG_H
-+# include <openjpeg-2.3/openjpeg.h>
-+#elif HAVE_OPENJPEG_2_2_OPENJPEG_H
-+# include <openjpeg-2.2/openjpeg.h>
-+#elif HAVE_OPENJPEG_2_1_OPENJPEG_H
- # include <openjpeg-2.1/openjpeg.h>
- #elif HAVE_OPENJPEG_2_0_OPENJPEG_H
- # include <openjpeg-2.0/openjpeg.h>
-@@ -42,7 +46,7 @@
- # include <openjpeg.h>
- #endif
-
--#if HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
-+#if HAVE_OPENJPEG_2_3_OPENJPEG_H || HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H || HAVE_OPENJPEG_2_0_OPENJPEG_H
- # define OPENJPEG_MAJOR_VERSION 2
- # define OPJ(x) OPJ_##x
- #else
-@@ -305,7 +309,7 @@ static av_cold int libopenjpeg_encode_in
-
- opj_set_default_encoder_parameters(&ctx->enc_params);
-
--#if HAVE_OPENJPEG_2_1_OPENJPEG_H
-+#if HAVE_OPENJPEG_2_3_OPENJPEG_H || HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H
- switch (ctx->cinema_mode) {
- case OPJ_CINEMA2K_24:
- ctx->enc_params.rsiz = OPJ_PROFILE_CINEMA_2K;
-@@ -769,7 +773,7 @@ static int libopenjpeg_encode_frame(AVCo
- opj_stream_set_write_function(stream, stream_write);
- opj_stream_set_skip_function(stream, stream_skip);
- opj_stream_set_seek_function(stream, stream_seek);
--#if HAVE_OPENJPEG_2_1_OPENJPEG_H
-+#if HAVE_OPENJPEG_2_3_OPENJPEG_H || HAVE_OPENJPEG_2_2_OPENJPEG_H || HAVE_OPENJPEG_2_1_OPENJPEG_H
- opj_stream_set_user_data(stream, &writer, NULL);
- #elif HAVE_OPENJPEG_2_0_OPENJPEG_H
- opj_stream_set_user_data(stream, &writer);