aboutsummaryrefslogtreecommitdiff
path: root/multimedia/get_iplayer
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2020-05-24 06:20:38 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2020-05-24 06:20:38 +0000
commit9be25dc4dcd5ea5bc16d946870e604a03666cdb1 (patch)
treee97a3592aa8da1259b5bf9feeb9bedb56e5ea011 /multimedia/get_iplayer
parent12b0295394dea7cf1aec21cd28368352c59d3d05 (diff)
downloadports-9be25dc4dcd5ea5bc16d946870e604a03666cdb1.tar.gz
ports-9be25dc4dcd5ea5bc16d946870e604a03666cdb1.zip
- Move to multimedia category
- Update to 3.25 - Update port description - Update WWW PR: 246558 Submitted by: Jamie Landeg-Jones <jamie@catflap.org> (maintainer) Approved by: ehaupt (mentor) Changelog: https://github.com/get-iplayer/get_iplayer/wiki/release320to329#release325
Notes
Notes: svn path=/head/; revision=536361
Diffstat (limited to 'multimedia/get_iplayer')
-rw-r--r--multimedia/get_iplayer/Makefile59
-rw-r--r--multimedia/get_iplayer/distinfo3
-rw-r--r--multimedia/get_iplayer/files/get_iplayer.in48
-rw-r--r--multimedia/get_iplayer/pkg-descr9
-rw-r--r--multimedia/get_iplayer/pkg-message8
5 files changed, 127 insertions, 0 deletions
diff --git a/multimedia/get_iplayer/Makefile b/multimedia/get_iplayer/Makefile
new file mode 100644
index 000000000000..7511d7ec7f0b
--- /dev/null
+++ b/multimedia/get_iplayer/Makefile
@@ -0,0 +1,59 @@
+# $FreeBSD$
+
+PORTNAME= get_iplayer
+PORTVERSION= 3.25
+DISTVERSIONPREFIX= v
+CATEGORIES= net multimedia
+
+MAINTAINER= jamie@catflap.org
+COMMENT= Search, index, or stream archive video from BBC iPlayer
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= p5-XML-LibXML>=0:textproc/p5-XML-LibXML \
+ p5-Mojolicious>=0:www/p5-Mojolicious \
+ p5-LWP-Protocol-https>=0:www/p5-LWP-Protocol-https \
+ p5-CGI>=0:www/p5-CGI
+
+USES= perl5 shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= get-iplayer
+USE_PERL5= run
+SHEBANG_FILES= ${PORTNAME} ${PORTNAME}.cgi
+NO_BUILD= yes
+NO_ARCH= yes
+
+USE_RC_SUBR= ${PORTNAME}
+
+USERS= get_iplayer
+GROUPS= get_iplayer
+
+SCRIPTS= ${PORTNAME} ${PORTNAME}.cgi
+PLIST_FILES= bin/${PORTNAME} ${SCRIPTS:S,^,${WWWDIR_REL}/,} \
+ man/man1/${PORTNAME}.1.gz
+
+DATADIR= ${WWWDIR}
+PORTDOCS= CHANGELOG.md README.md
+
+OPTIONS_DEFINE= DOCS FFMPEG ATOMICPARSLEY
+FFMPEG_DESC= Enable file conversion using FFmpeg
+FFMPEG_RUN_DEPENDS= ffmpeg>=0:multimedia/ffmpeg
+ATOMICPARSLEY_DESC= Enable tagging of media files
+ATOMICPARSLEY_RUN_DEPENDS= AtomicParsley>=0:multimedia/atomicparsley
+
+post-patch:
+ ${REINPLACE_CMD} -e "108,110c\\${.newline} \$$opt_cmdline->{getiplayer} = \"${PREFIX}/bin/${PORTNAME}\";" \
+ ${WRKSRC}/get_iplayer.cgi
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC}; ${INSTALL_SCRIPT} ${SCRIPTS} ${STAGEDIR}${WWWDIR})
+ ${LN} -sf ${WWWDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>
diff --git a/multimedia/get_iplayer/distinfo b/multimedia/get_iplayer/distinfo
new file mode 100644
index 000000000000..59d9df1cdf13
--- /dev/null
+++ b/multimedia/get_iplayer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1589850320
+SHA256 (get-iplayer-get_iplayer-v3.25_GH0.tar.gz) = 2ae278a812494d6289224e6d347c8761ec815ad84f4daf41fd0a4f62832b7d63
+SIZE (get-iplayer-get_iplayer-v3.25_GH0.tar.gz) = 146625
diff --git a/multimedia/get_iplayer/files/get_iplayer.in b/multimedia/get_iplayer/files/get_iplayer.in
new file mode 100644
index 000000000000..51a9a046f6c0
--- /dev/null
+++ b/multimedia/get_iplayer/files/get_iplayer.in
@@ -0,0 +1,48 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: get_iplayer
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf or /etc/rc.conf.local to
+# enable get_iplayer:
+# get_iplayer_enable (bool): Set to "NO" by default.
+# get_iplayer_chdir (string): Set to "/tmp" by default; this is where
+# downloaded files are stored. Should be writable
+# by get_iplayer user.
+# get_iplayer_flags (string): Set to "" by default.
+# get_iplayer_bind_port (number): Set to 9370 by default.
+# get_iplayer_listen_address (IP address): Set to 127.0.0.1 by default.
+#
+##########################################################
+## WARNING:
+## For security reasons, do NOT set get_iplayer_bind_port
+## unless your box is firewalled to allow only connections
+## from your local subnet. It is safest to use SSH
+## tunnelling if remote access is needed.
+##########################################################
+
+
+. /etc/rc.subr
+
+name=get_iplayer
+rcvar=get_iplayer_enable
+desc="Server for fetching programs from iplayer and PVR functionality"
+
+load_rc_config $name
+
+: ${get_iplayer_enable:=NO}
+: ${get_iplayer_bind_port=9370}
+: ${get_iplayer_listen_address=127.0.0.1}
+: ${get_iplayer_chdir=/tmp}
+
+command=/usr/sbin/daemon
+command_args="-f -u ${name} -p /var/run/${name}/${name}.pid %%WWWDIR%%/${name}.cgi -p ${get_iplayer_bind_port} -l ${get_iplayer_listen_address} --getiplayer %%WWWDIR%%/${name}"
+procname=/usr/bin/perl
+pidfile=/var/run/${name}/${name}.pid
+
+start_precmd="install -d -o ${name} -m755 /var/run/${name}"
+
+run_rc_command "$1"
diff --git a/multimedia/get_iplayer/pkg-descr b/multimedia/get_iplayer/pkg-descr
new file mode 100644
index 000000000000..c26d00726ef6
--- /dev/null
+++ b/multimedia/get_iplayer/pkg-descr
@@ -0,0 +1,9 @@
+This tool allows you to search, index, and record/stream:
+
+BBC iPlayer TV - up to 5200 kbps HD 720p H.264 / Quicktime / MP4
+BBC iPlayer Radio - up to 340 kbps AAC / MP4
+BBC iPlayer TV subtitles - SubRip / srt
+
+None of the above content is /protected/ by DRM. get_iplayer cannot remove DRM.
+
+WWW: https://github.com/get-iplayer/get_iplayer
diff --git a/multimedia/get_iplayer/pkg-message b/multimedia/get_iplayer/pkg-message
new file mode 100644
index 000000000000..4de1c521f914
--- /dev/null
+++ b/multimedia/get_iplayer/pkg-message
@@ -0,0 +1,8 @@
+[
+{ type: install
+ message: <<EOM
+You must be in the UK, or use a UK proxy, to gain
+access to most iPlayer content.
+EOM
+}
+]