aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gmerlin
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /multimedia/gmerlin
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=366215
Diffstat (limited to 'multimedia/gmerlin')
-rw-r--r--multimedia/gmerlin/Makefile12
-rw-r--r--multimedia/gmerlin/files/patch-configure43
2 files changed, 14 insertions, 41 deletions
diff --git a/multimedia/gmerlin/Makefile b/multimedia/gmerlin/Makefile
index 29938955c238..cc00202d0805 100644
--- a/multimedia/gmerlin/Makefile
+++ b/multimedia/gmerlin/Makefile
@@ -29,7 +29,7 @@ USE_LDCONFIG= yes
INSTALL_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib `pkg-config --libs gtk+-x11-2.0`
+LIBS+= -L${LOCALBASE}/lib
INFO= gmerlin
@@ -69,21 +69,21 @@ TIFF_CONFIGURE_OFF= --disable-libtiff
BROKEN= Fails to build with new libcdio
.endif
+.if !(${OPSYS} == FreeBSD && ${OSVERSION} < 900033)
+LDFLAGS+= -Wl,--add-needed
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
'/LIBS/s|-ldl || ; \
- s|^LDFLAGS="|&$${LDFLAGS} | ; \
s|-DGTK_DISABLE_DEPRECATED|| ; \
- s|-lpthread|-pthread| ; \
s|-O3.*-ffast-math||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
's|^texinfo_|#texinfo_|g' ${WRKSRC}/doc/Makefile.in
@${REINPLACE_CMD} -e \
's|ln -sf $$(DESTDIR)|ln -sf |' ${WRKSRC}/icons/Makefile.in
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-ldl||g ; \
- s|-lpthread|-pthread|g ; \
- /^LIBS = /s|$$| @LIBINTL@ -pthread|g'
+ 's|-ldl||g'
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/multimedia/gmerlin/files/patch-configure b/multimedia/gmerlin/files/patch-configure
index 68fe98404f42..e57101f87781 100644
--- a/multimedia/gmerlin/files/patch-configure
+++ b/multimedia/gmerlin/files/patch-configure
@@ -8,42 +8,15 @@
enable_libvisual
enable_libcdio
enable_musicbrainz
-@@ -6324,7 +6325,7 @@
- rm -rf conftest*
- ;;
+@@ -13247,7 +13248,7 @@
+ GMERLIN_DEP_RPATH=""
+ fi
+
+-LDFLAGS="$GMERLIN_DEP_RPATH"
++LDFLAGS="$LDFLAGS $GMERLIN_DEP_RPATH"
+
+
--x86_64-*kfreebsd*-gnu|x86_64-*linux*|ppc*-*linux*|powerpc*-*linux*| \
-+amd64-*freebsd*|x86_64-*kfreebsd*-gnu|x86_64-*linux*|ppc*-*linux*|powerpc*-*linux*| \
- s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
- # Find out which ABI we are using.
- echo 'int i;' > conftest.$ac_ext
-@@ -6336,7 +6337,7 @@
- case `/usr/bin/file conftest.o` in
- *32-bit*)
- case $host in
-- x86_64-*kfreebsd*-gnu)
-+ amd64-*freebsd*|x86_64-*kfreebsd*-gnu)
- LD="${LD-ld} -m elf_i386_fbsd"
- ;;
- x86_64-*linux*)
-@@ -6355,7 +6356,7 @@
- ;;
- *64-bit*)
- case $host in
-- x86_64-*kfreebsd*-gnu)
-+ amd64-*freebsd*|x86_64-*kfreebsd*-gnu)
- LD="${LD-ld} -m elf_x86_64_fbsd"
- ;;
- x86_64-*linux*)
-@@ -11240,7 +11241,7 @@
- for ac_word in $CC $CFLAGS $CPPFLAGS $LDFLAGS; do
- if test -n "$ac_prev"; then
- case $ac_word in
-- i?86 | x86_64 | ppc | ppc64)
-+ amd64 | i?86 | x86_64 | ppc | ppc64)
- if test -z "$ac_arch" || test "$ac_arch" = "$ac_word"; then
- ac_arch=$ac_word
- else
@@ -15396,9 +15397,9 @@
V4LCONVERT_REQUIRED="0.5.7"
have_v4lconvert=false