aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-ffmpeg80
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-08 18:41:51 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-08 18:41:51 +0000
commit82f6c6c5d3dbb0575500f7915ac7d9055c93724e (patch)
treee7e9b907d6584cff641952bae3b2e9a61b2a03d3 /multimedia/gstreamer-ffmpeg80
parent8271a0716fe43ac7a1f8153de34b7a9fb25917f4 (diff)
downloadports-82f6c6c5d3dbb0575500f7915ac7d9055c93724e.tar.gz
ports-82f6c6c5d3dbb0575500f7915ac7d9055c93724e.zip
Update to 0.8.1. See
Notes
Notes: svn path=/head/; revision=115673
Diffstat (limited to 'multimedia/gstreamer-ffmpeg80')
-rw-r--r--multimedia/gstreamer-ffmpeg80/Makefile13
-rw-r--r--multimedia/gstreamer-ffmpeg80/distinfo4
-rw-r--r--multimedia/gstreamer-ffmpeg80/files/extra-patch-gst-libs_ext_ffmpeg_libavformat_nut.c12
-rw-r--r--multimedia/gstreamer-ffmpeg80/files/patch-ext_ffmpeg_gstffmpegcodecmap.c31
-rw-r--r--multimedia/gstreamer-ffmpeg80/files/patch-gst-libs_ext_ffmpeg_libavformat_mov.c18
-rw-r--r--multimedia/gstreamer-ffmpeg80/files/patch-ltmain.sh51
-rw-r--r--multimedia/gstreamer-ffmpeg80/pkg-plist4
7 files changed, 42 insertions, 91 deletions
diff --git a/multimedia/gstreamer-ffmpeg80/Makefile b/multimedia/gstreamer-ffmpeg80/Makefile
index c97d9e41dc70..f491a1829c0a 100644
--- a/multimedia/gstreamer-ffmpeg80/Makefile
+++ b/multimedia/gstreamer-ffmpeg80/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.0
-PORTREVISION= 2
+PORTVERSION= 0.8.1
CATEGORIES= multimedia
MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-ffmpeg/
PKGNAMESUFFIX= -ffmpeg
@@ -24,19 +23,22 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack \
gnomeprefix
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
PLIST_SUB= \
VERSION="${GST_VERSION}"
-INSTALLS_SHLIB= yes
PKG_CONFIG?="${LOCALBASE}/bin/pkg-config"
GST_VERSION=${PORTVERSION:C/..$//}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-gst-libs_ext_ffmpeg_libavformat_nut.c
+.endif
+
post-patch:
@${REINPLACE_CMD} -E -e \
's|make|${GMAKE}|' \
@@ -44,6 +46,7 @@ post-patch:
post-install:
# register plugins
- -@${X11BASE}/bin/gst-register-${GST_VERSION} 2>/dev/null
+ -@${X11BASE}/bin/gst-register-${GST_VERSION} \
+ --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
.include <bsd.port.post.mk>
diff --git a/multimedia/gstreamer-ffmpeg80/distinfo b/multimedia/gstreamer-ffmpeg80/distinfo
index a31890d573c2..17fa35c12ee9 100644
--- a/multimedia/gstreamer-ffmpeg80/distinfo
+++ b/multimedia/gstreamer-ffmpeg80/distinfo
@@ -1,2 +1,2 @@
-MD5 (gst-ffmpeg-0.8.0.tar.bz2) = 26dd962c37e886cbc3be167680a44ee4
-SIZE (gst-ffmpeg-0.8.0.tar.bz2) = 1558194
+MD5 (gst-ffmpeg-0.8.1.tar.bz2) = f020b9f394fec2712964cd11ac46b43d
+SIZE (gst-ffmpeg-0.8.1.tar.bz2) = 1590668
diff --git a/multimedia/gstreamer-ffmpeg80/files/extra-patch-gst-libs_ext_ffmpeg_libavformat_nut.c b/multimedia/gstreamer-ffmpeg80/files/extra-patch-gst-libs_ext_ffmpeg_libavformat_nut.c
new file mode 100644
index 000000000000..1c1fc628e17a
--- /dev/null
+++ b/multimedia/gstreamer-ffmpeg80/files/extra-patch-gst-libs_ext_ffmpeg_libavformat_nut.c
@@ -0,0 +1,12 @@
+--- gst-libs/ext/ffmpeg/libavformat/nut.c.orig Wed Apr 14 20:38:02 2004
++++ gst-libs/ext/ffmpeg/libavformat/nut.c Sun Jul 11 18:14:19 2004
+@@ -59,6 +59,9 @@
+ #define FLAG_FULL_PTS 4
+ #define FLAG_KEY_FRAME 32
+
++// UINT64_MAX isn't defined on FreeBSD 4.x borrow it from 5.x
++#define UINT64_MAX 0xffffffffffffffffULL
++
+ typedef struct {
+ uint8_t flags;
+ uint8_t stream_id_plus1;
diff --git a/multimedia/gstreamer-ffmpeg80/files/patch-ext_ffmpeg_gstffmpegcodecmap.c b/multimedia/gstreamer-ffmpeg80/files/patch-ext_ffmpeg_gstffmpegcodecmap.c
deleted file mode 100644
index 18025870866b..000000000000
--- a/multimedia/gstreamer-ffmpeg80/files/patch-ext_ffmpeg_gstffmpegcodecmap.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- ext/ffmpeg/gstffmpegcodecmap.c.orig Fri Feb 6 15:29:09 2004
-+++ ext/ffmpeg/gstffmpegcodecmap.c Fri Feb 6 15:40:14 2004
-@@ -44,13 +44,13 @@
- "width", G_TYPE_INT, context->width, \
- "height", G_TYPE_INT, context->height, \
- "framerate", G_TYPE_DOUBLE, 1. * context->frame_rate / \
-- context->frame_rate_base, \
-+ context->frame_rate_base , \
- ##props, NULL) \
- : \
- gst_caps_new_simple (mimetype, \
- "width", GST_TYPE_INT_RANGE, 16, 4096, \
- "height", GST_TYPE_INT_RANGE, 16, 4096, \
-- "framerate", GST_TYPE_DOUBLE_RANGE, 0., G_MAXDOUBLE, \
-+ "framerate", GST_TYPE_DOUBLE_RANGE, 0., G_MAXDOUBLE , \
- ##props, NULL)
-
- /* same for audio - now with channels/sample rate
-@@ -60,10 +60,10 @@
- (context != NULL) ? \
- gst_caps_new_simple (mimetype, \
- "rate", G_TYPE_INT, context->sample_rate, \
-- "channels", G_TYPE_INT, context->channels, \
-+ "channels", G_TYPE_INT, context->channels , \
- ##props, NULL) \
- : \
-- gst_caps_new_simple (mimetype, \
-+ gst_caps_new_simple (mimetype , \
- ##props, NULL)
-
- /* Convert a FFMPEG codec ID and optional AVCodecContext
diff --git a/multimedia/gstreamer-ffmpeg80/files/patch-gst-libs_ext_ffmpeg_libavformat_mov.c b/multimedia/gstreamer-ffmpeg80/files/patch-gst-libs_ext_ffmpeg_libavformat_mov.c
new file mode 100644
index 000000000000..c57e76de3f6b
--- /dev/null
+++ b/multimedia/gstreamer-ffmpeg80/files/patch-gst-libs_ext_ffmpeg_libavformat_mov.c
@@ -0,0 +1,18 @@
+--- gst-libs/ext/ffmpeg/libavformat/mov.c.orig Fri Apr 30 20:41:45 2004
++++ gst-libs/ext/ffmpeg/libavformat/mov.c Sun Jul 11 18:21:15 2004
+@@ -998,6 +998,7 @@
+ else if( st->codec.codec_tag == MKTAG( 'm', 'p', '4', 'a' ))
+ {
+ /* Handle mp4 audio tag */
++ MOV_atom_t a = { format, url_ftell(pb), size - (20 + 20 + 8) };
+ get_be32(pb); /* version */
+ get_be32(pb);
+ st->codec.channels = get_be16(pb); /* channels */
+@@ -1006,7 +1007,6 @@
+ st->codec.sample_rate = get_be16(pb); /* sample rate, not always correct */
+ get_be16(pb);
+ c->mp4=1;
+- MOV_atom_t a = { format, url_ftell(pb), size - (20 + 20 + 8) };
+ mov_read_default(c, pb, a);
+ /* Get correct sample rate from extradata */
+ if(st->codec.extradata_size) {
diff --git a/multimedia/gstreamer-ffmpeg80/files/patch-ltmain.sh b/multimedia/gstreamer-ffmpeg80/files/patch-ltmain.sh
deleted file mode 100644
index e780774b31b4..000000000000
--- a/multimedia/gstreamer-ffmpeg80/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Thu Feb 26 13:28:02 2004
-+++ ltmain.sh Fri Feb 27 02:56:45 2004
-@@ -1280,7 +1280,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1290,8 +1290,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3000,6 +3008,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this ...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5428,10 +5439,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/gstreamer-ffmpeg80/pkg-plist b/multimedia/gstreamer-ffmpeg80/pkg-plist
index 1cdb885303a5..82aec7a0bbca 100644
--- a/multimedia/gstreamer-ffmpeg80/pkg-plist
+++ b/multimedia/gstreamer-ffmpeg80/pkg-plist
@@ -1,3 +1,3 @@
-@unexec %D/bin/gst-register 2>/dev/null || true
+@exec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true
lib/gstreamer-%%VERSION%%/libgstffmpeg.so
-@exec %D/bin/gst-register 2>/dev/null || true
+@unexec %D/bin/gst-register --gst-registry=%D/share/gnome/cache/gstreamer-%%VERSION%%/registry.xml 2>/dev/null || true