aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-bad
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /multimedia/gstreamer-plugins-bad
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Notes
Notes: svn path=/head/; revision=209647
Diffstat (limited to 'multimedia/gstreamer-plugins-bad')
-rw-r--r--multimedia/gstreamer-plugins-bad/Makefile4
-rw-r--r--multimedia/gstreamer-plugins-bad/files/patch-add_missing_files195
-rw-r--r--multimedia/gstreamer-plugins-bad/files/patch-ext-spc-gstspc.h11
-rw-r--r--multimedia/gstreamer-plugins-bad/pkg-plist64
4 files changed, 41 insertions, 233 deletions
diff --git a/multimedia/gstreamer-plugins-bad/Makefile b/multimedia/gstreamer-plugins-bad/Makefile
index aeeb5bf4112e..e9451e173993 100644
--- a/multimedia/gstreamer-plugins-bad/Makefile
+++ b/multimedia/gstreamer-plugins-bad/Makefile
@@ -3,7 +3,7 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/multimedia/gstreamer-plugins-bad/Makefile,v 1.7 2006/09/14 21:25:16 ahze Exp $
+# $MCom: ports/multimedia/gstreamer-plugins-bad/Makefile,v 1.11 2008/03/19 14:05:35 ahze Exp $
#
PORTREVISION= 2
@@ -25,8 +25,6 @@ PLIST_SUB= VERSION="${GST_VERSION}"
NO_GSTREAMER_COMMON= yes
PLIST= ${.CURDIR}/pkg-plist
-USE_GL= yes
-
do-build:
.for dir in ${BAD_GST_DIRS}
@(cd ${BUILD_WRKSRC}/${dir}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
diff --git a/multimedia/gstreamer-plugins-bad/files/patch-add_missing_files b/multimedia/gstreamer-plugins-bad/files/patch-add_missing_files
deleted file mode 100644
index 89a06596412d..000000000000
--- a/multimedia/gstreamer-plugins-bad/files/patch-add_missing_files
+++ /dev/null
@@ -1,195 +0,0 @@
-diff -urN /dev/null ext/ivorbis/vorbisdec.h
---- /dev/null Wed Dec 31 18:00:00 1969
-+++ ext/ivorbis/vorbisdec.h Thu Jul 5 14:49:17 2007
-@@ -0,0 +1,87 @@
-+/* -*- c-basic-offset: 2 -*-
-+ * GStreamer
-+ * Copyright (C) <1999> Erik Walthinsen <omega@cse.ogi.edu>
-+ *
-+ * Tremor modifications <2006>:
-+ * Chris Lord, OpenedHand Ltd. <chris@openedhand.com>, http://www.o-hand.com/
-+ *
-+ * This library is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU Library General Public
-+ * License as published by the Free Software Foundation; either
-+ * version 2 of the License, or (at your option) any later version.
-+ *
-+ * This library is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * Library General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU Library General Public
-+ * License along with this library; if not, write to the
-+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-+ * Boston, MA 02111-1307, USA.
-+ */
-+
-+
-+#ifndef __GST_IVORBIS_DEC_H__
-+#define __GST_IVORBIS_DEC_H__
-+
-+
-+#include <gst/gst.h>
-+#include <tremor/ivorbiscodec.h>
-+
-+G_BEGIN_DECLS
-+
-+#define GST_TYPE_IVORBIS_DEC \
-+ (gst_ivorbis_dec_get_type())
-+#define GST_IVORBIS_DEC(obj) \
-+ (G_TYPE_CHECK_INSTANCE_CAST((obj),GST_TYPE_IVORBIS_DEC,GstIVorbisDec))
-+#define GST_IVORBIS_DEC_CLASS(klass) \
-+ (G_TYPE_CHECK_CLASS_CAST((klass),GST_TYPE_IVORBIS_DEC,GstIVorbisDecClass))
-+#define GST_IS_IVORBIS_DEC(obj) \
-+ (G_TYPE_CHECK_INSTANCE_TYPE((obj),GST_TYPE_IVORBIS_DEC))
-+#define GST_IS_IVORBIS_DEC_CLASS(klass) \
-+ (G_TYPE_CHECK_CLASS_TYPE((klass),GST_TYPE_IVORBIS_DEC))
-+
-+typedef struct _GstIVorbisDec GstIVorbisDec;
-+typedef struct _GstIVorbisDecClass GstIVorbisDecClass;
-+
-+/**
-+ * GstIVorbisDec:
-+ *
-+ * Opaque data structure.
-+ */
-+struct _GstIVorbisDec {
-+ GstElement element;
-+
-+ GstPad * sinkpad;
-+ GstPad * srcpad;
-+
-+ vorbis_dsp_state vd;
-+ vorbis_info vi;
-+ vorbis_comment vc;
-+ vorbis_block vb;
-+ guint64 granulepos;
-+
-+ gboolean initialized;
-+
-+ GList *queued;
-+
-+ GstSegment segment;
-+ gboolean discont;
-+
-+ GstClockTime cur_timestamp; /* only used with non-ogg container formats */
-+ GstClockTime prev_timestamp; /* only used with non-ogg container formats */
-+
-+ GList *pendingevents;
-+ GstTagList *taglist;
-+};
-+
-+struct _GstIVorbisDecClass {
-+ GstElementClass parent_class;
-+};
-+
-+GType gst_ivorbis_dec_get_type(void);
-+
-+G_END_DECLS
-+
-+#endif /* __GST_IVORBIS_DEC_H__ */
-diff -urN /dev/null ext/ivorbis/vorbisenc.h
---- /dev/null Wed Dec 31 18:00:00 1969
-+++ ext/ivorbis/vorbisenc.h Thu Jul 5 14:49:43 2007
-@@ -0,0 +1,100 @@
-+/* GStreamer
-+ * Copyright (C) <1999> Erik Walthinsen <omega@cse.ogi.edu>
-+ *
-+ * This library is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU Library General Public
-+ * License as published by the Free Software Foundation; either
-+ * version 2 of the License, or (at your option) any later version.
-+ *
-+ * This library is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-+ * Library General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU Library General Public
-+ * License along with this library; if not, write to the
-+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-+ * Boston, MA 02111-1307, USA.
-+ */
-+
-+
-+#ifndef __VORBISENC_H__
-+#define __VORBISENC_H__
-+
-+
-+#include <gst/gst.h>
-+
-+#include <tremor/ivorbiscodec.h>
-+
-+#ifdef __cplusplus
-+extern "C" {
-+#endif /* __cplusplus */
-+
-+#define GST_TYPE_VORBISENC \
-+ (vorbisenc_get_type())
-+#define GST_VORBISENC(obj) \
-+ (G_TYPE_CHECK_INSTANCE_CAST((obj),GST_TYPE_VORBISENC,VorbisEnc))
-+#define GST_VORBISENC_CLASS(klass) \
-+ (G_TYPE_CHECK_CLASS_CAST((klass),GST_TYPE_VORBISENC,VorbisEncClass))
-+#define GST_IS_VORBISENC(obj) \
-+ (G_TYPE_CHECK_INSTANCE_TYPE((obj),GST_TYPE_VORBISENC))
-+#define GST_IS_VORBISENC_CLASS(klass) \
-+ (G_TYPE_CHECK_CLASS_TYPE((klass),GST_TYPE_VORBISENC))
-+
-+typedef struct _VorbisEnc VorbisEnc;
-+typedef struct _VorbisEncClass VorbisEncClass;
-+
-+struct _VorbisEnc {
-+ GstElement element;
-+
-+ GstPad *sinkpad,
-+ *srcpad;
-+
-+ ogg_stream_state os; /* take physical pages, weld into a logical
-+ stream of packets */
-+ ogg_page og; /* one Ogg bitstream page. Vorbis packets are inside */
-+ ogg_packet op; /* one raw packet of data for decode */
-+
-+ vorbis_info vi; /* struct that stores all the static vorbis bitstream
-+ settings */
-+ vorbis_comment vc; /* struct that stores all the user comments */
-+
-+ vorbis_dsp_state vd; /* central working state for the packet->PCM decoder */
-+ vorbis_block vb; /* local working space for packet->PCM decode */
-+
-+ gboolean eos;
-+
-+ gboolean managed;
-+ gint bitrate;
-+ gint min_bitrate;
-+ gint max_bitrate;
-+ gfloat quality;
-+ gboolean quality_set;
-+ gint serial;
-+
-+ gint channels;
-+ gint frequency;
-+
-+ guint64 samples_in;
-+ guint64 bytes_out;
-+
-+ GstCaps *metadata;
-+
-+ gboolean setup;
-+ gboolean flush_header;
-+ gchar *last_message;
-+};
-+
-+struct _VorbisEncClass {
-+ GstElementClass parent_class;
-+};
-+
-+GType vorbisenc_get_type(void);
-+
-+
-+#ifdef __cplusplus
-+}
-+#endif /* __cplusplus */
-+
-+
-+#endif /* __VORBISENC_H__ */
diff --git a/multimedia/gstreamer-plugins-bad/files/patch-ext-spc-gstspc.h b/multimedia/gstreamer-plugins-bad/files/patch-ext-spc-gstspc.h
deleted file mode 100644
index 3badde73c573..000000000000
--- a/multimedia/gstreamer-plugins-bad/files/patch-ext-spc-gstspc.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ext/spc/gstspc.h.orig Fri Dec 22 18:28:46 2006
-+++ ext/spc/gstspc.h Fri Dec 22 18:28:15 2006
-@@ -22,7 +22,7 @@
-
- #include <gst/gst.h>
-
--#include <openspc.h>
-+#include <OpenSPC.h>
-
- G_BEGIN_DECLS
-
diff --git a/multimedia/gstreamer-plugins-bad/pkg-plist b/multimedia/gstreamer-plugins-bad/pkg-plist
index 7c5297596d0c..01f03630769f 100644
--- a/multimedia/gstreamer-plugins-bad/pkg-plist
+++ b/multimedia/gstreamer-plugins-bad/pkg-plist
@@ -13,18 +13,21 @@ lib/gstreamer-%%VERSION%%/libgstcdxaparse.so
lib/gstreamer-%%VERSION%%/libgstdeinterlace.a
lib/gstreamer-%%VERSION%%/libgstdeinterlace.la
lib/gstreamer-%%VERSION%%/libgstdeinterlace.so
-lib/gstreamer-%%VERSION%%/libgstequalizer.a
-lib/gstreamer-%%VERSION%%/libgstequalizer.la
-lib/gstreamer-%%VERSION%%/libgstequalizer.so
+lib/gstreamer-%%VERSION%%/libgstdvdspu.a
+lib/gstreamer-%%VERSION%%/libgstdvdspu.la
+lib/gstreamer-%%VERSION%%/libgstdvdspu.so
+lib/gstreamer-%%VERSION%%/libgstfestival.a
+lib/gstreamer-%%VERSION%%/libgstfestival.la
+lib/gstreamer-%%VERSION%%/libgstfestival.so
lib/gstreamer-%%VERSION%%/libgstfilter.a
lib/gstreamer-%%VERSION%%/libgstfilter.la
lib/gstreamer-%%VERSION%%/libgstfilter.so
+lib/gstreamer-%%VERSION%%/libgstflvdemux.a
+lib/gstreamer-%%VERSION%%/libgstflvdemux.la
+lib/gstreamer-%%VERSION%%/libgstflvdemux.so
lib/gstreamer-%%VERSION%%/libgstfreeze.a
lib/gstreamer-%%VERSION%%/libgstfreeze.la
lib/gstreamer-%%VERSION%%/libgstfreeze.so
-lib/gstreamer-%%VERSION%%/libgstglimagesink.a
-lib/gstreamer-%%VERSION%%/libgstglimagesink.la
-lib/gstreamer-%%VERSION%%/libgstglimagesink.so
lib/gstreamer-%%VERSION%%/libgsth264parse.a
lib/gstreamer-%%VERSION%%/libgsth264parse.la
lib/gstreamer-%%VERSION%%/libgsth264parse.so
@@ -34,12 +37,15 @@ lib/gstreamer-%%VERSION%%/libgstinterleave.so
lib/gstreamer-%%VERSION%%/libgstmodplug.a
lib/gstreamer-%%VERSION%%/libgstmodplug.la
lib/gstreamer-%%VERSION%%/libgstmodplug.so
+lib/gstreamer-%%VERSION%%/libgstmpeg4videoparse.a
+lib/gstreamer-%%VERSION%%/libgstmpeg4videoparse.la
+lib/gstreamer-%%VERSION%%/libgstmpeg4videoparse.so
+lib/gstreamer-%%VERSION%%/libgstmpegtsparse.a
+lib/gstreamer-%%VERSION%%/libgstmpegtsparse.la
+lib/gstreamer-%%VERSION%%/libgstmpegtsparse.so
lib/gstreamer-%%VERSION%%/libgstmpegvideoparse.a
lib/gstreamer-%%VERSION%%/libgstmpegvideoparse.la
lib/gstreamer-%%VERSION%%/libgstmpegvideoparse.so
-lib/gstreamer-%%VERSION%%/libgstmultifile.a
-lib/gstreamer-%%VERSION%%/libgstmultifile.la
-lib/gstreamer-%%VERSION%%/libgstmultifile.so
lib/gstreamer-%%VERSION%%/libgstmve.a
lib/gstreamer-%%VERSION%%/libgstmve.la
lib/gstreamer-%%VERSION%%/libgstmve.so
@@ -49,6 +55,9 @@ lib/gstreamer-%%VERSION%%/libgstnsf.so
lib/gstreamer-%%VERSION%%/libgstnuvdemux.a
lib/gstreamer-%%VERSION%%/libgstnuvdemux.la
lib/gstreamer-%%VERSION%%/libgstnuvdemux.so
+lib/gstreamer-%%VERSION%%/libgstrawparse.a
+lib/gstreamer-%%VERSION%%/libgstrawparse.la
+lib/gstreamer-%%VERSION%%/libgstrawparse.so
%%I386%%lib/gstreamer-%%VERSION%%/libgstreal.a
%%I386%%lib/gstreamer-%%VERSION%%/libgstreal.la
%%I386%%lib/gstreamer-%%VERSION%%/libgstreal.so
@@ -61,30 +70,30 @@ lib/gstreamer-%%VERSION%%/libgstrfbsrc.so
lib/gstreamer-%%VERSION%%/libgstrtpmanager.a
lib/gstreamer-%%VERSION%%/libgstrtpmanager.la
lib/gstreamer-%%VERSION%%/libgstrtpmanager.so
-lib/gstreamer-%%VERSION%%/libgstspectrum.a
-lib/gstreamer-%%VERSION%%/libgstspectrum.la
-lib/gstreamer-%%VERSION%%/libgstspectrum.so
+lib/gstreamer-%%VERSION%%/libgstsdpelem.a
+lib/gstreamer-%%VERSION%%/libgstsdpelem.la
+lib/gstreamer-%%VERSION%%/libgstsdpelem.so
+lib/gstreamer-%%VERSION%%/libgstselector.a
+lib/gstreamer-%%VERSION%%/libgstselector.la
+lib/gstreamer-%%VERSION%%/libgstselector.so
lib/gstreamer-%%VERSION%%/libgstspeed.a
lib/gstreamer-%%VERSION%%/libgstspeed.la
lib/gstreamer-%%VERSION%%/libgstspeed.so
-lib/gstreamer-%%VERSION%%/libgstswitch.a
-lib/gstreamer-%%VERSION%%/libgstswitch.la
-lib/gstreamer-%%VERSION%%/libgstswitch.so
+lib/gstreamer-%%VERSION%%/libgstspeexresample.a
+lib/gstreamer-%%VERSION%%/libgstspeexresample.la
+lib/gstreamer-%%VERSION%%/libgstspeexresample.so
+lib/gstreamer-%%VERSION%%/libgststereo.a
+lib/gstreamer-%%VERSION%%/libgststereo.la
+lib/gstreamer-%%VERSION%%/libgststereo.so
lib/gstreamer-%%VERSION%%/libgsttta.a
lib/gstreamer-%%VERSION%%/libgsttta.la
lib/gstreamer-%%VERSION%%/libgsttta.so
-lib/gstreamer-%%VERSION%%/libgstvideoparse.a
-lib/gstreamer-%%VERSION%%/libgstvideoparse.la
-lib/gstreamer-%%VERSION%%/libgstvideoparse.so
lib/gstreamer-%%VERSION%%/libgstvideosignal.a
lib/gstreamer-%%VERSION%%/libgstvideosignal.la
lib/gstreamer-%%VERSION%%/libgstvideosignal.so
lib/gstreamer-%%VERSION%%/libgstvmnc.a
lib/gstreamer-%%VERSION%%/libgstvmnc.la
lib/gstreamer-%%VERSION%%/libgstvmnc.so
-lib/gstreamer-%%VERSION%%/libgstxingheader.a
-lib/gstreamer-%%VERSION%%/libgstxingheader.la
-lib/gstreamer-%%VERSION%%/libgstxingheader.so
lib/gstreamer-%%VERSION%%/libgsty4menc.a
lib/gstreamer-%%VERSION%%/libgsty4menc.la
lib/gstreamer-%%VERSION%%/libgsty4menc.so
@@ -94,20 +103,27 @@ lib/libgstapp-%%VERSION%%.so
lib/libgstapp-%%VERSION%%.so.0
share/locale/af/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/az/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/bg/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/cs/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/da/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/en_GB/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/es/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/fi/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/hu/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/it/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/ky/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/nb/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/or/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/pl/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/pt_BR/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/sk/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/sq/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/sr/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/sv/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/uk/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
share/locale/vi/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
+share/locale/zh_CN/LC_MESSAGES/gst-plugins-bad-%%VERSION%%.mo
@dirrmtry include/gstreamer-%%VERSION%%/gst/app
-@dirrmtry include/gstreamer-%%VERSION%%/gst
-@dirrmtry include/gstreamer-%%VERSION%%
-@dirrm lib/gstreamer-%%VERSION%%
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky