aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gstreamer-plugins-core
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-04 07:30:14 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-04 07:30:14 +0000
commit21a719b1d7397fd7d86cd970361f87b1186d859d (patch)
treee24d581ad836ee024c82e836e27f0fa636a97800 /multimedia/gstreamer-plugins-core
parent77bbd44ebb3091231bd342c51f2080aac2d5ab02 (diff)
downloadports-21a719b1d7397fd7d86cd970361f87b1186d859d.tar.gz
ports-21a719b1d7397fd7d86cd970361f87b1186d859d.zip
- add a knob, WITHOUT_DVD, to disable dvd plugins
Notes
Notes: svn path=/head/; revision=130326
Diffstat (limited to 'multimedia/gstreamer-plugins-core')
-rw-r--r--multimedia/gstreamer-plugins-core/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/multimedia/gstreamer-plugins-core/Makefile b/multimedia/gstreamer-plugins-core/Makefile
index c02906679221..84861f3d1f46 100644
--- a/multimedia/gstreamer-plugins-core/Makefile
+++ b/multimedia/gstreamer-plugins-core/Makefile
@@ -23,13 +23,26 @@ GST_DIR= lib/gstreamer-${PORTVERSION}
PLIST_FILES= ${GST_DIR}/.gstreamer-plugins-core.keep
# Audio plugins
-USE_GSTREAMER+= a52dec mad vorbis
+USE_GSTREAMER+= mad vorbis
# Graphics plugins
USE_GSTREAMER+= libpng
# Multimedia plugins
-USE_GSTREAMER+= ffmpeg dts dvd xvid
+USE_GSTREAMER+= ffmpeg xvid
+
+.if !defined(WITHOUT_DVD)
+# Audio plugins
+USE_GSTREAMER+= a52dec
+
+# Multimedia plugins
+USE_GSTREAMER+= dts dvd
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Disable DVD plugins by defining WITHOUT_DVD"
+ @${ECHO_MSG} ""
do-install:
if [ ! -d ${PREFIX}/${GST_DIR} ]; then \